Can't connect iPhone 4S

Discussion in 'ASUS AC Routers & Adapters' started by Zarley Z, Jan 25, 2013.

  1. Zarley Z

    Zarley Z New Around Here

    Joined:
    Jan 25, 2013
    Messages:
    2
    Hello everyone,

    New to the forums and could use some help. I just purchased this router, set it up, works great/fast, BUT I'm having trouble connecting my iPhone 4S. I initially had it connected day 1, but upon arriving home from work on day 2, the iPhone was unable to join the 2.4Ghz network. All other connections are fine (LAN, wireless laptop, etc). I'm hoping this doesn't turn into a perpetual need to reboot/reset the router. Does anyone have any suggestions for solving this problem? Thanks in advance.
     
  2. Log in / Register to remove this ad

  3. canuckle

    canuckle Regular Contributor

    Joined:
    Oct 7, 2012
    Messages:
    161
    Location:
    Canada
    Try changing the length of the passphrase.
     
  4. Zarley Z

    Zarley Z New Around Here

    Joined:
    Jan 25, 2013
    Messages:
    2
    It's actually a hidden network with no passphrase. I just reset the network settings on the iPhone and tried connecting with success. I'll have to see if it maintains connection this time around. If the connection drops again, I'll be back for suggestions, thanks!
     
  5. canuckle

    canuckle Regular Contributor

    Joined:
    Oct 7, 2012
    Messages:
    161
    Location:
    Canada
    How did you make out Z? What I discovered with several Apple products is that sometimes 10 or 13 character passphrases don't work, no idea why, lol. Seemed to be more of a problem with my E4200.
     

Share This Page