Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Ext3 permissions problem with router

Discussion in 'ASUS N Routers & Adapters' started by infamous_pb, Jan 1, 2013.

  1. infamous_pb

    infamous_pb Occasional Visitor

    Joined:
    Dec 27, 2012
    Messages:
    29
    Although I didn't really want to format my USB HDD to ext3, I did so (from NTFS) per everyone's recommendations. I installed Ext2Fsd so that I can see ext3 in Windows 7. With my USB HDD plugged directly to my Desktop, I was able to create folders and moved all my files over. When I connect the USB HDD to the RT-N66U Router, I can see all my files, mapped my drive, and I can create folders that are not in any other folder (I can create folders in the root directory). However, inside already existing folders, I cannot move or create folders - It says "You need permission to perform this action." How do I fix this? I was able to create folders within other folders when the USB HDD is plugged directly into the desktop. What happened?

    Any help would be appreciated.
     
  2. infamous_pb

    infamous_pb Occasional Visitor

    Joined:
    Dec 27, 2012
    Messages:
    29
    Ok cool. I finally figured it out. Tricky...

    In case you experience permissions problems in Windows 7 on an ext3 hard drive, do this:
    - In the router settings, click on the USB Application and go to the Network Place (Samba) tab.
    - Click "Share with account"
    - From Windows Explorer, manually type in your router/network name (usually \\(then name of the router)
    - Right Click on one of the folders causing permissions problems, and go to properties.
    - Click on the security tab.
    - Click advance
    - Under permissions, click "Everyone" and click "change permissions"
    - Click "Everyone" again and click "edit"
    - Check the box that says "Full Control" and click OK and Apply...
    - Go back into the USB Application within the router settings
    - Click on the Network Place (Samba) and switch it back to Share Without Account

    Now you have no more nasty permissions and can read, write, and create folders.
     
  3. infamous_pb

    infamous_pb Occasional Visitor

    Joined:
    Dec 27, 2012
    Messages:
    29
    Well, I thought I totally fixed it but it seems it only fixes the folders in the root directory, but not the subdirectories. Even when I try to do the same exact thing, but when I give it Full Control and select Apply to: This Folder, Subfolders, and Files it takes "full control" away and gives me "special" permissions. It only works if I individually go to each and every folder and apply these settings to each folder. Anyone know why it won't give me full control permissions on subfolders too? I got way to many subfolders to do this to.
    Surely I cant be the only one dealing with this...
     

Share This Page