Getting ATT Microcell to work behind TPLink ER5120 router

Discussion in 'Routers' started by hiroprotagonist, Jan 24, 2013.

  1. hiroprotagonist

    hiroprotagonist New Around Here

    Jan 23, 2013
    I have an ER5120 router and an AT&T 3G Microcell, and I cannot seem to figure out the best way to get the Microcell connected to the network.

    I have been able to get the Microcell working on a regular Netgear home router, so I know it works behind a router. That particular router didn't require any configuration, it just worked.

    The issue is that when it's connected to the ER5120, the Microcell shows the constant blinking of the cell network icon (bottom one), and won't register a handset.

    Here is what I have done so far to try and get it working:

    (1) Microcell has a DHCP reserved address

    (2) Router has Virtual Server ports open for that IP address: 123, 443, 4500, 500

    (3) Router has Firewall IP-Mac binding set for Microcell MAC / IP

    (4) ARP Spoof is on / off. Didnt make a difference.

    (5) Router has Firewall -> Access Control -> Services enabled with same ports / services as listed in Virtual Server.


    I'll admit, the router is new and I don't know everything about it yet. But I assumed that's all it needed to have the Microcell work behind the router. Hopefully I'm missing something simple.

    Thanks for anyone that might be able to provide some guidance.
  2. Log in / Register to remove this ad

  3. sfx2000

    sfx2000 Part of the Furniture

    Aug 11, 2011
    San Diego, CA

    If the AT&T 3G MicroCell is not working after connected to the router/gateway, first try the basic troubleshooting steps contained in the User Guide. If the 3G MicroCell still will not connect to the AT&T network (as indicated by a continuous blinking 3G light), then use the following instructions to check the router settings and change them, as needed. Please contact the router manufacturer or the ISP provider to obtain assistance with configuring the router settings.

    Normally, just plugging the 3G MicroCell into the router/gateway is all that is required. However, sometimes router/gateway settings have been changed or the 3G MicroCell will not connect properly. This section will show how to change the settings for some popular modems/routers to enable the 3G MicroCell to connect successfully.


    NOTE: Please be advised that the router manufacture or the ISP provider will not provide support for AT&T 3G MicroCell, but they can assist with configuring the router settings.

    - DHCP is on
    - Data is not restricted from passing through ports 4500 and 500 (AKA Port Blocking).
    - MTU size is set to 1492
    - MAC address filtering is either turned off or allowing the MAC address of the AT&T 3G MicroCell
    - IPSec Pass-Through is Enabled
    - Block Fragmented Packets is Disabled

    If using multiple routers, the 3G MicoCell must be connected to the first router connected to the broadband modem

    If the 3G MicroCell is connected to a router that is connected to a modem and both the router and the modem have NAT (Network Address Translation) enabled, disable NAT either in the router or the modem.

    Ensure the modem / router is using the latest software (firmware). Please see the manufacturer's documentation.

    TCP/UDP Ports

    NOTE: All ports listed need to be configured for inbound and outbound connections.

    123/UDP: NTP timing (NTP traffic)
    443/TCP: Https over TLS/SSL for provisioning and management traffic
    4500/UDP: IPSec NAT Traversal (for all signaling, data, voice traffic)
    500/UDP: IPSec Phase 1 prior to NAT detection (after NAT detection, 4500/UDP is used)
    4500/UDP: After NAT detection, 4500/UDP is used

    Also look here --
  4. hiroprotagonist

    hiroprotagonist New Around Here

    Jan 23, 2013
    This is all good info to have compiled for the device. Thank you.

    I think my question might be specific to this router, since I'm still learning my way around it. I believe I addressed the port issues correctly, but have I missed another area of the router that those need to be defined?

    I don't have the ability to uncheck the box for Fragmented Packets. That box is greyed out. I'm wondering why that is. (Router -> Firewall -> Attack Defense)

    I also don't seem to find the IPSEC passthrough option in the router.

    Now, funny enough, with all this reconfiguring and rebooting of the Microcell, it's lost GPS lock. So now I need to move it around it get that resolved. :mad:

    Last edited: Jan 24, 2013
  5. Butchfoote

    Butchfoote New Around Here

    Aug 2, 2013
    Same Problem with ASUS n66u

    Just like this poster. ATT microcell worked great with no config changes on WRT54G. Upgraded to ASUS n66u. Microcell doesn't work with new router, though it does successfully acquire local ip address. The long list of att suggested changes cannot all be made in the n66u either. Some yes, some no.

    It would be nice to have someone that knew these newer routers help us understand why the WRT modems from 8 years ago worked out of the box and the new 'high end' ones today aren't functional with the microcell.
  6. slyderz

    slyderz New Around Here

    May 31, 2013
    I have an n66u and it works fine out of the box with the latest firmware. All I did to mine was forward ports 500 and 4500 to get mms texts to send.
  7. CaptainSTX

    CaptainSTX Very Senior Member

    May 2, 2012

    When I was having problems with my micro cell I just put it in the DMZ. I don't think there is a huge security issue doing so, but just in case use a strong password.

    While I don't think the problems I had were related to port forwarding I got tired of tech support people from AT&T (dedicated support for micro cell and most of the people were quite knowledgeable ) having me futz with various port forwarding setting so to rule that out as a problem I just put the micro cell in the DMZ. The micro cell is working well so I have never bothered taking it out of the DMZ.

Share This Page