Network Connections Disappear - ASUS RT-N66U

Discussion in 'Asuswrt-Merlin' started by gbguy71, Jan 4, 2013.

  1. gbguy71

    gbguy71 Occasional Visitor

    Joined:
    Dec 28, 2012
    Messages:
    19
    Location:
    Northern CA
    I'm guessing that this is a problem with the ASUS/Broadcom drivers, but I can't find anything specific on this forum so I thought I'd ask.

    Periodically I lose the connection to the router from my laptops. This is 2.4Ghz, N protocol. (I haven't checked the 5Ghz connections). No SSID is broadcast and there is nothing in the router's log to indicate that anything went wrong.

    Sometimes the connection reestablishes itself and sometimes I have to reboot the router to get things going.

    Is this a known problem? Is there anything I can do to make things better? Is there any debugging advice (not at the code level :))?

    Whoops! Forgot to say I'm on build 3.0.0.4.260.21

    TIA
     
    Last edited: Jan 4, 2013
  2. Log in / Register to remove this ad

  3. KevTech

    KevTech Senior Member

    Joined:
    Feb 27, 2012
    Messages:
    402
    Location:
    United States
    Have you tried to see what happens if you do not hide your SSID?

    Really no reason to not broadcast and some devices will have issues if you do not broadcast.
     
  4. gbguy71

    gbguy71 Occasional Visitor

    Joined:
    Dec 28, 2012
    Messages:
    19
    Location:
    Northern CA
    KevTech,
    Thanks for the reply. I'm not sure the SSID broadcast makes any difference at all. It works for weeks at a time while broadcasting the SSID. The receiving devices are exactly the same (two laptops and a desktop).

    I'd heard somewhere that the ASUS wireless drivers had been buggy in the past. I just wanted to confirm/deny their stability issues.
     
  5. RMerlin

    RMerlin Part of the Furniture

    Joined:
    Apr 14, 2012
    Messages:
    14,683
    Location:
    Canada
    Wireless stability will always vary a lot between people, because there is a lot of factors involved: local interference, the Wireless client connecting, etc...

    Try the usual recommendations: static channel, limit it to 20 MHz on the 2.4 GHz band, etc...
     
  6. gbguy71

    gbguy71 Occasional Visitor

    Joined:
    Dec 28, 2012
    Messages:
    19
    Location:
    Northern CA
    Merlin,
    Thanks for the input! Since I'm basically a noob are there any other "usual recommendations"?

    (BTW - I "DID" have 20/40 MHz and auto channel)

     
  7. mikeg

    mikeg Senior Member

    Joined:
    Sep 8, 2012
    Messages:
    326
    Location:
    Sweden
    Did your problem got solved or do you still have issues ?
    There is a setting under the 2.4 GHz band Professional which you could try otherwise :
    Enhanced interference management : Enable or Disable to see what setting is best for you.


     
  8. gbguy71

    gbguy71 Occasional Visitor

    Joined:
    Dec 28, 2012
    Messages:
    19
    Location:
    Northern CA
    Mike,
    Thanks for the tip. The problem is intermittent, so I don't know if it is fixed or not (insert suitable emoticon here).

    What makes it especially difficult is that I have no idea what caused the problem. Everything but the WAN was working. So I'll just keep trying things until the problem appears to be fixed. Your suggestion, if needed, will be the next thing to try.

     
  9. jerry6

    jerry6 Senior Member

    Joined:
    Jan 24, 2010
    Messages:
    383
    Location:
    Montreal
    I f you're using windows in windows power settings , go to advanced wireless adapter settings set to maximum performance
    And in device manager > network adapters find your card > properties power management , make sure let this computer turn off this device to save power is not checked .
    Not sure if it will help but have had no disconnects since setting
     
  10. gbguy71

    gbguy71 Occasional Visitor

    Joined:
    Dec 28, 2012
    Messages:
    19
    Location:
    Northern CA
    Jerry,
    Thanks for the tips! I looked into them. In my case the advanced wireless adapter setting was already in maximum performance, as my laptop was plugged in at the time and max power would have been the plan in place. I wasn't aware of this option, so thanks again. (I should mention that my wireless outage was not confined to a single computer. All my 2.4GHz devices were out).

    The power management on my adapter, which I also wasn't aware of, wasn't the issue. When my laptop's wireless adapter is turned off I get a big icon that displays on my screen. I was using the laptop at the time the connection was lost and my wireless adapter was turned on.

    I'm wistfully hoping that some day there would be log entry on the router or client that would tell you exactly why the connection dropped. But then the log would probably be so verbose that the devices would be spending all their time logging :)

     
  11. TonyH

    TonyH Very Senior Member

    Joined:
    Feb 19, 2012
    Messages:
    1,084
    Location:
    Calgary AB Canada
    Hi,
    You know that kitchen MW oven can interfere with 2.4GHz signal. When MW oven is on it can knock off the connection. I hope this is not your situation. My wife's family room laptop loses connection every time MW oven in the kitchen is on. Her laptop is on 5GHz only now.
     
    Last edited: Jan 5, 2013
  12. gbguy71

    gbguy71 Occasional Visitor

    Joined:
    Dec 28, 2012
    Messages:
    19
    Location:
    Northern CA
    Tony,
    Thanks. I tried to think of something else that was happening in the house when the connection dropped. However, the last most noticeable event occurred when nothing else (apparently) was going on.
     
  13. RMerlin

    RMerlin Part of the Furniture

    Joined:
    Apr 14, 2012
    Messages:
    14,683
    Location:
    Canada
    The choice of 2.4 GHz for wifi was a pretty bad one in hindsights. The same band can interfere with cordless phones (that's why I only buy DECT 6.0 phones myself), Bluetooth, microwave ovens... That's why the industry is slowly shifting to the 5 GHz band, which will resolve a lot of interference issues.
     

Share This Page