Remote NFS mount onto Freenas

Discussion in 'General NAS Discussion' started by phreak, Feb 21, 2013.

  1. phreak

    phreak New Around Here

    Joined:
    Feb 21, 2013
    Messages:
    1
    Hi there,

    I posted this question to the Freenas forum but as of yet they have not been able to help me.
    The situation is this. I currently have a ClearOS box running my sites main file server. But as I want to move to setting permissions based on AD users I thought I would try out Freenas. I have managed to get my data on there for the most part and share it. However, on a seperate NAS server is some old archive data that needs to be in the same area for reference. No new data is going to be copied onto it or from it.
    So what I need to do it mount this share onto my Freenas server.
    I achieved this by using the following command.

    mount_nfs 10.10.10.1:/share /mnt/sharepath

    But the only problem is that mount gets lost when the server is rebooted. I wondered if there was any way to make this mount stick. I tried adding it to /etc/fstab but that file seems to get regenerated every time you reboot so non of my changes ever stick in there.

    Is there any way to do what I need?

    I also tried to Smbfs mount it with the following command.

    mount_smbfs -N -I 10.10.10.1 -W workgroup //user@remote_system/share /path/to/local/mount

    But to do that you need to put in a password for access and again, if I edit and put in those user details into /etc/nsmb.conf then that seems to get wiped on reboot.

    Any help is greatly appreciated.
     
  2. travalon

    travalon New Around Here

    Joined:
    Apr 29, 2013
    Messages:
    1
    I don't know the answer but i might suggest the freeS forums.
     

Share This Page