Use custom DNS and not my ISP's DNS

Discussion in 'Asuswrt-Merlin' started by rlcronin, Jan 17, 2013.

  1. rlcronin

    rlcronin Regular Contributor

    Joined:
    Sep 14, 2010
    Messages:
    104
    I want to always use OpenDNS. I've configured the primary OpenDNS server on my DHCP client configuration page. My clients report that they're using that server and 192.168.1.1 as their DNS servers. The router does have my ISP's two DNS servers listed on the Internet Status page. I have observed that my clients are only using the OpenDNS server *sometimes* (by going to welcome.opendns.com and 1 minute being told that I am using OpenDNS and then going there again a few minutes later and being told I am *not* using OpenDNS).

    I presume this is because the client has both the OpenDNS server address and the router address as DNS servers (i.e. when the query goes to the router's address, the router is sending it off to my ISP and when that response comes back first, it gets used in preference to the one from OpenDNS?).

    I just want to always use OpenDNS and never my ISP's DNS. How can I make that happen? Is there a way to configure DNS IP addresses in the router that will always be used instead of the ones it gets from my ISP?
    --
    bc
     
  2. Log in / Register to remove this ad

  3. r.rebergen

    r.rebergen New Around Here

    Joined:
    Jan 18, 2013
    Messages:
    6
    I assume your setup is incorrect. You need to configure the OpenDNS DNS servers on the WAN page. Every client within the network then needs to connect to your router's IP for DNS requests. I think the mixup is caused by your ISP's DNS adresses.
    In my case this is set up as described and works flawless!
     
    Last edited: Jan 18, 2013
  4. rlcronin

    rlcronin Regular Contributor

    Joined:
    Sep 14, 2010
    Messages:
    104
    D'oh! Ok, this was caused by me not understanding the meaning of the "Connect to DNS server automatically" option on the WAN page. I had noticed there was no place to manually specify DNS servers on that page. It just never dawned on me that I had to uncheck that option to get the server fields to appear. Thanks for the nudge ...
    --
    bc
     

Share This Page