Why no USB 3.0 for the RT-AC66U?

Discussion in 'ASUS AC Routers & Adapters' started by Takoru, Feb 20, 2013.

  1. Takoru

    Takoru Occasional Visitor

    Joined:
    Feb 20, 2013
    Messages:
    11
    Hello,

    I like my RT-AC66U so far, but I just don't understand why it lacks of USB 3.0.

    Is there any reason, why USB 2.0 was used instead of USB 3.0? Even the much cheaper RT-N65U has it.

    It's frustrating to just have USB 2.0 in 2013 for a highend-router. :(
     
  2. Log in / Register to remove this ad

  3. RMerlin

    RMerlin Part of the Furniture

    Joined:
    Apr 14, 2012
    Messages:
    13,048
    Location:
    Canada
    Because at the time, the Broadcom chip didn't support USB 3.0. That was only added with a new chip that Broadcom released later on.
     
  4. Takoru

    Takoru Occasional Visitor

    Joined:
    Feb 20, 2013
    Messages:
    11
    Thanks for the answer Merlin. :)
     
  5. buddee

    buddee New Around Here

    Joined:
    Jun 27, 2011
    Messages:
    3
    Not only that, but why would you really want a USB 3.0 port on a router anyhow? As it stands, a USB 2.0 port doesn't get full USB 2.0 speeds on a consumer router anyhow, why would USB 3.0 be any different?

    And last but not least, the best reason why not to have USB 3.0 ports on a wireless router: http://www.intel.com/content/www/us...al-bus/usb3-frequency-interference-paper.html

    USB 3.0 has alot of interference within the 2.4 band.
     
  6. Takoru

    Takoru Occasional Visitor

    Joined:
    Feb 20, 2013
    Messages:
    11
    Well, I'm even more happy with USB 2.0 then.

    I didn't know, that USB 3.0 has interferences with 2.4 band. I won't blame Asus about the missing USB 3.0 from now on. :D
     
  7. Mangix

    Mangix Occasional Visitor

    Joined:
    Feb 9, 2013
    Messages:
    18
  8. buddee

    buddee New Around Here

    Joined:
    Jun 27, 2011
    Messages:
    3
    Perhaps you jumped the gun on something you don't know works for sure..? From the link you posted, the OP just bought the cable and hasn't even posted test results thereof.
     

Share This Page