2.4Ghz and 5Ghz connection inconsistent with smart connect rules.

peterpan

New Around Here
I have some problems with my 2.4GHz and 5Ghz bands.
It seems that the smart connect rules do not help at all the clients roaming between the 2.4GHz and 5Ghz bands.

I have one main router and two aiMesh nodes. The mesh nodes have the standard ASUS firmware, whereas the main router as the merlin firmware.
When my router and aiMesh nodes reboot, all clients connect to 2.4GHz. This is because the 2.4GHz is the first one to be started.
However, none of the clients switches to 5GHz, even under optimal conditions. The only way I have to make clients connect to 5GHz, is to manually change a setting in the smart connect rule (Something which as a very small impact, like -1dBm in the RSSI steering policy), and apply. The wifi restarts and clients which are in range connect indeed to 5GHz once again.

All the 3 devices reboot every day once a day. This means that every day I have to change a small setting in the smart connect rule, in order to make the clients connect to the 5GHz band.
Here is an overview of the smart connect rule settings && and the settings on the wireless tab:

Screenshot 2022-02-27 at 15.00.24.png


Screenshot 2022-02-27 at 15.28.01.png


In the professional settings tab (wifi --> professional), I also set the roaming assitant of the 2.4GHz to disconnect clients who have a dBM of less than -76, in hope that the clients connected to 2.4GHz and which are in range of the 5GHz band are disconnected.

I have already used pretty much any combination of settings in the smart connect rule and in the professional tab settings of the wifi section, but nothing seems to solve the problem.
I have always had this problem, since the very beginning when I acquired the routers. Also, before I had ASUS merlin installed on the aiMesh nodes and not just on the main router. I decided to re-install the standard ASUS firmware on the nodes only to see if the problem would be solved, but it did not help.

There is a huge speed difference between 2.4GHz and 5GHz bands, and hence I would like the clients to use as much as possible the 5GHz band.

One idea I have to kinda fix this issue, is to automatically change the smart connect rules settings (a minor settings like explained above), so that the clients reconnect to the 5Ghz. But I cannot seem to find a command, or option with which I could change smart connect rules and apply them via a terminal SSH. If this would be possible, I would just schedule a script to be executed not long after the routers reboot.
This is also a hack and I would prefer to solve this issue instead.

In my old routers, which were not ASUS, the 2.4GHz/5GHz roaming worked just fine, so I know this is not related to the clients.
I have three wifi access points enabled.
2.4GHz
- Guest network
- Normal network
5GHz
- Normal network.
All three devices are the RT-AX68U model. One is the garage, another one in the 1st flooer and the last one in th 3th floor of the house. The nodes are connected via ethernet backhaul to the main router.

Could someone please help me out with this? Please note that I have already several posts on this forum about similar issues. I have been facing this issue for about 2 months now.
 

bbunge

Part of the Furniture
Set the 2.4 GHz to 20 MHz and the 5 GHz to 20, 40, 80, 160 MHz. If some of your clients do not like WPA2/WPA3-Personal set up a guest WIFI for them with just WPA2. As for the roaming assistant, they are disabled by default in Merlin. As for the other WIFI settings, default is always a great starting point. Disabling WPS is encouraged as it could be a security concern. There is no real reason to disable the 11b. In most neighborhoods the 2.4 GHz channels are pretty well filled up with routers that choose whatever channel they want to choose. That is one reason I use auto channel and my router seems to do a good job picking the least crowded channel. I set the 5 GHz on auto with 20, 40, 80, 160 MHz and it runs mostly in the lower UNII channels on 80 MHz until one of my AX clients connects then, if RADAR cleared, it switched to 160 MHz. Works very well for me (right now I am running Merlin 386.5 beta 1).
Trust your router to choose the best channel and bandwidth!
 

Tech9

Part of the Furniture
All the 3 devices reboot every day once a day.

Why? This is actually hurting the performance. The routers have to re-learn your environment every day.

Here is an overview of the smart connect rule settings && and the settings on the wireless tab:

Perhaps it's messed up because of 2.4GHz band set @40MHz wide channel and 5GHz band set @20MHz.

Set the 2.4 GHz to 20 MHz and the 5 GHz to 20, 40, 80, 160 MHz.

There is no 160MHz with RT-AX68U.
 

Deldarius

Occasional Visitor
You have the Greater/Less setting for the STA Selection Policy reversed. Try these settings as a template and fine tune the dBM to suit:
Smart Connect settings.png
 

peterpan

New Around Here
I am currently trying different things based on your feedback. I will keep you posted when I have something meaningful to share.
 

peterpan

New Around Here
Here are the tips that worked fine for me
  1. From bbunge
    1. Set the 2.4 GHz to 20 MHz and the 5 GHz to 20, 40, 80, 160 MHz
  2. From Deldarius
    1. You have the Greater/Less setting for the STA Selection Policy reversed. Try these settings as a template and fine tune the dBM to suit...
  3. From Tech9
    1. Why? This is actually hurting the performance. The routers have to re-learn your environment every day.
I am still not able to get 5GHz when the routers are automatically reset, but it sufficient to activate an deactivate the smart connect rule to trigger it.
Thank you all for the tips and your time.
 

Deldarius

Occasional Visitor
As Tech9 has asked earlier, why are you rebooting the network daily? That is pure overkill and a great way to burnout equipment.
If there is something that is only fixed by a daily reboot, you have a much bigger issue than AiMesh.

Leave it be. Quit poking bugbears.
 

peterpan

New Around Here
@Deldarius I am no longer doing that. That was actually one of the tips I took into consideration to solve the problem. I reboot my devices now every week.
What I meant was that when the devices are rebooted, I still face the same problem sometimes. That it is.
 

Deldarius

Occasional Visitor
Why do you feel the need to reboot even once a week? Unless you have some gear that gets grouchy if it is up too long, once a month should be fine, or even more infrequently.
 

Deldarius

Occasional Visitor
Have you thought about running Merlin on the nodes?

By getting slow, how much is the speed drop?
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top