1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

384.13 OpenVPN & DDNS

Discussion in 'Asuswrt-Merlin' started by Pedsteruk, Nov 9, 2019.

  1. Pedsteruk

    Pedsteruk Occasional Visitor

    Joined:
    May 31, 2017
    Messages:
    10
    RT-AC68U - Merlin 384.13

    Had this working in the past but noticed (likely after an update as I don’t use VPN that often) that my VPN was not working.

    Router and ASUS who is shows DDNS as working and resolving correct IP. So I tried to re export the OpenVPN client config.

    This is when I see that it’s not picking up the DDNS name in the exported config and instead using the current WAN IP which is not expected.

    Please can someone tell me how to make this use the DDNS or confirm this is a bug that will be fixed in future update.

    Thanks.
     
  2. Martineau

    Martineau Part of the Furniture

    Joined:
    Jul 8, 2012
    Messages:
    2,370
    Location:
    UK
    Whilst this can be frustrating, the exported clientX.ovpn file may legitimately contain a static IP (rather than a DDNS name e.g. in private WAN IP/multiple-NAT environments), so personally I don't believe it is a bug.

    In fact this very recent (2weeks old) post VPN instructions for a newbie by @elorimer explicitly states

    upload_2019-11-9_11-26-21.png
     
    dave14305 likes this.
  3. martinr

    martinr Part of the Furniture

    Joined:
    Nov 27, 2014
    Messages:
    2,206
    Location:
    Manchester, United Kingdom
  4. Pedsteruk

    Pedsteruk Occasional Visitor

    Joined:
    May 31, 2017
    Messages:
    10
    Ok thanks. Perhaps better term is change in behaviour rather than bug, as it used to pickup the DDNS address if set. There doesn’t seem to be a way to Opt for this in the settings.

    I’ve manually updated the address in the file now.

    Much appreciated.
     
    Last edited: Nov 9, 2019
  5. martinr

    martinr Part of the Furniture

    Joined:
    Nov 27, 2014
    Messages:
    2,206
    Location:
    Manchester, United Kingdom
    Happened to me the other day. Pretty sure the way I fixed it was:

    Using my Windows laptop,
    1. Exported the .ovpn config file to my desktop.

    2. Opened the .ovpn comfig file using Notepad++

    3. In the Edit section made sure that EOL was set to Unix formatting.

    4. Changed the IP address to my DDNS address. Then saved the file. Re-opened the file in Notepad++ to confirm I was now seeing a DDNS address and not an IP address.

    5. Imported that revised .ovpn file onto my iPhone then into the OpenVPN app


    I’ve glossed over some fine detail there, not knowing how familiar you are with things like Notepad++. I’m happy to go into further detail if necessary.

    I also have a feeling that I might also have done similar on an iPad - editing the config file prior to importing it, but I really can’t be sure.
     
    royarcher likes this.
  6. OBENZ

    OBENZ Regular Contributor

    Joined:
    Nov 22, 2018
    Messages:
    63
    It's mostly your ddns client not updating especially the asus ddns server nowadays

    Sent from my SM-G965F using Tapatalk
     
  7. Martineau

    Martineau Part of the Furniture

    Joined:
    Jul 8, 2012
    Messages:
    2,370
    Location:
    UK
    On my RT-AC68U the DDNS name is correctly exported (using WWW.DNSOMATIC.COM and 'Method to retrieve WAN IP=INTERNAL') and I believe @RMerlin's commit to remove the original restrictive ASUS 'bug'?
     
    Last edited: Nov 9, 2019
  8. Pedsteruk

    Pedsteruk Occasional Visitor

    Joined:
    May 31, 2017
    Messages:
    10
    Yep can just edit as a text file. I’ve also noticed / found you can override the server in the iOS client.
     
    martinr likes this.
  9. Pedsteruk

    Pedsteruk Occasional Visitor

    Joined:
    May 31, 2017
    Messages:
    10
    Yes you are right. Shame as has worked fine for years. It’s now not updating at all unless a remove and re add the DDNS.

    I’ve ditched it and all back working.

    Thanks all for the help.