[384.15_Alpha - builds] Testing all variants.

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.
Status
Not open for further replies.

octopus

Very Senior Member
Last edited:

L&LD

Part of the Furniture
I have been running this version on the RT-AX88U for 3 days and 12 hours now, no issues.
 

skeal

Part of the Furniture

S.claus

Regular Contributor
Adaptive QoS upload does not limit (download limits just fine)
Wifi 6/ax mode does not enable and disable unless you enable it during the setup. It indicates enabled but the moment you click to another tab and back it still shows disabled
 

L&LD

Part of the Furniture
@S.claus are you hitting the Apply button at the bottom of the page?
 

LimJK

Very Senior Member

TheOldMan

Senior Member
Hey, all you self-compilers, are you having trouble compiling 384.15_a1?

I'm getting this error...

make[3]: Entering directory '/home/;)/amng/release/src/router'
Makefile:4115: *** missing separator. Stop.
make[3]: Leaving directory '/home/;)/amng/release/src/router'
make[2]: *** [Makefile:4469: setprofile] Error 2
make[2]: Leaving directory '/home/;)/amng/release/src-rt-5.02hnd'
make[1]: *** [Makefile:4293: bin] Error 2
make[1]: Leaving directory '/home/;)/amng/release/src-rt-5.02hnd'
make: *** [Makefile:4439: rt-ac86u] Error 2
 

Delusion

Senior Member
Hey, all you self-compilers, are you having trouble compiling 384.15_a1?

I'm getting this error...

make[3]: Entering directory '/home/;)/amng/release/src/router'
Makefile:4115: *** missing separator. Stop.
make[3]: Leaving directory '/home/;)/amng/release/src/router'
make[2]: *** [Makefile:4469: setprofile] Error 2
make[2]: Leaving directory '/home/;)/amng/release/src-rt-5.02hnd'
make[1]: *** [Makefile:4293: bin] Error 2
make[1]: Leaving directory '/home/;)/amng/release/src-rt-5.02hnd'
make: *** [Makefile:4439: rt-ac86u] Error 2

I had issues when using mainline branch.. git throws an error. I managed to compile fine using Master branch ( I know we -86U users should use Mainline).
Can someone tell me why not to use Master branch for ac-rt86u?
 
Last edited:

S.claus

Regular Contributor
@S.claus are you hitting the Apply button at the bottom of the page?
I have applied the settings and I rebooted the router afterward no change. I, however, did not select a WAN packet overhead
 

L&LD

Part of the Furniture
@S.claus I just tried (again) and if I hit apply, the AX mode doesn't revert back to where it was. I think you are replying to another issue. ;)

When hitting Apply, the GUI refreshes and the new setting is selected until I choose to use the other setting (I prefer AX mode currently). :)
 

TheOldMan

Senior Member
I had issues when using mainline branch.. git throws an error. I managed to compile fine using Master branch ( I know we -86U users should use Mainline).
Can someone tell me why not to use Master branch for ac-rt86u?

@RMerlin does merge master git with mainline. It's how we do the commits when the master branch complains that the mainline branch has old files. I use git commit -a to synch master with mainline. The git manual I follow says to do: 1. git checkout master, 2. git pull, 3. git checkout mainline, 4. git merge master.... It works until master complains mainline has a "pimple."
 

S.claus

Regular Contributor
@S.claus I just tried (again) and if I hit apply, the AX mode doesn't revert back to where it was. I think you are replying to another issue. ;)

When hitting Apply, the GUI refreshes and the new setting is selected until I choose to use the other setting (I prefer AX mode currently). :)
Ok enable/disable it and go into professional 5G settings and check if you can select OFDMA or is it blanked out
 

RMerlin

Asuswrt-Merlin dev
Asus split the RT-AX88U code from their other models, forcing me to also split that between mainline and rtax88u. Since I didn't want to create two separate patches for everything that I did, I forked the mainline and rtax88 branches off. Since then, changes that apply to all branches are committed to master (like updated curl/dnsmasq/etc...). Code that is GPL-specific will be applied only to their relevant branch (either mainline or rtax88).

So, you don't want to build from master, unless you want to use a one-year old GPL with only the updated third party components or global fixes applied. Master has to merged on top of mainline/rtax88 to obtain the latest up-to-date code before building from either of these two. I only do so on git from time to time.

This will be the case until the day Asus merges the rt-ax88u code back onto their "main" repository, which will allow me to once again merge them back together into one single branch - master itself.

@RMerlin does merge master git with mainline. It's how we do the commits when the master branch complains that the mainline branch has old files. I use git commit -a to synch master with mainline. The git manual I follow says to do: 1. git checkout master, 2. git pull, 3. git checkout mainline, 4. git merge master.... It works until master complains mainline has a "pimple."

Git merging does require some hands-on knowledge about git to resolve merge conflicts, they will occasionally require human intervention if the same part of the code was changed both on master and the branch. For instance this is currently the case when merging master on top of rtax88.
 

L&LD

Part of the Furniture
Ok enable/disable it and go into professional 5G settings and check if you can select OFDMA or is it blanked out

When 802.11AX/Wi-Fi 6 mode is Enabled, I can select OFDMA Enable or Disable.

When 802.11AX/Wi-Fi 6 mode is Disabled, OFDMA is disabled with yellow/orange text stating to Enable Wi-Fi 6 mode to enable that functionality.
 

skeal

Part of the Furniture
When 802.11AX/Wi-Fi 6 mode is Enabled, I can select OFDMA Enable or Disable.

When 802.11AX/Wi-Fi 6 mode is Disabled, OFDMA is disabled with yellow/orange text stating to Enable Wi-Fi 6 mode to enable that functionality.
This makes sense as it's the default behavior you need wifi6 to get OFDMA.
 

eclp

Senior Member
This early alpha runs really well on my AX88U, and I don't have any error messages in the syslog. Only small thing here, DNSSEC tests don't run quite clean ly on this site. —> http://0skar.cz/dns/en/

Thank you RMerlin!
 

eclp

Senior Member
@Milan ...
Are you connected via DNS over TLS?
(WAN Settings)

:)
 

Marin

Very Senior Member
This early alpha runs really well on my AX88U, and I don't have any error messages in the syslog. Only small thing here, DNSSEC tests don't run quite clean ly on this site. —> http://0skar.cz/dns/en/

Thank you RMerlin!

Same here as well. Some of the tests do not pass validation. Did not experience this with previous FWs and have kept my configuration the same for quite some time now.


Sent from my iPhone using Tapatalk
 
Status
Not open for further replies.

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top