384.19 DNS very slow

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Nodiaque

Occasional Visitor
Hello,

I'm currently on 384.19 on a RT-AC3100 and I'm having a hard time with the DNS part. I tried rebooting, clearing and didn't worked. What's going on is on my computer, when I do a ping (or anything else that involve DNS), it take about 10 sec before the ip get resolved (and even more). On the DHCP page, I switched DNS 1 to 8.8.8.8 and it's instant answer, but once I remove it (so it's back to my router dns), it take forever before getting an answer.

I've tried turning off FlexQOS, Skynet, Diversion, nothing worked. I'm unsure if it's dnsmasq that's just very slow on the router. Problem is, if I put 8.8.8.8 as DNS, then diversion won't do it's job.

Thank you
 

dave14305

Part of the Furniture
What is set as WAN DNS on the router?

What does an nslookup from a client look like when it times out using the router as DNS?
 

Nodiaque

Occasional Visitor
Wan DNS is isp DNS and all client all router as DNS. If I change everyone for is DNS or google, it's faster.
 

shabbs

Regular Contributor
Do you need to use the ISP DNS?
I've set my WAN DNS to Quad9's DNS services: https://www.quad9.net/



For my LAN DNS, I run Pi-hole locally with OpenDNS upstream.

EDIT: What DNS is your DHCP giving out then? This is on the LAN setup. Just noticed that you're using DNSFilter.
 
Last edited:

Nodiaque

Occasional Visitor
I'm using the router as DNS. That's the problem. It's not the isp DNS the problem, it's when the router does the DNS job, it's slower then using isp or other directly in my dhcp settings. Even if I change my wan DNS, it doesn't go faster.
 

shabbs

Regular Contributor
Sorry, maybe I'm misunderstanding. Unless you're running a local DNS service, you'll need some reference to IPs running DNS services somewhere - either your ISP or Google or Quad9 etc...
The WAN DNS is DNS used by your router. That's typically your ISP DNS or a third party services like Google, Quad9 etc...
The LAN DNS specified in your DHCP settings is what will be used by your network clients when they connect to your network and get the DHCP handout.
If your LAN DNS entry is blank, it will use the DNS settings in the WAN entry.
If you've enabled DNSFilter and set it to Router. It will used the DNS entry in your DHCP settings.

EDIT: Sorry, seems I may be adding to the confusion as you're using Diversion. Could it be that the Diversion blacklist processing is slowing it down? I'm not too familiar with Diversion.
 
Last edited:

Yo_2T

Occasional Visitor
I'm using the router as DNS. That's the problem. It's not the isp DNS the problem, it's when the router does the DNS job, it's slower then using isp or other directly in my dhcp settings. Even if I change my wan DNS, it doesn't go faster.

What exactly are you using to run DNS on the router? Are you running Unbound?

What are filled out in the DNS fields under WAN settings?
 

Nodiaque

Occasional Visitor
The router have it's own DNS. If I do ipconfig, my dns server is my router. It's also the only way that if I do a ping hostname from a local machine, it will resolve. If I push instead google or something else in the config, it won't resolve.

I'm not using Diversion anymore, I totally formated my router and removed everything, it's now fresh merlin firmware without addon, with same result.

In DNS under WAN I have
dns1.png


I did try without filtering, didn't change anything.

In DHCP, I'm using router IP as DNS
dns1.png


When I do ipconfig, my DNS server is the router.

Now, if in the DHCP setting, I put my WAN ISP DNS server or google (or anything else), the DNS query are fast, very fast. But when I put my router, it's really slow to resolve.
 

shabbs

Regular Contributor
So, based on your setup, the DNS being used by your router, and thus your clients, is the ISP provided one. Maybe that's the issue.

I'd suggest you switch to a different DNS service:
- https://www.techradar.com/news/best-dns-server

Set the "Connect to DNS Server automatically" to NO and then input DNS entries for the service of your choice - Google, OpenDNS, Quad9 etc...
 

Nodiaque

Occasional Visitor
I think we don't understand each other, sorry english isn't my main language.

If I change the configuration, let's say in DHCP I put, on DNS Server 1, my ISP DNS (which is the same as the WAN DNS), everything is fast (but then, on ipconfig, it's not my router that's in dns server but the ISP one). Thus, it's not my ISP DNS the problem. Samething if I put anything in the DNS Server 1 or 2, it will be very fast unless I enter my router IP. If I change my router WAN DNS to google or something else, it's still slow. The problem is the router take too much time to reply to dns query.
 

ColinTaylor

Part of the Furniture
How are you measuring how slow the router's DNS server is?

How slow is "slow"? 0.1 second, 10 seconds, etc?

Is is slow all the time or just occasionally.

Is it slow on all clients or just some?
 

Nodiaque

Occasional Visitor
All clients.

MEasure is simple. If I do a ping, let's say google. The time between it resolve the address and start to ping is long. But more noticeable, loading web page is very long. You click on a link, 5-10 sec later the page start to load. When it's direct to ISP DNS, no problem, page load instant. Both wired and wireless clients.
 

ColinTaylor

Part of the Furniture
Can do try this from the client's command prompt and keep repeating it as fast as you can. Approximately how quickly do you get a reply?
Code:
nslookup www.google.com

Now try the same thing again with this command and compare the speed of the responses.
Code:
nslookup www.google.com 8.8.8.8


Are you using IPv6?
 

Nodiaque

Occasional Visitor
no ipv6

yup tried nslookup in the past too, forgot about it, that's when I saw it was really a DNS delay problem.Each time I run it without google dns, it take nearly 5 sec to resolve.
 

ColinTaylor

Part of the Furniture
Are you seeing any dnsmasq errors in the router's syslog?

Can you SSH into the router and post the output of cat /etc/dnsmasq.conf
 

ColinTaylor

Part of the Furniture
That all looks fine and normal so perhaps it's just a bug in the firmware? Have you tried any other versions of the firmware?

One thing you could try although there's no logical reason for it to make a difference, is to specify a domain name for your LAN at LAN > LAN IP > Domain Name. Try something like home.lan and then reboot your clients to pick up the change.
 

shabbs

Regular Contributor
I had that before I factory reset the router.
Did you try with Asus stock Firmware? A factory reset will just re-load Merlin.
 

Nodiaque

Occasional Visitor
No didn't try to go back to oem firmware. Factory Reset was to be sure merlin was properly configured since I always did in-place upgrade without configuration reset.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top