News [ 386.3_Alpha Build(s) ] Testing available build(s)

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

jsbeddow

Senior Member
Not if Asus hasn't released a new GPL in the meantime... If else, probably as soon as reasonably possible.
Yes, I know, and I believe that @RMerlin mentioned that there were some problems with one of the more recent GPL releases he had received from Asus, so I suspect that we are all waiting on another revision.
 

RMerlin

Asuswrt-Merlin dev
Hmmm... cryptic answer, maybe soon?
Not cryptic, just making sure that if someone reads my answer a week from now, they will realize that since these alpha builds are not formal releases, whatever builds that are available later on may or may not include the fixes.

Asus sent me new updates last night, but I haven't had the time to merge or test them, and they don't include all models yet either.
 

det721

Part of the Furniture
Asus sent me new updates last night, but I haven't had the time to merge or test them, and they don't include all models yet either.

What did they send you 43129 ? And im sure the AX58U is one of the models missing as there official site has been crickets for almost three months.
 

TimmyL

Occasional Visitor
Not cryptic, just making sure that if someone reads my answer a week from now, they will realize that since these alpha builds are not formal releases, whatever builds that are available later on may or may not include the fixes.

Asus sent me new updates last night, but I haven't had the time to merge or test them, and they don't include all models yet either.
Any news about the new updates from Asus ?
 

Wisiwyg

Senior Member

shabbs

Senior Member
I am recently guilty as well, and use Diversion as my failsafe backup :)
Dual pi-holes with a 3rd spare here... belts and suspenders!
 

RMerlin

Asuswrt-Merlin dev
What did they send you 43129 ? And im sure the AX58U is one of the models missing as there official site has been crickets for almost three months.
It's not a new GPL, it's just updated wireless drivers. GPL releases are currently on hold while some things get sorted out. (it's complicated).
 

Kingp1n

Very Senior Member
It's not a new GPL, it's just updated wireless drivers. GPL releases are currently on hold while some things get sorted out. (it's complicated).
@RMerlin would you happen to have a time frame with the possibility of what new router models you will support in the future? I understand if you don't know at this time and thought I would ask. I apologize if this has been asked previously! Thanks for all you do.
 

RMerlin

Asuswrt-Merlin dev
@RMerlin would you happen to have a time frame with the possibility of what new router models you will support in the future? I understand if you don't know at this time and thought I would ask. I apologize if this has been asked previously! Thanks for all you do.
Same answer I always give: I can't speculate about future model support, because I don't know for sure until I have gone ahead and actually worked on adding support, at which point I will announce it anyway. All I can say is there is one unreleased model that I have completed support for, but that model's launch got delayed by a few months, hence no announcement from me yet. A couple of other models have been discussed with Asus (some existing, some unreleased/unannounced models yet), but I don't have anything to announce about any of these at this time.
 

Clark Griswald

Senior Member
Now I'm waiting for RMerlin fw on routers I have no idea about (nor currently need) ;)
Stay Safe Everyone
EDIT: Latest alpha working smoothly!
 
Last edited:

RMerlin

Asuswrt-Merlin dev
I did some basic spot checks to some of the models, the updated driver seem to work properly for the few that I tested, so I'm uploading the models that I have updated so far.
 

det721

Part of the Furniture
Is a factory reset advisable or not nessesary ? And if is needed can we use a back up configuration ?
 
Last edited:

ComputerSteve

Regular Contributor
I just upgraded to this build and now my OpenVPN client wont connect --- I changed nothing & this is now what i'm getting.. Any help?
Jun 1 18:19:34 ovpn-client1[31350]: ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication
Jun 1 18:19:34 ovpn-client1[31350]: VERIFY EKU OK
Jun 1 18:19:34 ovpn-client1[31350]: VERIFY OK: depth=0, C=SK, ST=Bratislava, L=Bratislava, O=Tiger At Work & Co. k. s., OU=tigerVPN, CN=tigervpn.com, name=tigerVPN, emailAddress=[email protected]
Jun 1 18:19:34 ovpn-client1[31350]: UDP WRITE [152] to [AF_INET]162.250.2.18:1194: P_CONTROL_V1 kid=0 [ 3 ] pid=2 DATA len=126
Jun 1 18:19:34 ovpn-client1[31350]: UDP READ [77] from [AF_INET]162.250.2.18:1194: P_CONTROL_V1 kid=0 [ 2 ] pid=4 DATA len=51
Jun 1 18:19:34 ovpn-client1[31350]: UDP WRITE [529] to [AF_INET]162.250.2.18:1194: P_CONTROL_V1 kid=0 [ 4 ] pid=3 DATA len=503
Jun 1 18:19:34 ovpn-client1[31350]: UDP READ [261] from [AF_INET]162.250.2.18:1194: P_CONTROL_V1 kid=0 [ 3 ] pid=5 DATA len=235
Jun 1 18:19:34 ovpn-client1[31350]: UDP WRITE [22] to [AF_INET]162.250.2.18:1194: P_ACK_V1 kid=0 [ 5 ]
Jun 1 18:19:34 ovpn-client1[31350]: Control Channel: TLSv1.2, cipher TLSv1.2 ECDHE-RSA-AES256-GCM-SHA384, peer certificate: 2048 bit RSA, signature: RSA-SHA1
Jun 1 18:19:34 ovpn-client1[31350]: [tigervpn.com] Peer Connection Initiated with [AF_INET]162.250.2.18:1194
Jun 1 18:19:35 ovpn-client1[31350]: SENT CONTROL [tigervpn.com]: 'PUSH_REQUEST' (status=1)
Jun 1 18:19:35 ovpn-client1[31350]: UDP WRITE [56] to [AF_INET]162.250.2.18:1194: P_CONTROL_V1 kid=0 [ ] pid=4 DATA len=42
Jun 1 18:19:35 ovpn-client1[31350]: UDP READ [22] from [AF_INET]162.250.2.18:1194: P_ACK_V1 kid=0 [ 4 ]
Jun 1 18:19:35 ovpn-client1[31350]: UDP READ [86] from [AF_INET]162.250.2.18:1194: P_CONTROL_V1 kid=0 [ ] pid=6 DATA len=72
Jun 1 18:19:35 ovpn-client1[31350]: AUTH: Received control message: AUTH_FAILED,Username or password incorrect
 

RMerlin

Asuswrt-Merlin dev
Is a factory reset advisable or not nessesary ? And if is needed can we use a back up configuration ?
No need to.
 

RMerlin

Asuswrt-Merlin dev
I just upgraded to this build and now my OpenVPN client wont connect --- I changed nothing & this is now what i'm getting.. Any help?

Jun 1 18:19:35 ovpn-client1[31350]: AUTH: Received control message: AUTH_FAILED,Username or password incorrect

There's your problem.
 

shabbs

Senior Member
I did some basic spot checks to some of the models, the updated driver seem to work properly for the few that I tested, so I'm uploading the models that I have updated so far.
Away we go!!!

EDIT: Filthy upgrade from first alpha_1 on my three APs. So far so good. All devices re-connected, no issues so far. QR code still working. ;) FWIW, I seem to have gained a few dBm's on the clients connected to my RT-AC86U AP. They're showing "healthier" connections at this point, which is nice to see. This is on the 2.4GHz band. Not sure if that's the new alpha or just coincidence. I have a Nest cam on that one that can be finicky.
 
Last edited:

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top