86U OpenVPN slow speed unless apply no changes

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.


New Around Here
Very odd issue I'm having with my 86U. I have a 100mb/s connection, and without VPN I get ~120 on average. I signed up for NordVPN and set it up according to the instructions and it'll still get >100mb/s, but only for a few minutes. After waiting 10-15 mins, I'll try another speed test and I only get 25-30mb/s. I tried a different server, and it was 120 again, but only for a few minutes. I tried different DNS, same thing. Then I (on a whim) just hit "apply" without making any changes on the DNS page...and it got 120mb/s...then back down to 30 after about 10 mins. It's got to be something with the router, but I have no idea what. I'm running the latest MERLIN firmware. Did anyone experience something like this?


Part of the Furniture
Try disabling QoS if you have it turned on.


Part of the Furniture
IMHO VPN speeds tend to be highly variable vs local ISP.

It might help if you are using policy routing be sure the router itself is using the WAN and not the VPN. Screenshot_2020-08-30 spdMerlin - Internet Speedtest Stats.png

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!