What's new

A diary to solve Asus RT-AC1200G+ reboot and unstable wireless issue

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

amigoccs

Occasional Visitor
Hi All,

Whether your RT-AC1200G+ crash today?

I bought RT-AC1200G+ on 2017/3/10. It has several reboot randomly. I try to disable some features to skip from the bug and write Asus RT-AC1200G+ Random Reboots Automatically to keep track of it.

On 2017/5/7, PawelW leave a message in my post to share a new beta RT-AC1200G + _9.0.0.4_380_7415-gc949b277fca.trx which solved his problems.

A link to the beta firmware is available in his message. Please follow his reply or just leave your message there in case any update.

In local group, one guy install this firmware and is very satisfied with the stability.

I also got reply from Lisa who works for Asus in 哪裡可以下載 RT-AC1200G+ 台灣新 Beta 韌體 380_7415?. She explains this is not available to download and didn't deny the existence.

But some has security concern, I decide to dig into this issue continuously. I check the thread: Broadcom BCM47xx on OpenWrt, login to RT-AC1200G+ and run dmesg and nvram show, and compare with available documents on Linux kernel. I believe it's related to wireless driver. Because I have several cold and hot reboot with 5GHz, I decide to try different settings on BCM47189.

On 2017/5/7, I disable 802.11ac by setting Wireless Mode to [N only] in [Advanced Settings] → [Wireless] → [General] Tab to get better driver compatibility.

If you are interested in the detail, please read Asus RT-AC1200G+ Random Reboots Automatically.

My current configuration:

After install to official latest stable version 3.0.0.4.380.4089, reset and configure as below:

1. In [USB Application] → [Media Services and Servers], disable [Media Server] and [network Place (Samba) Share] which is default on.
2. In [USB Application] → [3G/4G], set Select USB Device to [Android phone].
3. In [Wireless], turn off WPS and set Channel bandwidth on 5GHz for 80MHz and on 2.4GHz for 40MHz; set Wireless Mode on 2.4GHz to [N Only] and on 5GHz to [N only]; set Control Channel on 5GHz to [Auto].
4. In [WAN], UPnP is turned on by default.
5. In [Firewall], Network Service Filter is turned off by default. Uncheck all selection and apply again.
6. In [Administration] → [System], Reboot Scheduler is turned off by default.

Just my two cents!

Best regards,

Amigo
 
Hi,

I didn't expect to update so soon.

On 2017/5/10, cold reboot at 13:15 (GMT+8) as usual.

I decide to drop the 5GHz completely by setting Enable Radio on 5GHz to [No] in [Advanced Settings] → [Wireless] → [Professional] Tab.

I can still see following messages going on:

May 10 13:24:40 kernel: txerr valid (1) reason 0100 tst 2222 pctls 3cc2 5c1b 0025
May 10 13:24:40 kernel: plcp 000b 006f || 3f0f 8f08 0000 || 722b 7288 || rxestats2 0000
May 10 13:24:40 kernel: txerr_tm 001c txerr_txbytes 0000 txfunfl 0 1 0 0 0 0 txtplunfl 0
May 10 13:24:40 kernel: debug1 7288 debug2 0000 debug3 0000 debug4 0000​

txerr should be Transmit Error but I have no ideas why.

But when I drop the 2.4GHz completely by setting Enable Radio on 2.4GHz to [No] in [Advanced Settings] → [Wireless] → [Professional] Tab. The above messages are gone.

Anyway, I will start by disabling 5GHz. If it doesn't work, I will stop 2.4GHz and re-enable 5GHz next time.

Let's wait and see.

Follow this post to see any updates in the future.
 
I also get a respond from Hong Kong local community. fatdog suggest to use firmware 3.0.0.4.380_3971-g516a6d6 and schedule reboot every day in Asus RT-AC1200G+不定期重啟 (Cold and Hot Reboot) #11. He has no problems at all. I will give it a try after above option.

Here I got two bad messages. PawelW reports that the beta firmware RT-AC1200G + _9.0.0.4_380_7415-gc949b277fca.trx eventually crash after 19 days. nikisi on Asus suppport forum also reports in [Sharing]A diary to solve Asus Rt-AC1200G+ cold and hot reboot issue that the link to beta firmware is no longer available. Dark clouds enveloped!

Many people suggest me to send back to fix. No, it's a very bad idea. If I cannot find a standard operation procedure to reproduce the crash in time, they will never fix it.

If the last option doesn't work, I will return for a fix to test my idea and record every return here.
 
Status Update

On 2017/5/12, Freeze at 13:13PM


I see warning message continuously generated after disabling 5GHz from 2017/5/10. Finally it freeze today. For those already connected, they won't be able to access internet. Others won't see the SSID. I have to restart RT-AC1200G+ with its power button.

On 2017/5/13, Change Network Topology

Some of my device doesn't support 5GHz. Therefore I disable 5GHz and DHCP of RT-AC51U. Use LAN to LAN to connect RT-AC51U to RT-AC1200G+. The former will be responsible for 2.4GHz while the later is 5GHz. How to Connect Two Routers on wikiHow has great illustration and explain in plain English.

Both of my NAS are connected to the Gigabit Ethernet of RT-AC1200G+ while Mac mini is 802.11n @ 5GHz with 2T2R at 300Mbps. Copying a single 3.87Gb file is about 25 MB/s. Only those connected to RT-AC51U will be limited by the slow Fast Ethernet.

Read the reformatted version

Links to New Beta Firmware

Shared by PawelW here. Please follow the comments and share your experience there. It probably doesn't work on your local version. Be careful!

massimo seems encounter some issue here and I am trying to help.

Have a nice day!
 
Hi,

2017/5/15 it reboots again but WAN was restored automatically. No need to reset tethering on Android mobile. If you are interested in the detail, check my log on 2017/5/15 in Asus RT-AC1200G+ Random Reboots Automatically.

I have experience 4 different issue:

1. Reboot and drop USB tethering
2. Reboot and drop USB tethering without reset uptime
3. Freeze
4. Reboot but didn't drop USB tethering

Because it's still unstable, I have to send back to Asus. There is nothing I can do.

I print two copy total 14 pages of my diary together with my router. Let's see if they may solve this problem.

Keep walking!
 
Hi,

I am going to keep track of RMA in Asus RT-AC1200G+ Random Reboots Automatically and updates here.

1st RMA: From 2017/5/15 till Now

On 2017/5/15, I contact Asus and get a RMA code. Print this post together with my RT-AC1200G+ to send back to Asus at 15:30.

On 2017/5/16, a tech support form Kaohsiung call me at 17:37. He ask me several questions which I have already provide the detail in my post. Maybe it’s the routine conversation or he doesn’t have time to read this long report. At the end, he decide to send me a new replacement and upgrade to the latest firmware.

I will begin to test when I get it.

If you are interested in the whole RMA process, please follow this thread or my post.

To be continue...
 
Hi, it's nice to know the firmware works.

I got a call from tech support that he cannot reproduce reboot with GbE. I instruct him to generate error message, make the wireless network unstable, and use Google Drive to monitor.

I think he never read my printed post included in RMA.

I have a bad feeling that they will never reproduce the reboot issue of RT-AC1200G+.

Asus RT-AC1200G+ Random Reboots Automatically
 
On 2017/5/22, the same tech support contact me that he finally reproduce a reboot on 5GHz in the weekend. This is a great news and I can see how hard he work on this issue. Because the reboot has been confirmed by tech support, it's officially confirmed my RT-AC1200G+ has random reboot. Now research and development engineer finally may investigate my issue.

On 2017/5/23, the same tech support contact me that THE RESEARCH AND DEVELOPMENT ENGINEER REFUSED TO CHECK UNLESS I PROVED VIDEO OF RT-AC1200G+ AND SCREEN RECORDING ON ALL MY DEVICE AND NAS AT THE CRASH POINT TO PROOF IT'S NOT WORKING.

I told the tech support it's impossible to provide screen recording because it against security and governance. I may setup a video camera on the router and clip only the crash point and upload to YouTube.

The only way to stop is to return you device for refund or repair within warranty.

I will continue to fight for a stable machine! Put your RMA image link here to join!
 
Hi,

As updates on 2017/5/23, Asus request video capture of crash moment even though they have successfully reproduce this issue. It's difficult to use your mobile or camera to capture due to limited storage. Therefore, I have setup a surveillance system with NAS and IP Cam successfully. Now, it's easier to capture crash moment.

Detail in Setup a Surveillance System to Proof Crash of Asus RT-AC1200G+.

1. Get a NAS and IP Camera. I choose Asustor AS5102T and D-Link DCS-930L. Check here for compatibility. I will update a QNAP version later.

2. Use wired line to connect to DCS-930L. Get its IP address on your router.

3. Install Asustor Surveillance Station in ADM.

4. It's the tricky part: install the view package when you launch Surveillance Station for the first time. Use Internet Explorer or Safari to login Surveillance Station to setup. It doesn't work with Firefox or Chrome.

5. Video default saves to [Surveillance] in MKV format. One file every minute. Then group by hour and date.

Wish it helps!
 
Hi,

Here is the latest update after 2015/5/23

On 2017/5/25, Prepare to Capture Next Reboot

I get a same-model replacement today. Then upgrade firmware, configure, keep RT-AC1200G+ in a simplified network for future test. Remove USB tethering and connect the LAN on RT-AC51u toWAN on RT-AC1200G+. Strangely, RT-AC51u crash when I turn on NAS which both plug-in in RT-AC100G+. I have try 5 times but cannot repeat the reboot.

On 2017/5/26, Research on syslog.log, Change Network Map, Testing Cooling System, and an Unstable 5GHz Issue

I search several reference, try to generate more logs. When I real a post from RMerlin, I realize syslog.log won't generate enough information for kernel crash. I need a serial and special software to communicate.

To make sure the surveillance system may capture the crash moment, I modify the network map as below:

20170526-network-map-to-capture-crash-moment-of-asus-rt-ac1200g.png


I also use a fan to test if temperature is the key factor to its unstable.

About 11:00PM, 5GH becomes unstable. I get the video successfully but cannot read the information from lights. Following 3 videos are capture at different time but looks similar.




Please check the detail in Asus RT-AC1200G+ Random Reboots Automatically if your are interested.

I think the next step is to find the right tool.

Keep walking!
 
Hi,

I have following updates but doesn't have time to abstract these days. Here is a quick summary. Please read this post for detail text, screen capture, log, and video.

On 2017/6/1, Upgrade to RT-AC1200G+_9.0.0.4_382_10680-gc72d1c8.trx (get the new firmware in comments)

On 2017/5/31, 5GHz Unstable, Reboot (Get video captures and upload to Youtube)

On 2017/5/30, Pressure Test, 5GHz Radio Jamming, Wireless Technologies (Surprisingly stable)

On 2017/5/29, Reboot, Identify Crash Time with Another Router (Get exact time firs time)

On 2017/5/28, Upgrade to Un-official RT-AC1200G+_9.0.0.4_380_7415-gc949b277fca.trx (an unofficial test version but doesn't work)

On 2017/5/26, Research on syslog.log, Change Network Map, Testing Cooling System, and an Unstable 5GHz Issue. (It's not a temperature issue)

Have a nice day!
 
Last edited:
On 2017/5/28, Upgrade to Un-official RT-AC1200G+_9.0.0.4_380_7415-gc949b277fca.trx

No, it still doesn't work.

On 2017/5/29, Reboot, Identify Crash Time with Another Router

Two router is better than one in this case.

On 2017/5/31, 5GHz Unstable, Reboot

And I finally catch the crash movie, WiFi Scanner/Analyzer screenshot

On 2017/6/1, Upgrade to RT-AC1200G+_9.0.0.4_382_10680-gc72d1c8.trx

I got this new firmware from Dolly Chu who work in Asus Customer Service Taipei. It's not public yet.

I have found following information in the new firmware:
  1. kernel: Linux version 2.6.36.4brcmarm (root@asus) (gcc version 4.5.3 (Buildroot 2012.02) is still the same
  2. kernel: eth1: Broadcom BCM43227 802.11 Wireless Controller 9.10.178.61 (r667680) has been upgrade from 9.10.178.27 (r584393)
  3. kernel: eth2: Broadcom BCM43c8 802.11 Wireless Controller 9.10.178.61 (r667680) has been upgraded from 9.10.178.27 (r584393)
On 2017/6/7, Update Network Map, MAC filter list Issue

Because there is no reboot for 6 days after upgrading to RT-AC1200G+_9.0.0.4_382_10680-gc72d1c8.trx and nobody feedback any issue, I restore original network map again on 2017/6/7. Make RT-AC1200G+ the only one wireless router.

During setup, I notice some issue with the icon and name in MAC filter list in [Wireless MAC Filter] tab. It would be displayed as New device with default icon after modified and apply until connected. In some case, your edit won't be apply for no reason.

For example, I add a Windows device, choose a Windows icon, and change it to SurfaceRT. Then hit Apply button twice. It is displayed as New device with a default laptop icon. When this Windows device connects to RT-AC1200G+, the name is changed to WinRT with a Windows Desktop icon. I try to change it again but fails. It won't save or apply.

I will continuous monitoring if there is any issue in the next 3 weeks.

I am also maintain a new section to keep track of no-reboot-days with the new firmware 9.0.0.4_382_10680. Maybe you may help!

Detail: Asus RT-AC1200G+ Random Reboots Automatically
 
Hi all,

It's 15 days after upgrading to RT-AC1200G+_9.0.0.4_382_10680- gc72d1c8.trx without reboot issue. There are three minor issue as below:
  1. caliban reports a 20 seconds wireless drop and reconnect once.
  2. Available channels doesn't fit EU regulation.
  3. Need NVRAM reset after upgrade or 2.4GHz SSID might be unavailable.
I will continuous monitoring if there is any issue in the next 2 weeks.
 
Hi,

Since my last post on 2017/6/16, Asus RT-AC1200G+ Random Reboots Automatically has been added following sections:

Official 3.0.0.4.380.7743 Testing by Net Friends

Official release new firmware but I receive three reports about reboot with this version.

On 2017/7/2, Unstable 5GHz Issue

Experience 5GHz SSID missing or very slow. Reset in admin menu or power button doesn’t help.

On 2017/7/3, Unstable 5GHz Issue is Solved by Switching Control Channel

Experience 5GHz SSID missing again. WiFi Scanner/Analyzer reports no visible 5GHz SSID. After setting 5GHz SSID Control Channel to 153 and reloading Broadcom BCM47189 driver, everything goes back to normal.

I am not sure it is Radio Jamming or Interference but doesn’t looks like a firmware issue.

Summary

1. I have not experience reboot issue for 34 days with 10680 from 2017/6/1.

2. Nandolv reports a new replacement or 10680 doesn’t help his reboot issue. 10680 is not a silver bullet.

3. AsusRTUsers, caliban, hitchhiker, Mike, nikisi, RT-AC1200G+, and tycjan don’t report any reboot issue yet.

4. caliban has experience 2.4GHz SSID missing issue in AP mode but not reboot.

5. Always clean your NVRAM and reconfigure your RT-AC1200G+ after flashing to 10680 or you might experience 2.4GHz SSID missing issue.

Detail: Asus RT-AC1200G+ Random Reboots Automatically
 

Latest threads

Support SNBForums w/ Amazon

If you'd like to support SNBForums, just use this link and buy anything on Amazon. Thanks!

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top