Aaaaarghhh! Want to add USB drive to RT-AC86U

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

tigreseis

Occasional Visitor
I know that didn’t help at all, but I seem to be eternally cursed never to find whatever I‘m searching for!

Look, I have an RT-AC86U, all I want to do is add an external hdd to it.

When I plug the usb drive in, it shows in the router gui, but shows as “unmounted”. How do I mount the thing?

Just want to use it to store files and have access across my home.

Any, “how to’s” out there?

My curse carries over to this forum. Any search gives me a plethora of “this” and “this” and ”that” wasn’t included in the search because...........
 

Jeffrey Young

Very Senior Member
How is your HDD formatted? If extFAT (as a lot of USB Keys are), that format is not supported. Use your computer and format to FAT or NTFS
 

L&LD

Part of the Furniture
You're asking for a lot more 'Aaaaarghhh'. :D

What you're asking for is what a NAS does best. QNAP and Synology recommended.

In the meantime, you can provide more information on the router's firmware, the capacity of the external HDD and any other relevant details like the type of files you want to store and share in your network and the file format the drive is currently using. An external power supply would be recommended as would trying different USB Ports too.

Did you recently update the firmware more than 3 'levels' higher or lower, on the router? Did you do a full reset afterward?

All the above and more may be a cause for the issue with your external drive problems.


And keep in mind that you can throw this search string into google to search this forum with better results "external HDD unmounted snbforums.com"
 

tigreseis

Occasional Visitor
Thank you @L&LD, but none of that applied. Haven’t had good experiences with Synology. Asus has worked great for me. Firmware is latest and the rest of those suggestions didn’t have any bearing on whether the drive would mount or not. Don’t need an external power supply with this setup and the RT-AC86U only has 1 USB 3 port, don’t want to use the USB 2. No on the 3 levels and no on the reset.

The solution was simple and @Jeffrey Young reminded me of it. I had used this as a go between drive with MacOS and Windows, so it was exFAT formatted.

Reformatted the 1TB to FAT32 and everything is working fine,

Thanks all for suggestions.
 

L&LD

Part of the Furniture
Yes, that is what happens when too little information is given. The replies can seem out of place.

That doesn't mean what I wrote doesn't apply. It just wasn't needed in your case though. :)
 

tigreseis

Occasional Visitor
I guess that depends on what “too little information” means. What was given was enough to elicit the correct answer, thank you Jeffrey.

Through context, you could see that I was talking about my case, thus the ”none of that applied”.

Although, I confess, I have no idea why the type of files or the capacity would have anything to do with why it wouldn’t mount.

That being the case, I do thank all for any help given.
 

L&LD

Part of the Furniture
The part that applied directly was to search better. :)

I suppose I could have added another (educated) guess and mention that the router only supports NTFS, FAT32, and Ext'X' ('X', depending on what router model you have).
 

tigreseis

Occasional Visitor
Nope, nope, you did your best. I new about the formats, but forgot the drive was exFAT!

That was my mea culpa. Nevertheless, on to meliora!
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top