1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

AC-RT88U and DNS settings?

Discussion in 'ASUS AC Routers & Adapters' started by zachary brown, Jun 9, 2018.

  1. zachary brown

    zachary brown New Around Here

    Joined:
    Jun 9, 2018
    Messages:
    3
    Hello,

    Just signed up to ask this question.

    I have the Asus AC-RT88U and recently bought a ras pi to tryout pi-hole and Im having weird issues with the router and the DNS settings.

    Under the WAN section, I set the ras pi ip address to my DNS server 1 and Google's to 2 as a fail safe. I originally left the LAN DNS section blank. Doing this I still get ad's served to me. So then I set the LAN DNS to the ras pi and everything worked fine, no more ads. I've now set the LAN DNS to blank again, and only the ras pi ip address as DNS 1; no ads. Add the Google DNS and I get ads. Set both to some random ip, no DNS resolving at all.

    Am I doing something wrong? Has anyone else had an issue like this? Id like to have a fallback dns server listed in case the ras pi goes down.

    Thanks
     
  2. Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!
  3. ColinTaylor

    ColinTaylor Part of the Furniture

    Joined:
    Mar 31, 2014
    Messages:
    5,469
    Location:
    UK
    Sounds a bit strange. Try SSH'ing into the router and issuing the following command. Maybe they have set "all-servers" and your pi-hole is too slow.

    cat /etc/dnsmasq.conf
     
  4. Jerie-

    Jerie- New Around Here

    Joined:
    Jun 7, 2018
    Messages:
    6
    zachary b,

    I'm going to assume that you are running stock firmware and not running Merlins' on your RT-AC88U since you only have one DNS option in LAN setting? Ok, if that's the case you need to do this:

    1. Set LAN DNS to rPi address
    2. Set WAN DNS1 to rPi address and set WAN DNS2 to Google's DNS address.

    This will setup a backup as you wanted. If your rPi is down, your LAN clients will look to your RT-AC88U for DNS and will find rPi (DNS1) & Google DNS (DNS2). Since rPi is down, it will use DNS2 in your WAN setting. Okay? Just remember that when your are force to use DNS2, you will see ads. To eleminate this, get a second rPi and config that too with Pi-Hole. Put the second rPi address into WAN DNS2 and now, should one rPi go down, the other picks up... thus no ads.

    I have two rPi 3s setup this way. No ads... well, fewer ads. There are still some ads Pi-Hole can not fully block. You will still see youtube ads but hopefully the next version of Pi-Hole will solve that with FTLDNS and regex blocking.

    Hope that helps.
     
  5. zachary brown

    zachary brown New Around Here

    Joined:
    Jun 9, 2018
    Messages:
    3
    Thanks for the help; both of you. I will try the SSH command when I have time to play around with it. In the meantime, I will set the DNS settings like I had them before (and how they were recommended above).
     
  6. Jerie-

    Jerie- New Around Here

    Joined:
    Jun 7, 2018
    Messages:
    6
    Hey Zachary b,

    I recall having similar issues as you stated when I first installed pi-hole. Did you by chance flush your dns cache on all client after installing your rPi? Reboot your router after you made the recommend changes and flush dns. Example; under windows using command prompt, issue this command: ipconfig /flushdns

    Also, if you care about statistics and have your pi-hole query logging (should be by default), you MUST set rPi as your DNS in LAN settings. So, basically set it as I recommend for LAN & WAN above. If you don't, when you log into pi-hole's webgui (http://your-rpi-ip-address/admin), all queries well be logged as being made by your router only and rPi's (localhost, 127.0.0.1).

    To make sure all your rPi is resolving your DNS queries, make sure to have a browser tab open to http://your-rpi-ip-address/admin and see if Total queries, Queries Blocked, etc. are being counted (going up) as you browse the web.

    Good luck.
     
  7. zachary brown

    zachary brown New Around Here

    Joined:
    Jun 9, 2018
    Messages:
    3
    Ill flush the dns on my windows pc and see if that helps as well.

    Its been working just fine lately. I have the LAN dns set to the pi-hole and my PCs and MBP automatically get the pi-hole as its main dns and the gateway as a second. So if the pi-hole were to fail, it should revert back to the gateway which will use my wan dns 2 of 8.8.8.8.

    Thanks everyone!
     
Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!