Solved ac3100 giga bit speed not advertised post reboot

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

mvadu

Regular Contributor
Setup: ac3100 connected to a raspberrypi 4 using a cat 7 cable.
Issue: Post rebooting the router it does not advertise gbps speed ( 1000baseT/Half 1000baseT/Full ) and only when I unplug the cable and put it back it goes to 1gbps. It stays until router is rebooted.


Post router restart

client side:
Code:
ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
        Link partner advertised pause frame use: Symmetric Receive-only
        Link partner advertised auto-negotiation: Yes
        Link partner advertised FEC modes: Not reported
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
Cannot get wake-on-lan settings: Operation not permitted
        Current message level: 0x00000007 (7)
                               drv probe link
        Link detected: yes

ac3100:
Code:
 robocfg showports
Switch: enabled
Port 0:   DOWN enabled stp: none vlan: 1 jumbo: on mac: 
Port 1:  100FD enabled stp: none vlan: 1 jumbo: on mac: 
Port 2:  100FD enabled stp: none vlan: 1 jumbo: on mac: 
Port 3:  100FD enabled stp: none vlan: 1 jumbo: on mac: 
Port 4: 1000FD enabled stp: none vlan: 2 jumbo: on mac: 
Port 5: 1000FD enabled stp: none vlan: 1 jumbo: on mac: 
Port 7: 1000FD enabled stp: none vlan: 1 jumbo: on mac: 
Port 8: 1000FD enabled stp: none vlan: 2 jumbo: on mac:

After unplugging cable and plugging back
Code:
 ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
                                             1000baseT/Half 1000baseT/Full
        Link partner advertised pause frame use: Symmetric Receive-only
        Link partner advertised auto-negotiation: Yes
        Link partner advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
Cannot get wake-on-lan settings: Operation not permitted
        Current message level: 0x00000007 (7)
                               drv probe link
        Link detected: yes

ac3100:
Code:
 robocfg showports
Port 0:   DOWN enabled stp: none vlan: 1 jumbo: on mac:
Port 1:  100FD enabled stp: none vlan: 1 jumbo: on mac:
Port 2:  100FD enabled stp: none vlan: 1 jumbo: on mac:
Port 3: 1000FD enabled stp: none vlan: 1 jumbo: on mac:
Port 4: 1000FD enabled stp: none vlan: 2 jumbo: on mac:
Port 5: 1000FD enabled stp: none vlan: 1 jumbo: on mac:
Port 7: 1000FD enabled stp: none vlan: 1 jumbo: on mac:
Port 8: 1000FD enabled stp: none vlan: 2 jumbo: on mac:

See the change in port 3 speed and Link partner advertised link modes.
 

ColinTaylor

Part of the Furniture
Try using a Cat 5e cable instead and seeing if that works.
 

ColinTaylor

Part of the Furniture
Do you not already have a Cat 5e cable you can try? It's just for testing purposes.

P.S. Try not to use flat cables.
 
Last edited:

mvadu

Regular Contributor
Thank you for the pointers. I did replace the cable and after 2 reboots it came back with 1gbps. I am still using a flat cable, but a different one. I should have thought of switching the cable before posting here.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top