AC66U B1 dnsmasq issue

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Yuuko

New Around Here
Hey Guys,

I set up my home network using an AC66U B1 router (running 384.17 firmware) and a raspberry pi. Here is my arrangements:

- The AC66U B1 router (192.168.50.1) connets to the ISP modem and serves as DHCP server of my network.
- The pi (192.168.50.2) is configured as default gateway (sice I need to proxy traffic in the network) and dns server for all other clients in the network.

To achieve this goal, I configure dnsmasq in asus router using dnsmasq.conf.add:
Code:
no-resolv
server=192.168.50.2

# pi configuration
dhcp-host=E3:A4:32:AE:F0:F5,set:pi,192.168.50.2
dhcp-option=tag:pi,option:router,192.168.50.1

# others
dhcp-option=option:dns-server,192.168.50.2

The problem is, while clients in my network do use 192.168.50.2 as default gateway and dns server, the IPV6 address of the asus router is also listed in their default gateway and dns server configuration.
Here is the output when running ipconfig /all on one of my windows PC in the network :
Code:
Default Gateway . . . . . . . . . : fe80::****:****:****:****%13 // local IPV6 address of asus router
                                    192.168.50.2
DHCP Server . . . . . . . . . . . : 192.168.50.1
DNS Servers . . . . . . . . . . . : 2409:8a28:8c7:****:****:****:****:**** // global IPV6 address of asus router
                                    192.168.50.2
NetBIOS over Tcpip. . . . . . . . : Enabled

Sice asus router's IPV6 address appears before 192.168.50.2 in the dns servers, clients in the network are actually using asus router as dns server rather than pi, which really bothers me.
I tried to override the IPV6 dns server with pi's local IPV6 address like this, but it doesn't work:
Code:
no-resolv
server=192.168.50.2

# pi configuration
dhcp-host=DC:A6:32:AE:F0:F4,set:pi,192.168.50.2
dhcp-option=tag:pi,option:router,192.168.50.1

# others
dhcp-option=option:dns-server,192.168.50.2
dhcp-option=option6:dns-server,[fe80::381f:149b:e4d7:2323] // local IPV6 address of pi
dhcp-option=lan,option6:23,[fe80::381f:149b:e4d7:2323]

Full version of my dnsmasq.conf is uploaded as an attachment.

Can someone help me solve this problem?
 

Attachments

  • dnsmasq.conf.txt
    1.1 KB · Views: 32
Last edited:

dave14305

Part of the Furniture
Did you remove the default entry for IPv6 DNS via dnsmasq.postconf? This line needs to be removed to avoid sending the router IP as DNS server.
Code:
dhcp-option=lan,option6:23,[::]
 

Yuuko

New Around Here
Did you remove the default entry for IPv6 DNS via dnsmasq.postconf? This line needs to be removed to avoid sending the router IP as DNS server.
Code:
dhcp-option=lan,option6:23,[::]
No I didn't. I will try this later.
Why the default entry dhcp-option=lan,option6:23,[::] won't be overrided by this line dhcp-option=lan,option6:23,[fe80::381f:149b:e4d7:2323] in dnsmasq.conf.add? I don't understand.
 
Last edited:

ColinTaylor

Part of the Furniture
Why the default entry dhcp-option=lan,option6:23,[::] won't be overrided by this line dhcp-option=lan,option6:23,[fe80::381f:149b:e4d7:2323] in dnsmasq.conf? I don't understand.
Because you have two conflicting statements. There's nothing in the documentation that states which one will take precedence. So you can't assume your statement will supersede the previous one.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top