AC68U and AC1900P are proxying DNS even when DNS is not enabled on router -- bug or something I can force?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

jonkaye

New Around Here
I am setting up a turnkey network system for my product with a linux server that is handling DHCP and DNS, so I have turned those off on the router. The system is designed to work with or without internet connectivity, but mostly without internet connectivity. I have both an RT-AC1900P and an RT-AC68U, both have same behavior here.

I also have reassigned the LAN range to 192.168.101.0, instead of leaving the default 192.168.1.0 range, because leaving it on the latter range might cause issues for some of my clients.

With the ethernet unplugged to internet, intentionally, and I try to access the page my.simsushare.site (which I have my server assigned to 192.168.101.2). I can see from pinging my.simsushare.site that the router is trying my ethernet's gateway, 10.0.0.1 (which is not connected, intentionally). Of course when I try this in the browser, I get a page from the router saying I should check if my ethernet plug is connected.

However, I have triple checked that the LAN has turned off DHCP and the DNS is set to my DNS server (which is 192.168.101.2). If I look at my windows wifi settings from a client, the DNS is correctly pointing to 192.168.101.2 and 8.8.8.8, the values my server is setting. Even on the WAN settings in the router admin panel I have turned that off and set the DNS server manually to 192.168.101.2. For good measure (and superstition), I even set a port range on the LAN page under DHCP (which is disabled) and I assign my server's MAC address in the manual table, with the correct IP address and DNS Server.

What's weird is that from one windows computer, if I connect over the 5G broacast, it seems to work, i.e., the router does not interfere and I get the right page -- most of the time. I then switch to the 2.4G connection and the router interferes. I go back to 5G, it works. On another windows computer, both do not work. After I do an ipconfig /renew, it usually starts working. I can't get this reliably to work.

I am at my wits end, it seems that the router is proxying a valid DNS setup to go check the ethernet cable. Somehow when I make a router admin change, it rights itself. Anyone have an idea why this proxying is happening and how to fix it?

Thank you for any assistance.
 

Attachments

  • dns is pointing to correct ip address.jpg
    dns is pointing to correct ip address.jpg
    84.6 KB · Views: 24
  • error message.jpg
    error message.jpg
    68.8 KB · Views: 22
  • router not using dns.jpg
    router not using dns.jpg
    74.2 KB · Views: 25
  • windows wifi profile assigned by my dhcp server through router.jpg
    windows wifi profile assigned by my dhcp server through router.jpg
    95.9 KB · Views: 21

john9527

Part of the Furniture
Maybe just an unlucky choice of addresses.
If you are running a 386 code base, ASUS has 'reserved' 192.168.101.x and 102.x addresses for use by the first guest network (closed source, so not sure everything they may be doing even if you aren't using the guest network). I'd try a different address range.
 

jonkaye

New Around Here
Thanks for the super quick response. I will consider a different address range, but it is a major change for my system. Odd part is I had different problems with Netgear routers. I did deploy a Linksys router last year fine on this address range, I am waiting to receive another Linksys router to see if I can duplicate that. Again, I appreciate your insight and response!
 

L&LD

Part of the Furniture
Down grade? No. :)
 

dave14305

Part of the Furniture
The fact that you are getting a 10.0.0.1 return address suggests that you may have the "Enable WAN down browser redirect notice" option enabled on the Admin / System page of the router. This would intercept outgoing DNS if the router thinks the WAN is down.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top