AC68U Bridge, Bad internet speed and drops. Error every third second: kernel: br0: received packet on eth2 with own address as source address

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

sabelstrom

New Around Here
Hi.

Im new here, have read post here in years but never needed to post anything.

I have a AC87U as main router using stock firmware 3.0.0.4.382_51939 every thing is good here.
I have a Netgear EX7000 as bridge using the 2.4GHz band, works fine.
When i set up my AC68U with Merlin 384.19 as Media Bridge using the 5.0GHz band i get bad internet speed and drops and the error kernel: br0: received packet on eth2 with own address as source address every third second.
I have googled the problem, found many people that have same error but no solution that have worked for me.

I have static ip on both bridges.
 

ColinTaylor

Part of the Furniture
Do the messages stop if your turn off the EX7000?

What devices do you have plugged into the AC87U's LAN ports?
 

sabelstrom

New Around Here
In the AC87U it is two usb drives, one cable from the bridged fiber modem/router and one cable to a switch.
From the switch to a desktop PC, one NAS and switch number two.
From switch number two to TV, Receiver, Tvbox, Xbox.
The only enabled WiFi is the 2.4GHz and the 5GHz from the AC87U.

Pulled the plug on the EX7000 and restarted the AC68U, still the same message.

Code:
Nov  5 23:40:38 kernel: br0: received packet on eth2 with own address as source address
Nov  5 23:40:38 kernel: br0: received packet on eth2 with own address as source address
Nov  5 23:40:38 kernel: br0: received packet on eth2 with own address as source address
Nov  5 23:40:38 kernel: br0: received packet on eth2 with own address as source address
Nov  5 23:40:41 kernel: br0: received packet on eth2 with own address as source address
Nov  5 23:40:41 kernel: br0: received packet on eth2 with own address as source address
Nov  5 23:40:41 kernel: br0: received packet on eth2 with own address as source address
Nov  5 23:40:41 kernel: br0: received packet on eth2 with own address as source address
Nov  5 23:40:57 kernel: br0: received packet on eth2 with own address as source address
Nov  5 23:40:57 kernel: br0: received packet on eth2 with own address as source address
Nov  5 23:40:57 kernel: br0: received packet on eth2 with own address as source address
Nov  5 23:40:57 kernel: br0: received packet on eth2 with own address as source address
Nov  5 23:41:00 kernel: br0: received packet on eth2 with own address as source address
Nov  5 23:41:00 kernel: br0: received packet on eth2 with own address as source address
Nov  5 23:41:00 kernel: br0: received packet on eth2 with own address as source address
Nov  5 23:41:00 kernel: br0: received packet on eth2 with own address as source address
Nov  5 23:41:17 kernel: br0: received packet on eth2 with own address as source address
Nov  5 23:41:17 kernel: br0: received packet on eth2 with own address as source address
Nov  5 23:41:17 kernel: br0: received packet on eth2 with own address as source address
Nov  5 23:41:17 kernel: br0: received packet on eth2 with own address as source address
 

ColinTaylor

Part of the Furniture
If the TV, Receiver, Tvbox or Xbox have WiFi adapters they must be disabled if they also have an Ethernet cable plugged in. If you don't disable the WiFi connection you may see that error message.
 

sabelstrom

New Around Here
Problem seems solved after i change the bridge to use the 2.4GHz band.
Changed it becouse it seems my 5GHz band disconnect from time to time and some time is gone. Will try a Merlin firmware to see if it get solved.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top