AC68U/Merlin 386.2_6 time scheduling working intermittently only?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Mine Ong

Regular Contributor
hi,

I've enabled AiProtection->Parental Controls->Time Scheduling and activated Time Management based on MAC addresses. This is because I don't want kids to have internet access late at night. However, I find it to be working only intermittently. Some times it works, and most of time it doesn't. As an example, I am currently typing this message on kid's computer when it is not supposed to have internet access.

Just want to confirm: is anyone else experiencing this problem? My set up is pretty trivial: After I flashed Merlin 386.2_6, I cleared NVRAM, specified a few port-forwarding rules, and a few static-DHCP IP addresses. Other than that, most of my settings were left at default. Most of my devices (with time scheduling) are on wired connection. Router is set to reboot on a weekly basis.

disabling/re-enabling (with hitting "Apply" at the bottom of the page) doesn't resolve the problem. Rebooting the router, however, does.

any help is very much appreciated,
 
Last edited:

Adooni

Regular Contributor
Parental control in Asus like most of rest solutions on market is a joke. The only good one on market is in Synology like RT2600AC or MR2200AC. If this feature is very important for you I would suggest to check it. It allow to easy setup w/o special scripts not only time like 6-8pm but total time per day like 2h a day.
 

RMerlin

Asuswrt-Merlin dev
With companies like Apple implementing MAC randomization, they are pretty much screwing up anyone trying to do any kind of network management these days... Toss that to the same pile of stupid ideas such as DoH that will screw up with network management.
 

Mine Ong

Regular Contributor
thanks for the prompt replies. My current solution is just to reboot the router more often. Not ideal, but at least it is automatic using AsusWRT/Merlin.

the devices under parental control are either 1) windows-10 PCs, and 2) android tablets. I have no Apple devices.

regards,
 

RMerlin

Asuswrt-Merlin dev
Another thing that can help with the Parental Control reliability is disabling hardware acceleration (this will limit your Internet speed to around 250-300 Mbps however).
 

Sharpbarb

Occasional Visitor
Another thing that can help with the Parental Control reliability is disabling hardware acceleration (this will limit your Internet speed to around 250-300 Mbps however).
How do you go about doing that these days (AX88U)? It used to be NAT acceleration, but now there's Runner and Flow Control. There doesn't appear to be a setting for these, they just get disabled when some incompatible feature gets turned on.
 

Natty

Occasional Visitor
Go to LAN --> Switch Control then set NAT Acceleration to disabled.
Alternatively, there is a link to this from LAN --> Switch control in AiProtection --> Parental Controls --> Time Scheduling
The link is underlined in the note in yellow text on the Time Scheduling tab.
Time scheduling seems to work ok on my RT-AC66U-B1 with 386.2_6 with NAT acceleration disabled.
 

dave14305

Part of the Furniture
Go to LAN --> Switch Control then set NAT Acceleration to disabled.
Alternatively, there is a link to this from LAN --> Switch control in AiProtection --> Parental Controls --> Time Scheduling
The link is underlined in the note in yellow text on the Time Scheduling tab.
Time scheduling seems to work ok on my RT-AC66U-B1 with 386.2_6 with NAT acceleration disabled.
It’s not a visible option for HND models.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top