AC68U - One of the CPU cores always hitting 100% when downloading

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

IceTea

Occasional Visitor
Like it says on the title, core 1 at 100% usage when downloading.

Ran 'top' on the router, and the culprit is [ksoftirqd/0].
ScreenShot_20210831185707.png


HW Acceleration is enabled. All the extra features are disabled(QoS, AI Protection, etc.)

Running the latest Merlin Firmware (386.3_2)
My WAN is PPPoE
LAN cable is CAT6

CPU Model BCM470x - Cortex A7 ARMv7 revision 0 - Rev. c0 (Cores: 2)
CPU Frequency 1000 MHz
CPU Load Average (1, 5, 15 mins) 0.12, 0.16, 0.19
CPU Temp ~60C

I have tried doing a Nuclear Reset as set out here https://www.snbforums.com/threads/major-issues-w-rt-ac86u.56342/page-4#post-495710

I don't even have any addons or amtm installed after the reset, but I still get the same behaviour.

Does anyone have any insight?

My main issue with this is that I got 1gbps fibre recently, and I seem to be bottlenecked at ~750mbps, whereas other people I know with the same router, gets about 920mbps... <Cries in first-word problems, even though I am in a third-word country>
 

ColinTaylor

Part of the Furniture
Where are you downloading to and what protocol are you using?
 

L&LD

Part of the Furniture
If you're not downloading to a USB attached drive, M&M time.
 

ColinTaylor

Part of the Furniture
From what I've read in these forums it appears to be a hardware limitation of the RT-AC68U when using PPoE connections. Link.
 

L&LD

Part of the Furniture
Maybe the hardware is done?
 

L&LD

Part of the Furniture
I hope not too.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top