AC86U DFS Channels Missing (Canada) Latest Firmware

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

rumipuffs

Occasional Visitor
I recently picked up a AC86U for a relatively good price. I bought it on the recommendation that it had DFS channels available (https://www.duckware.com/tech/wifi-in-the-us.html#routers). After reading a few threads here it seems like it's mainly available on EU or CN versions. But, also saw someone mentioned that it was enabled for US models starting from firmware 384.

I've tried updating the firmware with both official firmware and Merlin but I'm having no success at all. Only channels I can see are the non-DFS ones. According to Wiki DFS is allowed in Canada. Does anyone know if I have to do something specific to get it started? I don't have any option to change the country code.
 

L&LD

Part of the Furniture
Welcome @rumipuffs, I believe that you read that link incorrectly?

Below the table is a list of routers eliminated for NOT meeting these criteria
 

Jeffrey Young

Senior Member
My 86U gives me DFS channels as options in the dropdown box. I live here in the Great White North.

What software version are you running?
 

rumipuffs

Occasional Visitor
I've tried Merlin 384.19 and 386.1beta4 and the official firmware 386.41634 .

Each time, I tried factory reseting after upgrading but when I get to the drop down menu I can't see any DFS channels. Not sure if I'm doing something wrong. I've even tried switching it to router mode (initially trying with AP mode) but that doesn't seem to have made a difference either.
 

ColinTaylor

Part of the Furniture
Maybe your router isn't a Canadian model but some sort of grey import. Try SSHing into the router and running these commands:
Code:
nvram show | grep wl._country
nvram get territory_code
 

rumipuffs

Occasional Visitor
Maybe your router isn't a Canadian model but some sort of grey import. Try SSHing into the router and running these commands:
Code:
nvram show | grep wl._country
nvram get territory_code

wl_country_code=(blank)
wl_country_rev=987
territory_code=CA/02

Does that mean anything?
 

ColinTaylor

Part of the Furniture
I think you mis-typed the first command. Can you try it again.

Or maybe just do this instead:
Code:
nvram show | grep country | sort
 

ColinTaylor

Part of the Furniture
OK, thanks. So that confirms that it's a version tailored specifically for Canada so it should have DFS channels.

What do these produce:
Code:
nvram get wl1_chlist
nvram get wl_ifnames
 

ColinTaylor

Part of the Furniture
Can you see what this produces, I'm guessing it will be the same as above.
Code:
wl -i eth6 channels
 

ColinTaylor

Part of the Furniture
Yup same thing.
[email protected]:/tmp/home/root# wl -i eth6 channels
36 40 44 48 149 153 157 161 165
Oh dear. Maybe it's an early production model that wasn't certified for DFS. That would be a bit bizarre though. I think I'd contact Asus Canada and ask them whether that channel selection is correct or not.

EDIT: On the other hand, even if you had the DFS channels available you'd probably want to use 149 to 165 because they have the highest power.
 
Last edited:

L&LD

Part of the Furniture
What specific version of the firmware(s) did you test with?

Was a full reset performed afterward?

Fully Reset Router and Network

What settings do you change from defaults after a full reset to factory defaults? What other options/features do you use?

Can you post a screen snip of the General and Professional wireless GUI pages for the 5GHz band?

If changing any settings 'now' doesn't offer the option for 160MHz bandwidth, a full reset may reveal it if you leave things at their defaults.
 

Jeffrey Young

Senior Member
Oh I did. Sorry.

wl0_country_code=CA
wl0_country_rev=987
wl1_country_code=CA
wl1_country_rev=987

This is most interesting, despite purchasing my Router two years ago from a well known Canadian retailer (Staples), my router shows a different county code than Canada. This is the first I have checked this.

I will have to remember this when speaking to this topic as I have obviously spoke out of turn in this case.
 

rumipuffs

Occasional Visitor
Oh dear. Maybe it's an early production model that wasn't certified for DFS. That would be a bit bizarre though. I think I'd contact Asus Canada and ask them whether that channel selection is correct or not.

EDIT: On the other hand, even if you had the DFS channels available you'd probably want to use 149 to 165 because they have the highest power.

I bought this specifically to use DFS. The 5Ghz on non-DFS is super congested by neighbours (townhouse complex). Zoom/FaceTime is really bad during the day. If i can't get this to work I might give up and get Ubiquiti APs instead. Right now I'm using two TP-LINK APs and they don't have DFS, was hoping I could replace both with this one.

pro.png

What specific version of the firmware(s) did you test with?

Was a full reset performed afterward?

Fully Reset Router and Network

What settings do you change from defaults after a full reset to factory defaults? What other options/features do you use?

Can you post a screen snip of the General and Professional wireless GUI pages for the 5GHz band?

If changing any settings 'now' doesn't offer the option for 160MHz bandwidth, a full reset may reveal it if you leave things at their defaults.

I've factory reset each time I swapped firmwares, using the methods you mentioned in that link (found also during my search). Doesn't seem to really do anything.

I've only put the router in AP mode and then immediately look to see if DFS is enabled each time. So very miniimal changes.
 

rumipuffs

Occasional Visitor
This is most interesting, despite purchasing my Router two years ago from a well known Canadian retailer (Staples), my router shows a different county code than Canada. This is the first I have checked this.

I will have to remember this when speaking to this topic as I have obviously spoke out of turn in this case.

That's interesting. I bought mine at Staples too. Does yours say something like US or EU then?

Even on the box it says manufactured 2020 firmware 384. So, you'd think it would have DFS since it was approved in Canada in 2018.
 

L&LD

Part of the Furniture
Ah, is it because it is in AP mode that DFS channels are not being revealed?
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top