ac87 concurent client limit?

  • ATTENTION! As of November 1, 2020, you will not be able to reply to threads 6 months after the thread is opened. Threads will not be locked, so posts may still be edited by their authors.

strumf666

Occasional Visitor
Is there a practical limit to how many clients it can handle (in AP mode if it matters)? Atm I have around 20 clients connected, most to 2.4GHz, some on 5GHz, and after adding the last few (on 2.4) some of the existing clients on 5GHz are disappearing and I can only get them back after either a client restart, router restart or both. I am using a pfsense running on a pc for routing and ac87 is running merlin fw.
 

ColinTaylor

Part of the Furniture
What firmware version?

With only 20 clients spread across two bands there should be not problem at all.

What do you mean when you say you are "adding clients", adding them to what? Likewise "disappearing", disappearing from what?
 

strumf666

Occasional Visitor
Latest fw, I believe, I'll check when I get home.
Clients aren't spread evenly, most are on 2.4GHz, because they don't support 5GHz. The ones having problem are on 5GHz, though (a few RPi 3b+)
Adding meaning connecting clients to the wifi, disappearing meaning they can't be reached on the network.
 

ColinTaylor

Part of the Furniture
The number of clients you have connected to 5GHz should be no problem. The RT-AC87U is slightly unusual because it's provided by a Quantenna chip. That can sometimes be troublesome. When you next have the problem log into the router and a) check the syslog for error messages, and b) check the wireless log to see what devices it thinks are still connected.
 

strumf666

Occasional Visitor
FW is latest.
1.png

Both rpi's are missing and of course are unreachable as well. Phone and tablet works fine. No errors in syslog
A few refreshes later, on RPi appeared back and it is reachable and works as it should.

2.png


After a few restarts of the missing RPi it is also back and working normally.
I had very few problems like this in the past, but all of a sudden they appear almost daily.
I guess I'll switch the RPis to 2.4GHz.
 
Last edited:

ColinTaylor

Part of the Furniture
-70dBm is a pretty weak signal. Maybe the client is trying to roam to a different access point. Or maybe the router is forcibly disconnecting it.

Check that Smart Connect is disabled on the router. Also check that the Roaming assistant is disabled under Wireless - Professional - 5GHz. Untitled.png
 

strumf666

Occasional Visitor
RPi is running a music player os/distribution (volumio) which has option to store credentials for a single wifi network, so jumping around isn't an option, afaik. Is it possible to see if the router is forcibly disconnecting a client in log?
The other disappearing RPI has ~10dBm stronger singal, but it doesn't seem to make any difference. I have Roaming assistant se to disabled, not sure where to find smart connect. I don't think ac87 supports it.
3.png
 

ColinTaylor

Part of the Furniture
If it's only RPi's that are the problem it would sound like a compatibility issue. Turn off Universal Beamforming and MU-MIMO as those are known to cause problems with some devices. It also reminds me of this post here.

I don't know whether the log would normally show WiFi disconnects because I don't have that model router. Like I said, the 5GHz on the AC87U is different from the other models and probably doesn't display the same sort of information.

Maybe some other owners of the AC87U can make some suggestions.
 

strumf666

Occasional Visitor
Well this exact same setup worked without problems for a couple of years, and at the time when problems began I didn't upgrade or change anything, so I am a bit puzzled... Could be that router is starting to give up since it was damaged by lightning about a year ago (dead wan port), but until now it was working without a hitch.
Ok, will try what you suggested. Thanks.
 
Last edited:

sfx2000

Part of the Furniture
Could be that router is starting to give up since it was damaged by lightning about a year ago (dead wan port), but until now it was working without a hitch.
these devices are aging out - it's been a fair amount of time since the 87U was discontinued...

FWIW - random instability is usually a key indicator that the AC power adapter is getting "soft" and causing glitches.

Oddly enough - the 2.4GHz on 87U is usually fairly stable, most of the complaints on that model are related to the 5GHz Quantenna radio...
 

Sky

Regular Contributor
Is there a practical limit to how many clients it can handle (in AP mode if it matters)? Atm I have around 20 clients connected, most to 2.4GHz, some on 5GHz, and after adding the last few (on 2.4) some of the existing clients on 5GHz are disappearing and I can only get them back after either a client restart, router restart or both. I am using a pfsense running on a pc for routing and ac87 is running merlin fw.
Fwiw, I run a couple of the AC87's in different locations on OEM fw. One of them handles 45-60 concurrent clients in a mix of 2.4 GHz, 5 GHz and gigabit hardwire, the other handles 30-40 concurrent clients all WiFi in 2.4 & 5 GHz. There are multiple clients streaming video, security, & doing various internet/local routine work. These have been running since 2015 and capacity has never been a problem. I did have one client (an iPad securities trader) that suffered drops; it gave me a headache for years. That finally resolved last year I think it was and since then everything is rosey. So long story short, I think I'd look elsewhere for a cure to the issue.

WinFi (https://www.helge-keck.com/) and inSSIDer (https://www.metageek.com/products/inssider/) are superb utilities for troubleshooting and tweaking the WiFi, finding the best channel and frequency combinations, etc. There are also some detailed posts on the forum that delve into the "wonkier" side of some of the FW settings that may be helpful. However, before going to that much work, try out inSSIDer and WinFi. They may cure your issues toot sweet!

Sky
 

strumf666

Occasional Visitor
Well, I switched RPi's to 2.4 GHz and the issue still exists, so my second assumption that 5ghz is to blame is incorrect. I'll check WinFi and inSSIDer next, thanks for the suggestion.
 

Sky

Regular Contributor
Well, I switched RPi's to 2.4 GHz and the issue still exists, so my second assumption that 5ghz is to blame is incorrect. I'll check WinFi and inSSIDer next, thanks for the suggestion.
After evaluating your installation environment with the tools. Look for clear(er) channels in both 5GHz and 2.4GHz. Unless you have really old legacy B/G stuff you are trying to run:
  • On the 2.4 GHz band:
    • set your 2.4 to 'N' only, 40 MHz
    • set your 2.4 control channel to the "most empty" one you see, or that with the lowest external outside interference
    • leave the extension channel to the router's choice
  • On the 5 GHz band:
    • set your 5GHz to Auto (N only will slow it down)
    • set your bandwidth to the widest you can get away with (Everyone will say limit it to 40 or 20, like a good neighbor. You can do that, but try 80 — you can always cut it back)
    • set your 5GHz control channel to the "most empty" one you see
    • set Protected Management Frames 'Disable' unless you have a known overriding reason and need to use them
Let us know how it goes. I suspect what you're encountering is a lot of external interference plaguing your WiFi.

Sky


P.S. Please define "RPi's" for those of us with old brains who don't think in shorthand.
 

ColinTaylor

Part of the Furniture
P.S. Please define "RPi's" for those of us with old brains who don't think in shorthand.
Raspberry Pi

Well, I switched RPi's to 2.4 GHz and the issue still exists, so my second assumption that 5ghz is to blame is incorrect. I'll check WinFi and inSSIDer next, thanks for the suggestion.
Is it still only the RPi's that are having problems?
 

strumf666

Occasional Visitor
Still only RPI's having the problem; laptop, phone and tablet work normally on both frequencies.
For 5GHz (Domain666_5G) all setting are already set as @Sky recommended and I am the only one in range using it, so interference is quite unlikely to be the cause of the problem.
For 2.4GHz (Domain666) I changed settings according to @Skys recommendation; I hope it makes a difference.
Screenshot_20201015_045758_abdelrahman.wifianalyzerpro.jpgScreenshot_20201015_045746_abdelrahman.wifianalyzerpro.jpg
 
Last edited:

Sky

Regular Contributor
If the dominant network in each graph is yours, and
assuming the graph with only one network showing is 5 GHz…


2.4 GHz channel is off according to the graph; it would perform better on ch-1
5 GHz channel is fine but the bandwidth is narrower than it needs to be, I'd suggest maxing that.

My opinion only, of course. YMMV
 

Sky

Regular Contributor
I changed 2.4GHz channel to 1. What makes you think it will work better on 1? I get a lot of overlap in both cases.
How would you suggest to max bandwidth for 5GHz?
You can go here to educate yourself about how 2.4 WiFi works.

All devices are built to play nicely in the "prime channel" spaces. Essentially, channels 1/6/11 are 802.11b (legacy) "prime" channels with 22 MHz of bandwidth each and no overlap. Like a 3-lane highway, the traffic here runs smoothly — in 802.11b. In 802.11g/n you have more channels, but less bandwidth (20 MHz), and again they can play nicely together staying in their lanes 1/5/9/13. Of course, to use #13 you'd have to have #13 available to select. You may, I do not. Then you have 802.11n — n has fat bandwidth (40 MHz) but only two prime channels, 3 & 11.​
Now, if you did set yours to [N only] as recommended, assuming you are Domain666, it appears you were set to ch-10. This is akin to the guy who's changing lanes weaving in and out of traffic all the time. Only when he weaves he hits something (collision) and everything slows down, sometimes to a crawl, sometimes to a stop, because he's not staying in his lane and playing nice. Assuming your fisrt graph showing 2.4GHz (in blue) is 2.4GHz and assuming you are set to [N only] in your router, then channel 3 would be ideal. It's prime and pretty much not there — except, again assuming Domain666 is you — there is a secondary 2.4GHz broadcast on that domain at ch 5 (again weaving unless it's g/n) and that has very low quality and is crowded by at least 3 competing broadcasts with much higher signal strengths two of which are not yours. It sure likes lie it's set to g/n to me, and that's a problem.​
So... pick your setup. My recommendation was [N only] [40 MHz] in which case you'd want ch-3 as ch-11 has crowding from 'Irena'.​
Legacy (802.11b) would net ch-1 as the least crowded Prime. IMO, g/n is a waste unless your R-pi's run on g? If they do you'd have to go [Auto] and you may need to play with your bandwidth like trying 20MHz to make your signal "skinny", essentially splitting the lanes like a motorcycle, to cut interference as 40MHz may be just too much traffic "merging" traffic.​
In your newest phone screen shot (my those are hard to read on a desktop) it looks like you are running g/n instead of N-only and you have a weak signal on ch-5 (g/n) and a strong signal on ch-3 (n).​
If your R-pi's run N you are making a mess because they are trying to find an open lane on a very crowded multi-lane bridge packed with traffic. They keep weaving between lanes 0 & 9, crossing over lanes 1-8 enroute and only making some progress on lane 3 while crawling on lane 5 and near-stopped the rest of the time. I am guessing this is the root of the problem. Your setup creates it's own traffic jams!​
If I'm right, your best setup for 2.4GHz here is [N only].​

This is from the AC87 OEM firmware display, yours may be slightly different:
  • Wireless > General | Band (5GHz) Channel bandwidth (80 MHz)
 

strumf666

Occasional Visitor
Domain666/5G are my SSIDs.; Domain665 too, but thats another router in the basement so not important in this case.
RPi's are b/g/n/ac, before this issue I had them on 5GHz, and I plan to return them to 5GHz if possible.
Thanks for the explanation; I wasn't aware of prime channels, I thought they were all equal.
In the above pictures I had set the 2.4 to N only and 40MHz, in this picture I changed control channel to 3; bigger picture attached, hope you can see it better.
For 5GHz I had set the bandwidth to 80MHz in the picture above.
Screenshot_20201016_205821_abdelrahman.wifianalyzerpro.jpg
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top