1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

[AC87U] Issue with OpenVPN Client - no internet

Discussion in 'Asuswrt-Merlin' started by ZeMitras, Oct 16, 2019.

  1. ZeMitras

    ZeMitras New Around Here

    Joined:
    Oct 16, 2019
    Messages:
    4
    Location:
    Portugal
    Hello!

    This is my first post here, although I've been using Asus hardware from long time ago. I own an Asus RT-AC87U and since I discover asuswrt Merlin my life became brighter.

    I've tried to draw a simplified version of my network setup (luckily I still maintain some paint skills form my collage time):
    upload_2019-10-16_14-54-30.png
    In summary, my telco router does not allow bridge mode, and so I setup the DMZ to my Asus RT-AC87U.
    I've setup an OpenVPN Server running in AC87U which works flawassly.

    The problem is with the OpenVPN Client (to my VPS which is running an OpenVPN server).
    When I enable the OpenVPN Client, the session is established and I see the correct external IP (from my VPS) but every LAN device that I force (via policy) to use this VPN looses the contact with the internet (I cant reach any outside site).

    What I have already tested, after I enable the VPN Client:
    - I've check that the devices ping the router and other LAN devices with normal ping times (< 8 ms in wifi)
    - I've checked that the OpenVPN clients can reach the pi-hole DNS server machine and resolve the DNS.
    - Even so, and to simplify this debug, I've setup 1.1.1.1 DNS server (WAN tab) and made sure that the "LAN - DCHP Server" tab the DNS is set to the router (10.10.10.1) but no luck either

    Router config screens:
    home page:
    upload_2019-10-16_15-29-44.png
    wan page:
    upload_2019-10-16_15-41-5.png

    openvpn client config page:
    upload_2019-10-16_16-2-22.png

    system log - routing page:
    upload_2019-10-16_16-3-19.png

    I would appreciate any help you could provide.
    Thanks in advance!
     
  2. Zastoff

    Zastoff Senior Member

    Joined:
    Nov 21, 2017
    Messages:
    310
    Test on vpn client page to set compression=None
    Edit:
    Also look for clues in syslog
    And Welcome to the forum :)
     
    Last edited: Oct 16, 2019
  3. ZeMitras

    ZeMitras New Around Here

    Joined:
    Oct 16, 2019
    Messages:
    4
    Location:
    Portugal
    Hello Zastoff! Thanks for your reply.
    I dont understand what happened, I tried to set compression=None and nothing changed, but when I reverted compression=disabled it started to work... I dont understand why, but it is working! Thanks for the help

    EDIT:
    I think i've found the cause, the VPN Server was running simultaneously and apparently this causes the VPN CLient to not work properly.
     
    Last edited: Oct 16, 2019