1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

AC87U: problems with BT Television

Discussion in 'ASUS AC Routers & Adapters' started by acherubini, Jan 24, 2015.

  1. acherubini

    acherubini New Around Here

    Joined:
    Jan 24, 2015
    Messages:
    3
    Hallo,
    I am using the ASUS RT-AC87U with network provided by BT Infinity, i.e. it is linked to the BT OpenReach modem. The TV is connected via the BT Vision box, which is connected to the ASUS via ethernet.

    It's working fine apart from one serious problem: none of the HD channels are showing, and of course none of the "special" channels e.g. BT sport etc.
    They were working fine with the BT Homehub router.

    When resetting the BT Vision box, it gives an error: "Your BT Homehub should be at least version 2" or similar. After that, if I try to see one of those channels, I just get a black screen with a message "Broadband interruptions are affecting this channel" (or similar words).

    Has anybody had a similar problem? Any idea how to solve it?

    Thanks in advance
     
  2. scaramonga

    scaramonga Regular Contributor

    Joined:
    Jan 15, 2015
    Messages:
    54
    I have BT Infinity, but I don't have this router. Assuming the features are the same, set accordingly for IPTV:

    Under WAN, set 'Enable VPN + DHCP Connection' to 'No'

    Under LAN/IPTV, set these

    - 'Select ISP Profile' = None
    - 'Choose IPTV STB Port' = None
    - 'Use DHCP routes' = Microsoft
    - 'Enable multicast routing (IGMP Proxy) = Enable
    - 'Enable efficient multicast forwarding (IGMP Snooping) = Enable
    - 'UDB Proxy (Udpxy) = 0

    Had to do this on my AC68U, and all working fine with BT TV now :)
     
  3. CirenJules

    CirenJules New Around Here

    Joined:
    Dec 14, 2015
    Messages:
    1
    When previously on Sky aDSL, I ran a Draytek 120 modem and ASUS N66U running Merlin firmware. After moving to BT Infinity1, I wanted an alternative to the HH5 so upgraded to a Draytek 130 VDSL modem and ASUS RT-87U running Merlin RT AC87U_378.56_2 firmware.

    Like many other people, the issue I had was that the HH5 worked fine with streaming services including BT TV, BT Sport and iPlayer etc. via YouView - but the ASUS didn’t; I kept getting the dreaded IPC 6023 even though the LAN info. was right and the displayed YouView time/clock was remained accurate.

    After spending many hours researching and then resolving this issue, I wanted to share what I learnt including the ‘must do’ steps which worked for me:

    1. The Draytek130 and ASUS routers do work with Infinity1 and YouView for both BT TV/Sport & the Players
    2. A fundamental point is not to forget about your modem set-up as well as your router
    3. The BT YouView services are based around multi-cast which in turn needs igmp-related services to be running on your IPTV compatible router
    4. ASUS introduced a bug into a past version of their vanilla firmware which specifically affected only PPPoE and which resulted in a zeroconf error; meaning that igmpproxy-services didn’t start. Merlin unknowingly inherited the bug but then worked with others to fix-it (thank you Merlin http://www.snbforums.com/threads/asuswrt-merlin-378-54_2-is-now-available.24902/page-6). The latest versions of the ASUS vanilla and Merlin are good.
    5. Steps:
    a. Log-on to your ASUS router as Admin
    b. Check your Firmware version; upgrade if necessary but before doing so take screen-shots of each config. page if you’ve got a complex configuration; back-up the Conf. too
    c. Once you’ve upgraded the firmware, do a manual hard reset back to factory using the button on the back of the Router
    d. Do not be tempted to load any previously saved router configurations; start clean
    e. Log-on to the Router as Admin – on the various sections/tabs:
    i. ASUS LAN - Router needs to allocate a fixed LAN IP to the YouView box: in my case 192.168.50.28
    ii. ASUS LAN – IPTV settings:
    upload_2015-12-14_13-20-47.png
    iii. ASUS WAN – apply a number of Forwards to the YouView box:
    upload_2015-12-14_13-19-41.png
    f. You may not need all the above Forwards, but I’ve just had enough playing around with this and now have a configuration that works! Someone commented that these worked with an earlier BT Vision and they just kept them when they went to BT TV
    g. You have to disable DHCP+VPN on the WAN page; ASUS have enabled this by default (as it's necessary to connect with some Russian ISPs apparently). If you don’t do this, the router will use DHCP on the WAN interface which is an issue
    h. Reboot the Router via the Admin home page; YouView box powered off
    i. Power up the YouView box; check it’s got the static LAN IP address in e.i above
    j. Log-on to the Draytek as admin via Ethernet into the single modem WAN port (192.168.2.1)
    k. Under ‘Internet Access’ on the modem, change the default MPoA setting from ‘disable’ to ‘enable’ >>This is what made the difference on my set-up<<
    l. After I made this change, I struggled to log back on to the Draytek modem home page as Admin; I ignored this and moved to Step m. below
    m. Reconnect the Ethernet cable from the ASUS router WAN port to the Draytek modem WAN Port
    n. BT YouView should now display a picture and sound; the ‘Players’ should work too; my Sky+ box also continued to download Catch-Up TV/Boxsets etc. (This Sky HD box and the YouView connect to the N66U via 2x ethernet cables; N66U redeployed as an Access point; connected from an 87U LAN port into the WAN port on the N66U via BT Powerline adaptor and ethernet)
    o. If you have a second YouView box, just plug this into another LAN Port on the ASUS and it will work*
    *You will need to pay for ‘multi-room’ for this to work; you will see a message in red on your other ‘primary’ YouView box which states BT have identified a second YouView box and you can only have 1 with the basic subscription!

    I hope that helps. Manoj from Draytek support was very helpful. Any questions or feedback please let me know.
     
    atefish and Embattle like this.
  4. Embattle

    Embattle Regular Contributor

    Joined:
    Apr 17, 2013
    Messages:
    98
    Thanks, I think part K. of your guide finally resolved my IPTV issues with BT and my Vigor 130.
     
  5. atefish

    atefish New Around Here

    Joined:
    Apr 13, 2016
    Messages:
    1
    Thank you CirenJules, this got me out of a hole, thought I was going to have to back to the HH for a while <shudder>

    Now flying with My ASUS RT-87U (using the BT supplied white modem box). UHD TV now working as expected.