AC88U no 5Ghz

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

tennbrikket

Occasional Visitor
Hello :) i picked up an used AC88U to replace my old ac66u. I've just installed merlin software and did a factory reset right after. But the 5ghz led lamp is not indicating anything. Also i have no 5GHZ client in device list. My oneplus 7t which is sitting next to the router should auto connect to 5ghz. Also when i open wifi analyzer its not showing any 5ghz close by, only 2.4ghz. Is my router faulty? , must sucks since i bought it used from an "old" lady which probably had no clue, i guess its out of warranty as well :/ . Are there any fixes i could try to solve the problem? Wifi setting is set to dual band smart connect. Firmware is merlin RT-AC88U_384.14_2
 

ColinTaylor

Part of the Furniture
Put the stock Asus firmware back on it and do a factory reset (and complete power off/on). If it still doesn't work it's likely to be faulty.

P.S. Try it without Smart Connect.
 

Grisu

Part of the Furniture
First disable SmartConnect and set fix channel 36 (works worldwide on all 5GHz devices)!
Maybe your one+ doesnt support the channel used by router.
 

tennbrikket

Occasional Visitor
First disable SmartConnect and set fix channel 36 (works worldwide on all 5GHz devices)!
Maybe your one+ doesnt support the channel used by router.

Hi and thanks for reply. I've disabled snart connect, but i am unable to change the channel. I am in settings->advanced->wifi->general-> 5ghz current control channel 0. This in on stock firmware btw
 

bitsbytes

Senior Member
channel 0 usually is an indication of faulty hardware, which i'm seeing a lot lately here !!!!!
 

ColinTaylor

Part of the Furniture
Remove the power lead from the router but leave its power button in the on position so as to drain all current from the device. Wait a couple of minutes before powering it back on again. You might get lucky.
 

tennbrikket

Occasional Visitor
Remove the power lead from the router but leave its power button in the on position so as to drain all current from the device. Wait a couple of minutes before powering it back on again. You might get lucky.

I have just tried it without any luck :/
 

tennbrikket

Occasional Visitor
Luckily i have recieved the receipt and all electronics which are bought in Norway has 5 years warranty by law :). I've requested an RMA case now, so hopefully i will recieve a new one. The device was bought at a well known electronic shop, which has fantastic customer service, so this should get resolved pretty fast.
 

royarcher

Very Senior Member
Hello :) i picked up an used AC88U to replace my old ac66u. I've just installed merlin software and did a factory reset right after. But the 5ghz led lamp is not indicating anything. Also i have no 5GHZ client in device list. My oneplus 7t which is sitting next to the router should auto connect to 5ghz. Also when i open wifi analyzer its not showing any 5ghz close by, only 2.4ghz. Is my router faulty? , must sucks since i bought it used from an "old" lady which probably had no clue, i guess its out of warranty as well :/ . Are there any fixes i could try to solve the problem? Wifi setting is set to dual band smart connect. Firmware is merlin RT-AC88U_384.14_2
Have you turned off smart connect pressed save and tried then ?
 

royarcher

Very Senior Member
Yes, did not solve the issue. Based on what i have been reading on this forum the ac88u seems to have 5ghz radio issues. Hopefully i will just get a replacement.
I've been lucky with mine.had it running all day (streaming) for years without any problems
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top