Access modem behine router (with VLAN)

abcxyz

Occasional Visitor
Capture.PNG


Hello,

Here is my network topology. And I want to access my ISP modem web GUI from PC, laptop... I try to do by following this article but it didn't work: https://github.com/RMerl/asuswrt-merlin.ng/wiki/Access-modem-Web-UI-on-WAN-port-(no-script)

Please help me to do this.

Thanks in advanced!
 

archiel

Senior Member
View attachment 37859

Hello,

Here is my network topology. And I want to access my ISP modem web GUI from PC, laptop... I try to do by following this article but it didn't work: https://github.com/RMerl/asuswrt-merlin.ng/wiki/Access-modem-Web-UI-on-WAN-port-(no-script)

Please help me to do this.

Thanks in advanced!
Assuming that you have merlin installed on the AX56U (you haven't said), there are various threads on how to access your modem, I have done it by enabling scripts and then using WinSCP to add wan-event to /jffs/scripts
Code:
#!/bin/sh

if [ "$2" = "connected" ]; then
  ifconfig $(nvram get wan"$1"_ifname):1 192.168.0.2
fi
and setting permissions to 0755.
 

abcxyz

Occasional Visitor
Assuming that you have merlin installed on the AX56U (you haven't said), there are various threads on how to access your modem, I have done it by enabling scripts and then using WinSCP to add wan-event to /jffs/scripts
Code:
#!/bin/sh

if [ "$2" = "connected" ]; then
  ifconfig $(nvram get wan"$1"_ifname):1 192.168.0.2
fi
and setting permissions to 0755.
I'm using merlin fw with newest version 386.4_beta1 but your script didn't work :(
 

archiel

Senior Member
Did you restart the router or run the wan-event script after creating it?

The script should create an entry for eth0:1

So running ifconfig I can see that on my setup the script created

Code:
eth0:1    Link encap:Ethernet  HWaddr {MAC of AX88}
          inet addr:192.168.0.2  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING ALLMULTI MULTICAST  MTU:1500  Metric:1

And in the System Log> Routing Table you should see
Code:
Destination    Gateway    Genmask        Flags    Metric    Ref    Use    Iface
192.168.0.0       *     255.255.255.0     U          0         0     0     WAN

So if I enter 192.168.0.1 into a browser it loads the modem homepage.
 

abcxyz

Occasional Visitor
Sure, I restarted my router several times but this script not working

Code:
[email protected]:/tmp/home/root# ifconfig eth0:1
eth0:1    Link encap:Ethernet  HWaddr ABCDEF
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

This command: ifconfig eth0:1 didn't show ip address.!!

In the System Log> Routing Table show

Code:
192.0.0.0    *    255.0.0.0    U    0    0    0    MAN

I can ping 192.168.0.2 but can't ping 192.168.0.1
 

archiel

Senior Member
What are your LAN IP and WAN IP settings?

if you run ifconfig, what is showing for eth0, is is showing your external / public IP?

i.e.
Code:
eth0      Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx
          inet addr:{WAN IP}  Bcast:xxx.xxx.xxx.255  Mask:255.255.252.0
          inet6 addr: fe80::aa5e:45ff:feae:5050/64 Scope:Link
          UP BROADCAST RUNNING ALLMULTI MULTICAST  MTU:1500  Metric:1
          RX packets:159247358 errors:0 dropped:61026 overruns:0 frame:0
          TX packets:89987045 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:177819007169 (165.6 GiB)  TX bytes:47170644192 (43.9 GiB)
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top