Access modem configuration page

vprasinos

Occasional Visitor
Hello, this is my first post here as a new owner of the RT-N66U. Maybe this question has been answered before but I looked through many threads in this forum before asking without a definitive answer.

I am trying to see the config page of my Linksys WAG200G that has been flashed with openwag and used only as a modem (Modem only option) so DHCP automatically disabled. The RT-N66U is used as a router and the PPPoE connection is done with it. My setup is as follows:

WAG200G (modem) IP: 192.168.0.1 - Subnet mask: 255.255.255.0
RT-N66U IP: 192.168.1.1 - Subnet mask: 255.255.255.0

The two devices are only connected with a Cat5e from LAN port of WAG200G to WAN port of RT-N66U. Is there any way to access the config page of WAG200G? When trying from a computer connected to the asus router I get connection timed out. Maybe there is a routing scheme I can enter in the LAN - Route page of the RT-N66?

Note: I tried connecting a 2nd ethernet cable from a LAN port of RT-N66U to a LAN port of WAG200G and managed to access it (by first giving an IP 192.168.1.254) but this method proved strange as it kept creating strange messages in the log i.e. "kernel: vlan1: received packet with own address as source address" every 2-3 seconds or so.
 

vprasinos

Occasional Visitor
Thanks for your answer, but if u see my note in the end, I already did that (I used 192.168.1.254 with 192.168.1.1 being the Asus router - i.e. same subnet). By simply entering 192.168.0.1 won't get me to the config page if the 2 devices are only connected with one Ethernet cable.
In order for this method to work, an extra Ethernet cable is needed from RT-N66's LAN port to a LAN port of WAG. I don't want to do this for 2 reasons:

1. An extra LAN port is occupied
2. A message appears in the log every 3 seconds flooding my DHCP log.



Any other solution? Preferably one that does not involve a switch?


Sent from my iPad using Tapatalk HD
 

Pericynthion

Senior Member
I believe you need to enter a static route on the WAG for the 192.168.1.x subnet, being via 192.168.0.y (where 0.y is the WAN port IP address of the N66).

-Right now your internal device (192.168.1.x) doesnt know about 192.168.0.x so it passes the packets to its default gateway (the N66).
-The N66 knows about 192.168.0.x being directly connected via its WAN interface (192.168.0.y), so passes the packets directly to the WAG.
-The WAG process the packet but doesnt have a route back to the original 192.168.1.x client, so it will pass it out to its default gateway (probably the uplink to the ISP).

If you run a netstat -nr on the WAG I think you'll see it only knows about the directly connected networks and its default route.
 
Last edited:

jlake

Very Senior Member
My DSL modem is in bridge mode. It has a default IP address of 192.168.1.254

To access it, I simply slide the Ethernet cable from the Asus Rt-n66u's wan port over to one of the rt-n66u's LAN ports. And then type 192.168.1.254 in a web browser address bar.

I don't have much need to look at DSL logs and statistics on a regular basis, so that method works for me. Obviously you'll temporarily lose Internet to your network while your logged in to the bridged modem GUI. When I'm done, I just slide the Ethernet cable back to the wan port.
 
Last edited:

vprasinos

Occasional Visitor
->Pericynthion

Thanks for your explanation, I understand what you are saying but I have 2 questions:
1. Since the WAG is in bridge mode, doesn't it disable all routing functions? I'll try it anyways when I get back home.
2. The WAN IP of RT can be seen in the "Network Map" and is the one that the ISP has given me. Is there a second WAN IP that is internal of the form 192.168.0.y??


->jlake

That process is exactly what I am trying to avoid. I need a permanent connection to the WAG modem, I don't want to be changing cables from and to the asus router since the devices are a bit far away. Besides you also need to be changing the connected computers IP to a static one that resides within the WAG modem's subnet (192.168.0.x), a bit time consuming.
 

truva

New Around Here
If you are using Merlin's firmware, here is a definitely working way of accessing modem interface through the router:

1. Give your modem an IP that is outside the router's ip range. (Your IP numbers 192.168.0.1 for modem and 192.168.1.1 for router are ok).

2. Enable jffs partition.

3. You need to add two scripts to the /jffs/scripts directory, namely wan-start and nat-start scripts.


wan-start script :

#!/bin/sh
ifconfig `nvram get wan0_ifname`:0 192.168.0.2 netmask 255.255.255.0

Note : the IP number shown in bold must be one more than your modem's IP. If your modem's ip is 192.168.0.1 then it must be written as 192.168.0.2.


nat-start script :

#!/bin/sh
iptables -t nat -I POSTROUTING -o `nvram get wan0_ifname` -j MASQUERADE



Before adding scripts, you can check if this works for you easily. Just SSH to your router and enter the commands in the scripts (you can use copy-paste). Then open a browser session to your modem (192.168.0.1 in your case) and there is your modem interface.

Adding scripts just makes sure that the commands are run on router startup.

--
 
Last edited:

mich

Occasional Visitor
WAG200G (modem) IP: 192.168.0.1 - Subnet mask: 255.255.255.0
RT-N66U IP: 192.168.1.1 - Subnet mask: 255.255.255.0
Your PC's subnet mask should be 255.255.255.0 too, so you have two subnets, your LAN and your Modem. I have a similar setup which works without problems. If it doesn't for you, maybe your modem will only serve its web interface to devices on the same subnet. You could try to change the modem's subnet mask to 255.255.254.0 (or 255.255.0.0), maybe that helps.
 

vprasinos

Occasional Visitor
-> mich

Well, the WAG's interface does not allow a subnet mask other than 255.255.255.x. So not an option. But thanks for letting me know the case.

-> truva

Perfect answer! Exactly what I was looking for. Thanks a lot!
 

tuxing

New Around Here
If you are using Merlin's firmware, here is a definitely working way of accessing modem interface through the router:

1. Give your modem an IP that is outside the router's ip range. (Your IP numbers 192.168.0.1 for modem and 192.168.1.1 for router are ok).

2. Enable jffs partition.

3. You need to add two scripts to the /jffs/scripts directory, namely wan-start and nat-start scripts.


wan-start script :

#!/bin/sh
ifconfig `nvram get wan0_ifname`:0 192.168.0.2 netmask 255.255.255.0

Note : the IP number shown in bold must be one more than your modem's IP. If your modem's ip is 192.168.0.1 then it must be written as 192.168.0.2.


nat-start script :

#!/bin/sh
iptables -t nat -I POSTROUTING -o `nvram get wan0_ifname` -j MASQUERADE



Before adding scripts, you can check if this works for you easily. Just SSH to your router and enter the commands in the scripts (you can use copy-paste). Then open a browser session to your modem (192.168.0.1 in your case) and there is your modem interface.

Adding scripts just makes sure that the commands are run on router startup.

--

hi truva,
i tried these commands on my rt-n16 dualwan setup.
my modem(192.168.1.1) is connected to primary wan in bridged mode.
so i changed 192.168.0.2 to 192.168.1.2.
but these command dont seem to work for my dualwan setup.

any suggestions?

thanks
 

VinceV

Regular Contributor
hi truva,
i tried these commands on my rt-n16 dualwan setup.
my modem(192.168.1.1) is connected to primary wan in bridged mode.
so i changed 192.168.0.2 to 192.168.1.2.
but these command dont seem to work for my dualwan setup.

any suggestions?

thanks
For this setup to work, your modem's IP address needs to be on a different subnet than your LAN. So, try changing your modem's IP to 192.168.0.1.
 

tuxing

New Around Here
My router ip is 192.168.3.1 , so modem ip of 192.168.1.1 must be ok right?

Sent from my GT-I9500 using Tapatalk HD
 

VinceV

Regular Contributor
My router ip is 192.168.3.1 , so modem ip of 192.168.1.1 must be ok right?

Yes. If your router doesn't have any interfaces on the 192.168.1.XXX network, that that should be fine. Maybe things are a bit different in a dual-WAN setup. Can you ping the modem IP directly from the router?
 

tuxing

New Around Here
Yes. If your router doesn't have any interfaces on the 192.168.1.XXX network, that that should be fine. Maybe things are a bit different in a dual-WAN setup. Can you ping the modem IP directly from the router?

I am unable to ping the modem ip from the router.

Sent from my GT-I9500 using Tapatalk HD
 

tuxing

New Around Here
Thanks vincev

ifconfig output

ASUSWRT RT-N16_3.0.0.4 Wed Jul 24 19:27:34 UTC 2013
[email protected]:/tmp/home/root# ifconfig
br0 Link encap:Ethernet HWaddr E0:CB:4E:C0:0C:69
inet addr:192.168.3.1 Bcast:192.168.3.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:186444 errors:0 dropped:0 overruns:0 frame:0
TX packets:229264 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:18519734 (17.6 MiB) TX bytes:286510655 (273.2 MiB)

eth0 Link encap:Ethernet HWaddr E0:CB:4E:C0:0C:69
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:751965 errors:0 dropped:0 overruns:0 frame:0
TX packets:694348 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:767632746 (732.0 MiB) TX bytes:512361910 (488.6 MiB)
Interrupt:4 Base address:0x2000

eth1 Link encap:Ethernet HWaddr E0:CB:4E:C0:0C:69
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:147478 errors:0 dropped:0 overruns:0 frame:36019
TX packets:208945 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:13652552 (13.0 MiB) TX bytes:271724269 (259.1 MiB)
Interrupt:3 Base address:0x1000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MULTICAST MTU:16436 Metric:1
RX packets:749 errors:0 dropped:0 overruns:0 frame:0
TX packets:749 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:84850 (82.8 KiB) TX bytes:84850 (82.8 KiB)

ppp0 Link encap:point-to-Point Protocol
inet addr:117.204.117.17 P-t-P:117.204.112.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING MULTICAST MTU:1460 Metric:1
RX packets:200628 errors:0 dropped:0 overruns:0 frame:0
TX packets:143689 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:276876888 (264.0 MiB) TX bytes:10521818 (10.0 MiB)

vlan1 Link encap:Ethernet HWaddr E0:CB:4E:C0:0C:69
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:206418 errors:0 dropped:0 overruns:0 frame:0
TX packets:360215 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:18898462 (18.0 MiB) TX bytes:480745119 (458.4 MiB)

vlan2 Link encap:Ethernet HWaddr E0:CB:4E:C0:0C:69
inet addr:169.254.134.178 Bcast:169.254.255.255 Mask:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:213725 errors:0 dropped:0 overruns:0 frame:0
TX packets:144950 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:279942076 (266.9 MiB) TX bytes:14300918 (13.6 MiB)

vlan3 Link encap:Ethernet HWaddr E0:CB:4E:C0:0C:69
inet addr:192.168.2.102 Bcast:192.168.2.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:331822 errors:0 dropped:0 overruns:0 frame:0
TX packets:189183 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:462061734 (440.6 MiB) TX bytes:17315873 (16.5 MiB)

route output

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
117.204.112.1 * 255.255.255.255 UH 0 0 0 ppp0
192.168.2.1 * 255.255.255.255 UH 0 0 0 vlan3
192.168.3.0 * 255.255.255.0 U 0 0 0 br0
192.168.2.0 * 255.255.255.0 U 0 0 0 vlan3
169.254.0.0 * 255.255.0.0 U 0 0 0 vlan2
127.0.0.0 * 255.0.0.0 U 0 0 0 lo


thanks
 

VinceV

Regular Contributor
Okay, none of your interfaces have an address on your modem's subnet...

What happens if you run this command:

Code:
ifconfig `nvram get wan0_ifname`:0 192.168.1.2 netmask 255.255.255.0

Do you get any error messages? Does it add an address to your WAN interface? Can you ping the modem?
 

tuxing

New Around Here
just tried the ifconfig command
got no error messages
it seems to add a new address for vlan2 - modem?

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
117.207.160.1 * 255.255.255.255 UH 0 0 0 ppp0
192.168.2.1 * 255.255.255.255 UH 0 0 0 vlan3
192.168.3.0 * 255.255.255.0 U 0 0 0 br0
192.168.2.0 * 255.255.255.0 U 0 0 0 vlan3
192.168.1.0 * 255.255.255.0 U 0 0 0 vlan2
169.254.0.0 * 255.255.0.0 U 0 0 0 vlan2
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
default 117.207.160.1 0.0.0.0 UG 0 0 0 ppp0

can ping the modem at 192.168.1.1 now

but cant reach the modem page at 192.168.1.1

thanks
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top