1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Actiontec ECB6200 direct connection slow speed

Discussion in 'MoCA, HomePlug, HPNA' started by dashrendar, Aug 13, 2019 at 10:14 AM.

  1. dashrendar

    dashrendar New Around Here

    Joined:
    Tuesday
    Messages:
    6
    Hi all,

    This is my first post. I currently have a single router (Netgear R7000 with FreshTomato firmware) serving a single Ethernet to a Synology NAS and the rest of the devices in the house through WiFi 2.4 and 5 Ghz.

    My main computer connects to the router through an Ethernet Adapter (ASUS EA-N66). Maximum speeds I get on it when I transfer large files back and forth between my main computer and the NAS are about 110-120 Mbps.

    I recently learned about MoCa and I have a coaxial outlet in the same room my main computer is. I had a technician come in to fix the cabling (e.g. identify the cables going from the central point in the basement storage room to the different rooms in the house). The cable between the central point and my room is an RG6. Please keep in mind that I cut the cord, so I have only Spectrum Internet coming from outside > Arris Gateway > Nighthawk R6000 > intended MoCa network. So the intended MoCa network is internal and not sharing anything with cable or satellite and it should not leark to the oustide world.

    I bought two Actiontec ECB66200 adapters and connected them per the instructions. For testing, I had a direct cable from the basement to my main computer room, no splitters or anything. I was surprised to find the speeds to be not much greater than the WiFi I had. The results were:
    Writing to NAS: 122 Mbps
    Reading from NAS: 144 Mbps

    I took a step back and decided to connect the MoCa adapters directly to each other using the supplied coaxial cable.

    Laptop > Ethernet cable > MoCa adapter > coaxial cable > MoCa adapter > Ehternet cable > Router LAN port

    Surprisingly, I had around the same results. Speeds did not go over 145 Mbps at all.

    Then I thought perhaps my NAS, which uses SMB for file transfer protocol, was the bottleneck or something. I decided to connect my Laptop directly to the router via the Ethernet cable. In this case, I got read/write results ~600 Mbps--much better but perhaps hitting the limits of the NAS or SMB or something.

    I tried different things to resolve the issue:
    - Different coaxial cables;
    - Different Ethernet cables;
    - Adding a MoCa 2.0 splitter to the mix.
    - Resetting the Actiontec;
    - Restarting the router and the Actiontecs.
    - Reflashing the firmware on the Actiontecs (Even though they had the latest versions)

    I did NOT try to change the bands or the RF frequency because I was told the defaults were ideal for most people.

    All my testing results are pointing at the adapters being broken. But I'd rather see a dead adapter rather than one that performs poorly, because I can't tell if it's my test setup or something else.

    Here is the device and node info I see when I connect Actiontec:
    [​IMG]
    [​IMG]

    I am in the process of boxing up the Actiontec and replacing them with the Motorola MoCa 2.0 adapters to see if they work. I am not giving up on MoCa yet, but I thought I would ask here in case anyone has any ideas of anything I'm missing.
     
    Last edited: Aug 13, 2019 at 1:18 PM
  2. degrub

    degrub Very Senior Member

    Joined:
    Dec 21, 2015
    Messages:
    872
    How are you testing ?

    Mbps = mega bits/sec, correct ?

    If using iperf, then there are specific parameters to set. see posts by Kaufmann and others

    You modems are synced correctly with a 647 Mbit/sec physical rate.
    The issue is elsewhere in the linkage or software.

    what are your ping statistics through the MOCA link ?
     
    dashrendar likes this.
  3. dashrendar

    dashrendar New Around Here

    Joined:
    Tuesday
    Messages:
    6
    Thanks for your response.

    Yes, Mbps = Megabits/sec.

    I was not using iperf. I tested using:
    - LAN Speed Test 4.4 using 1 GB file size.
    - Normal Windows copy of 3 GB file.

    In both cases, I didn't see any considerable improvement over WiFi.

    I don't know what it could be. I tested using both coax cables and Ethernet cables supplied with the Actiontec adapters.

    If it's a software problem, wouldn't have affected the direct Ethernet test that resulted in ~600 Mbps transfer rate?

    When I ping my NAS over th MoCa network, I get the following:
    [​IMG]
     
  4. degrub

    degrub Very Senior Member

    Joined:
    Dec 21, 2015
    Messages:
    872
    i wonder if you are seeing buffering effects with the test.
     
    dashrendar likes this.
  5. dashrendar

    dashrendar New Around Here

    Joined:
    Tuesday
    Messages:
    6
    Buffering effects?
     
  6. dashrendar

    dashrendar New Around Here

    Joined:
    Tuesday
    Messages:
    6
    Okay, now I'm ready to start banging my head against the wall.

    I received my Motorola adapters (MM1000) and I performed the same direct connection test and I'm getting similar results!!

    Read/Write speeds across the MoCa network are between 110 and 150 Mbps.

    Speed across direct Ethernet connection is 500-700 Mbps.

    I tried a direct connection and also from room to room--similar results.

    I am starting to doubt the router now, but it's the same port. I confirmed the negotiated speed is 1000 Mbps in both the router and my laptop I'm using for testing.

    Would the router limit the speed based on something else in the connection? That's so weird! What am I missing here?

    What are the odds that both the Actiontec and Motorola adapters are bad? Highly unlikely I think.

    Any help, hints or guidance would be appreciated.
     
  7. degrub

    degrub Very Senior Member

    Joined:
    Dec 21, 2015
    Messages:
    872
    What is the laptop lan port link speed when connected to a moca modem ?

    Moca modem to router port ?

    Iperf also will report similar results when running across moca 2 bonded. There is a setting to use multiple simultaneous links rather than a single link. Then iperf shows the full bandwidth being used.

    I wonder if the lan speed test software being used has the same issue.

    There are multiple threads here with the command line options listed.

    Just an oddball thought -
    Did you turn off wireless in the laptop during testing ?
     
    dashrendar likes this.
  8. dashrendar

    dashrendar New Around Here

    Joined:
    Tuesday
    Messages:
    6
    Thanks for your response, degrub.

    When I checked in Windows, it was 1.0 Gbps. I even tried configuring the adapter to force using 1000Mbps Full Duplex instead of auto negotiation. I noticed the lights on the back of the laptop's Ethernet port were amber, but they were also amber when I connected directly to the router using an Ethernet cable and achieved 500-700 Mbps.

    Same... The R7000 FreshTomato interface shows the port at 1000 Mbps.

    I haven't tried iperf yet, but I will see if I can test with it tonight. The problem is I don't think I have two laptops. Can I still use it to test with a shared folder on my NAS? (Sorry, never used it before).

    But if this was an issue, wouldn't the direct Ethernet-only connection be impacted as well? I do see a big noticeable difference there.

    I guess I can test with iperf just to confirm whether the bandwidth is available. I hope it still shows slow speed results because it would tell me something is wrong. If it's fast, then I don't know how MoCa would help me. Most real world applications (copying files, network backups, etc.) won't be using multiple threads/connections. I don't understand why the single thread won't use the entire bandwidth. It's not like there is a cap on individual connections/threads.

    Just an oddball thought -
    When I tested with the Actiontecs, I had my laptop "forget" the 2.4Ghz and 5.0 GHz SSIDs of my router, so it shouldn't have been accidentally using WiFi.

    I'll try again this evening with the MM1000 adapters, perhaps with the WiFi adapter completely disabled.

    I tried researching to see if there is any reason why my router would limit the LAN speed. I couldn't find anything. I don't think the router can tell (or cares) whether it's a direct Ethernet connection or one that has MoCa in it.
     
  9. degrub

    degrub Very Senior Member

    Joined:
    Dec 21, 2015
    Messages:
    872
    for some reason, your results indicate similar to moca 1.1 speeds or wireless speeds.. but the actiontec diagnostic screen indicates bonded 2.0.
    iperf just needs two pcs, one as server, one as client. search the threads here for the specific command line.



    take a look through krkaufman's post's on moca installations. you may figure something out.
     
    Last edited: Aug 15, 2019 at 11:12 AM
    dashrendar likes this.
  10. dashrendar

    dashrendar New Around Here

    Joined:
    Tuesday
    Messages:
    6
    Okay, I think I have good news...

    It was my ridiculous laptop!

    Taking a step back, yesterday I went back home and I tried a number of things including (a few might not make sense but I was growing frustrated):
    • Disable QoS on R7000 router (I know this is only for WAN-to-LAN);
    • Turn on CTF on R7000 router (I know this is only for WAN-to-LAN);
    • Inserting an unmanaged switch into the mix (between MoCa adapter and Router);
    • Mixing and matching an Actiontec with Motorola adapter, both 2.0 bonded, on the network.
    • Testing in a different room that has a coax line available as well.
    My 8-year-old daughter was in the room with me and noticed my frustration. "Can I help with anything, Daddy?".

    I wasn't suspecting the laptop, just the router, because it passed the direct Ethernet (No MoCa) test. However, right before I gave up, I decided to get a longer Ethernet cable and connect the client-side MoCa adapter to my desktop computer rather than the laptop. Ding! Ding! Ding!

    LAN Speed Test results:
    Write to NAS = 350 Mbits/sec
    Read from NAS = 880 Mbits/sec

    Windows copy file to NAS transfer rate: ~110 MBytes/sec (i.e. ~880 Mbits/sec)

    I still don't understand why the NAS write was that much slower than the read, but I was very relieved to see this something considerably greater than the previous results. I decided to stick with the Motorola MoCa adapters because I tried the Actiontecs before with my desktop and I didn't see this result at all. So it might be another variable (perhaps something I changed on the router side). Secondly, the Motorola ones are nicer designs and cheaper, albeit not as configurable.
     
  11. degrub

    degrub Very Senior Member

    Joined:
    Dec 21, 2015
    Messages:
    872
    maybe there is a cable or receptacle connection issue. on another post, someone found a bit if trash in the receptacle.
    the up/down difference with the NAS may be explained by the NAS ability to buffer read and not buffer adequately the writes.. Perhaps a random block location rather than contiguous blocks on the read. Use the NASPT tests.
     
    dashrendar likes this.