Activating a VPN for a specific port/device (386.7_2)

vango44

Occasional Visitor
Hi everyone,

I have two AX86U in hardwired mesh, and an Apple TV hardwired to one of them.
Just got Nord VPN and trying to activate the VPN from the router, only for the Apple TV.
I was using these instructions: https://support.nordvpn.com/Connectivity/Router/1047410642/AsusWRT-Merlin-setup-with-NordVPN.htm
but they didn't seem to work.

Can anyone please provide some guidance or assistance on how to do this?

Thanks in advance!

Andrew
How far did you get it working?
Were you able to add a Nord server and start the client through the firmware UI pages?

I haven't used this in a while but when I did I was able to get my whole network on the Nord server but when I switched to single devices it was unreliable. I ended up subscribing to a dns-based solution for my media devices.

If you can use Merlin firmware addons, see this one as well:

VPN Manager Addon for NordVPN
 

Tech9

Part of the Furniture

128bit

Regular Contributor
You have to use VPN Director for this.

finally, a thread that hits right at home for me. the only difference between me and andrew is that my ax is not meshed. i run merlinware and see the vpn director ui to which u refer.
  1. would that be all i need?
  2. would i also need the addon (vango44) or anything else??
i've been struggling with setting this for years now as i'd like to use nord at the router level and w/o their app but need to be able to manage restrictions for some media clients (tv).
 

Tech9

Part of the Furniture
I personally haven't tried lately NordVPN on Asuswrt-Merlin router, but I remember it was working properly and even showing >220Mbps speeds to local servers on AC86U router. VPN Director replaced the previous Policy Based routing and it's quite easy to set VPN to specific devices only. The devices have to have reserved IP address in DHCP server or static IP set on the device. Just follow the instructions and you'll figure it out.
 

128bit

Regular Contributor
I personally haven't tried lately NordVPN on Asuswrt-Merlin router, but I remember it was working properly and even showing >220Mbps speeds to local servers on AC86U router. VPN Director replaced the previous Policy Based routing and it's quite easy to set VPN to specific devices only. The devices have to have reserved IP address in DHCP server or static IP set on the device. Just follow the instructions and you'll figure it out.
yep, been "playing" since i initially wrote and have got it working in "strict" mode! gotta figure out how to make it device specific (exclusive), with director. i already have those devices assigned to static ip's, so it should be a piece of cake. the good news is that the addon will not be necessary - very happy with that.
 

128bit

Regular Contributor
Hi everyone,

I have two AX86U in hardwired mesh, and an Apple TV hardwired to one of them.
Just got Nord VPN and trying to activate the VPN from the router, only for the Apple TV.
I was using these instructions: https://support.nordvpn.com/Connectivity/Router/1047410642/AsusWRT-Merlin-setup-with-NordVPN.htm
but they didn't seem to work.

Can anyone please provide some guidance or assistance on how to do this?

Thanks in advance!

Andrew
so a couple things you may want to try. the nord url was quite helpful, but it may need a tweak especially if using merlinware, which is what i use and highly recommend.
  1. in step 8, after selecting "strict" or "exclusive" for the Redirect Internet traffic through tunnel, choose "yes (all)." this is not mentioned in the nord tutorial. i started with "strict" for now.
  2. in step 9, remove/clear any existing script before pasting the nord script.
  3. once you complete step 9, "apply" before doing the "wan" dns work.
  4. the "wan" merlinware ui is different from nord's, but adding the dns address is fairly straightforward
  5. after the dns work, "apply."
  6. now go back to the vpn client page and change "Service state" to "on," then "apply."
the vpn status page shows your status. i would reboot for good measure.
 

AndrewJacob

Regular Contributor
Thank you guys!
Appreciate the help @128bit but it didn't work and i couldn't get the VPN working even.
Actually, I think I did get it working but then nothing was being allowed through and I couldn't even access any webpages.
It showed this:
1660609123031.png


Also, not sure what method to use to get this working specifically for the Apple TV once it's working?

Thanks in advance.

PS: I also got those speeds @Tech9 when connecting to the VPN through my iPhone so the VPN's performance seems to be good.
 

128bit

Regular Contributor
Thank you guys!
Appreciate the help @128bit but it didn't work and i couldn't get the VPN working even.
Actually, I think I did get it working but then nothing was being allowed through and I couldn't even access any webpages.
It showed this:
View attachment 43569

Also, not sure what method to use to get this working specifically for the Apple TV once it's working?

Thanks in advance.

PS: I also got those speeds @Tech9 when connecting to the VPN through my iPhone so the VPN's performance seems to be good.
i've since made some changes and have it working completely now with the exception of one laptop. hell, the laptop won't even work when i fully revert, so i'm treating that as an anomaly and will dig in later.

in a nutshell, the nord post is old and we're advised to use quad9 (9.9.9.9, 149.112.112.112) instead. i was already using it before, and it's has its own entry in the merlinware ui.

Solved Exclusive DNS leads to all VPN connections blocked


mine always worked using "strict" but now it also works with "exclusive" and "director." luv it!! "strict" was fairly straighforward for me. once there, the rest should be ez.
 

AndrewJacob

Regular Contributor
Great, that worked @128bit ; thank you!
I am also still getting good speeds for the VPN connection.
1660626222263.png


However, I do have another question.
How do I correctly use VPN Director so that the VPN only works on one device? At the moment I've enabled it on one device but it's still enabled on all.
 

128bit

Regular Contributor
Great, that worked @128bit ; thank you!
I am also still getting good speeds for the VPN connection.
View attachment 43580

However, I do have another question.
How do I correctly use VPN Director so that the VPN only works on one device? At the moment I've enabled it on one device but it's still enabled on all.
if u read through the link i sent, it should be fairly obvious.
lemme know
 

AndrewJacob

Regular Contributor
The DNS post? I couldn't find the answer to my question... I'm trying to figure out how to get all my other connections to not use the VPN. I played around a bit but couldn't figure it out.
Any ideas?
 

doczenith1

Very Senior Member
The DNS post? I couldn't find the answer to my question... I'm trying to figure out how to get all my other connections to not use the VPN. I played around a bit but couldn't figure it out.
Any ideas?


Under the VPN client tab for the "Redirect Internet traffic through tunnel" setting you want to choose VPN Director (policy rules).

1660778320749.png


And then on the VPN Director tab you'll have something similar to this but for the IP address of the device that you want to route through the VPN tunnel.

1660778435353.png


You can set the IP address for the device on the LAN>DHCP Server tab.

1660778572556.png
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top