What's new

Adding a static route to all clients?


Regular Contributor
So, I think I might have found the issue.. well, not the issue, but pin-pointed the issue.

The route gets added to all my clients, except ANDROID devices (actually, it worked for sometime and then it stopped on android devices).

I am not sure what is so different with Android devices that it does not take the dhcp-option=lan,33.... option.

The weird thing is that if you use a VPN client on the android device, then the routes are pushed (so that all traffic goes through the vpn connection), so android should be able to accept static routes.

Has anyone see this issue before?


Regular Contributor
In case anyone is interested; I was able to figure out why some ANDROID devices were not getting the static route that I had specified earlier in my dnsmaswq.conf
I enabled enabled addition DHCP logging by adding
in my /jffs/configs/dnsmasq.conf.add and noticed that some of my android devices never requested option 33, therefore this would be ignored. I had to force the option regardless if the client requested it by adding the following to /jffs/configs/dnsmasq.conf.add:
NOTE: I added option 121 (classless) just in case, and now all my clients are able to connect to my server, regardless on which node they are connected to. I still do not understand why I need to do this as all my clients are on the same subnet, I still think that there is some issues on the way Asus implemented their aimesh system.


Senior Member
Glad you got it working. As I said before, there's definitely something weird going on there because there's no reason you should need a static route on the same local network. But next to impossible for anyone here to even venture a guess. It would take some close hands-on analysis to figure it out.

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!