What's new

AI mesh node not aligned with master

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

NightWolfix

New Around Here
Hi,

I own a AX10000 router in AP AI mesh mode with latest Marlin firmware connected to RP-AX58 with stock Asus latest firmware. I forced the 80 mhz channel width on the master which is correctly applied to the mesh SSID on the master. The slave however is always on a different 5 ghz channel on the same SSID and the width is always 20 mhz regardless of the setting. Is that normal? I tried removing and resetting the node many time but with no luck. The two are connected by 5 ghz backhaul.
 

Attachments

  • Screenshot_20240607-092742.png
    Screenshot_20240607-092742.png
    43.1 KB · Views: 13
What channel is the node using? There are a few spots on the band where the WiFi will only work @20MHz.
 
Channel 36 on the main router, and channel 140 on the node, backhaul is on channel 100
Set the node's WiFi to "Auto 20/40/80" and see what happens
 
Hi,

I own a AX10000 router in AP AI mesh mode with latest Marlin firmware connected to RP-AX58 with stock Asus latest firmware. I forced the 80 mhz channel width on the master which is correctly applied to the mesh SSID on the master. The slave however is always on a different 5 ghz channel on the same SSID and the width is always 20 mhz regardless of the setting. Is that normal? I tried removing and resetting the node many time but with no luck. The two are connected by 5 ghz backhaul.

Not normal... AiMesh uses the same channel per band across all nodes. Given your various equipment, I would backoff and try less variables first... AiMesh in router mode with ASUSWRT OEM/stock firmware on all nodes. If that works, step it up to AiMesh in AP Mode. As you progress, you may discover at what point AiMesh goes abnormal or just doesn't work with the given equipment.

Be sure to Hard Reset the installed firmware to its default settings on all nodes before configuring the router/AP root node firmware from scratch and adding the AX58U node to it.

OE
 
Last edited:
Not normal... AiMesh uses the same channel per band across all nodes. Given your various equipment, I would backoff and try less variables first... AiMesh in router mode with ASUSWRT OEM/stock firmware on all nodes. If that works, step it up to AiMesh in AP Mode. As you progress, you may discover at what point AiMesh goes abnormal or just doesn't work with the given equipment.

Be sure to Hard Reset the installed firmware to its default settings on all nodes before configuring the router/AP root node firmware from scratch and adding the AX58U node to it.

OE
Did all of this. Now the 5ghz runs at 80mhz but the 5 GHz is still on two different channels, 36 and 100 while for 2.4 they are on the same channel. You sure that this is not allowed? Everything seems to work fine
 
Did all of this. Now the 5ghz runs at 80mhz but the 5 GHz is still on two different channels, 36 and 100 while for 2.4 they are on the same channel. You sure that this is not allowed? Everything seems to work fine

Each band will have its own channel.

OE
 
Each band will have its own channel.

OE
I have a theory. This is intended behavior. AX11000 has two 5 GHz radios one on 36 and the other necessarily on a different channel, 100 in my case, for backhaul. Contrary to ax11000, the RP-AX58 has only one 5ghz radio which necessarily needs to match the backhaul. So how can RP ax58 match the ax 11000 channel 36 if it needs to be connected over 100 for the backhaul? It can't
 
I have a theory. This is intended behavior. AX11000 has two 5 GHz radios one on 36 and the other necessarily on a different channel, 100 in my case, for backhaul. Contrary to ax11000, the RP-AX58 has only one 5ghz radio which necessarily needs to match the backhaul. So how can RP ax58 match the ax 11000 channel 36 if it needs to be connected over 100 for the backhaul? It can't
Seems my theory is right. I activated Ethernet backhaul by freeing the 5 GHz band on the RP-AX58. Now both the AX11000 and the RP AX58 went on the same 100 channel and the roaming happens on that same channel.

Question: What is the drawback of going back to wireless backhaul and having therefore two different channels?
 
I have a theory. This is intended behavior. AX11000 has two 5 GHz radios one on 36 and the other necessarily on a different channel, 100 in my case, for backhaul. Contrary to ax11000, the RP-AX58 has only one 5ghz radio which necessarily needs to match the backhaul. So how can RP ax58 match the ax 11000 channel 36 if it needs to be connected over 100 for the backhaul? It can't

5-1 is low 5.0 band; 5-2 is high 5.0 band... one overall 5.0 band but two radios, two 'bands' 5-1 and 5-2 in this case (on one end), and two channels.

You'll have to discover how your mixed band APs/firmware behave. Ideally, you wire the backhaul, enable Ethernet Backhaul Mode to disable all wireless backhauls to free all WiFi for client use only and to prevent spurious failover from wired to wireless backhaul for whatever reason... disrupts clients), and configure your extra/bonus/nuisance 5.0 band however you want on the root node to have a extra WLAN (until you upgrade). Otherwise, for a non-dedicated/shared wireless backhaul (mismatched number of bands and shared WiFi) you'll have to sort through it to see what makes the most sense for your situation.

OE
 
Seems my theory is right. I activated Ethernet backhaul by freeing the 5 GHz band on the RP-AX58. Now both the AX11000 and the RP AX58 went on the same 100 channel and the roaming happens on that same channel.

Be sure to settle on using a control channel that all clients support.

Question: What is the drawback of going back to wireless backhaul and having therefore two different channels?

The extra WLAN on the tri-band router makes using the overall 5.0 band more restrictive... you'll live with it until you can improve on it. Roaming those clients to a different WLAN/SSID on the dual-band node will be less elegant.. and when they get there, their wireless connection throughput will be about half due to the same band being shared with the wireless backhaul.

Ideally, wire the backhaul and avoid models that split a band for no good reason (a dedicated wireless backhaul not shared with clients is a good reason, but you can't do this with your mismatched nodes).

And pardon me if I've mistated some model details... I'm too busy right now to research the model specs. I trust you can fill in/adjust the details... the nut of the issue is the same.

OE
 
Last edited:

Similar threads

Latest threads

Support SNBForums w/ Amazon

If you'd like to support SNBForums, just use this link and buy anything on Amazon. Thanks!

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top