AiMesh - 386.1_2 Issue with LED Lights on Routers

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

SeaMonkey80

New Around Here
Hi All,

This is a really minor issue, but enough of one that the wife has started to complain. I have 3 AX86U Routers in an AiMesh ethernet backhaul setup (1 main, 2 nodes). Everything is running perfectly as far as network stability and performance on my Xfinity gigabit plan. The nodes are located in the common areas, with the router at my home's "brain" in the master closet.

The issue that I am having is when the AiMesh reboots, even though I have the settings in the GUI set to keep the LEDs off, everything just comes back on. When I go back into the settings, it will show the LED toggle off, but I will have to toggle it on, then off to really turn the LEDs off again. Of course, the wife hates the blinking lights in the common area. Is there a fix for this?

Like I said, this is a minor nit picky issue. Thanks in advance!
 

CaptainSTX

Part of the Furniture
Black electrical tape. If the lights are really intense use multiple layers.

Have had to do this to maintain a happy wife which as they say leads to a happy life.
 

dev_null

Senior Member
How frequently and why are you rebooting the mesh/nodes?

Mine are quite stable from build to build and seldom require rebooting otherwise.
 

New2This

Senior Member
Same here, NO issues running 2 AX88U
Sounds like they might need a nuke, and start over
 

SeaMonkey80

New Around Here
How frequently and why are you rebooting the mesh/nodes?

Mine are quite stable from build to build and seldom require rebooting otherwise.
oh, I live in a crowded area, and have been tinkering with the WiFi channels. with every change, the lights come back on. Also, one of my devices connected to the node through one of the ethernet ports was causing a problem that required the AiMesh system to restart. In all cases, the Lights just won't stay off. For the most part, I will be trying not to reboot the system if I can avoid it.
 

argh0815

Occasional Visitor
I had the same issue. My workaround was to enable custom scripts support on the nodes by logging in to each of them via SSH client and issue the following commands
Code:
nvram set jffs2_scripts="1"
nvram commit

(SSH has to be enabled on the main router and the IP addresses of the nodes can be found in the AiMesh/Network tab)

and then copy below services-start script to /jffs/scripts/ on each of them with WinSCP.

Code:
#!/bin/sh

sleep 60
nvram set led_disable=1
service restart_leds

This is keeping my LEDs off after a reboot.
 

archiel

Senior Member
I had the same issue. My workaround was to enable custom scripts support on the nodes by logging in to each of them via SSH client and issue the following commands
Code:
nvram set jffs2_scripts="1"
nvram commit

(SSH has to be enabled on the main router and the IP addresses of the nodes can be found in the AiMesh/Network tab)

and then copy below services-start script to /jffs/scripts/ on each of them with WinSCP.

Code:
#!/bin/sh

sleep 60
nvram set led_disable=1
service restart_leds

This is keeping my LEDs off after a reboot.
Or if you don't want to add a script, ssh onto the node and run

Code:
nvram set led_disable=1
nvram commit
service restart_leds

Works on my AX58U
 

SeaMonkey80

New Around Here
Or if you don't want to add a script, ssh onto the node and run

Code:
nvram set led_disable=1
nvram commit
service restart_leds

Works on my AX58U
I spent all yesterday learning how to SSH into my router (I know, I’m a noob), but this worked! Thanks!
 

NivekTheSizable

Occasional Visitor
I am also seeing this with 386.1 and 386.1_2 on a RT-AC3100 that was factory reset before putting 386.1 on it and it was put into AiMesh mode.

Another workaround is to toggle the LEDs on (even though they're already on) and off again in the web interface of the master router at AiMesh > [click your node] > Management > LED.

This issue appears to have been introduced with 386.1, I don't think I would have missed it in prior versions.
 

aex.perez

Regular Contributor
Since I'm already running other scripts on the AIMesh Nodes on 386.1_2, added the LED control - Scheduled LED control script. On at 9am, off at 9pm for the nodes in the bedrooms.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top