AiMesh roaming problem

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Psu2ski32

Occasional Visitor
Hi All- Recently upgraded to Merlin 386.2_2 on both my AC5300 and AC3100 routers.

I have AiMesh network set up. For some reason, I have one of the nodes (AC5300) that some clients (macbook, ipad, iphone, etc.) seem to constantly bind to rather than roam to the strongest producing node (I do not have binding enabled). (As an example, I have a router in the kitchen and one in the office for hardwired setup)..While in the office, I would expect my iphone to connect to node I am sitting right next to rather than the kitchen...Is there some type of AiMesh "refresh rate" setting I need to play with such that I am connecting to closest node?

Also, the AC5300 router in the kitchen, there are times the speed drops down to ~10MB..after a system reboot it will jump back up to 300+ MB downloads for a couple days, and then act up again. Any thoughts?

Appreciate everyones thoughts/insights.
 

Hazel

Regular Contributor
I don't have an actual answer to your question, but I've found out that the 'i' in AiMesh must be for something else than 'Intelligence'. I still use it, as I'm to lazy to setup my network again but I use a combination of binding for (fixed placed) devices to specific nodes and the roaming blocklist, because I've also seen that AiMesh makes some illogical choices which worsen performance or even loose connection. It could be because of temporary interference that they choose to switch but they never seem to turn back to the most logical choice of node where the signal is measurably stronger and performance better.

So basically, I only use AiMesh for mobile devices (phones, tablet, laptops) moving throughout the house and for the devices that have a fixed place but keep choosing the wrong nodes at the cost of performance, loss of connection, I just bind them to a node or prevent them from roaming. As long as a device stays on the most logical node, I leave it untouched. AiMesh apparently isn't as smart as I hoped it would be.

I don't use Smart Connect either btw, because it doesn't act 'Smart' either. Next time I set up my network again, I'll probably set my AiMesh Node to AP Mode, because beside the great AiMesh UI I personally see much benefit (which could be totally caused by my personal situation, building structure etc. but I've read about more similar experiences).
 

OzarkEdge

Part of the Furniture
I don't have an actual answer to your question, but I've found out that the 'i' in AiMesh must be for something else than 'Intelligence'. I still use it, as I'm to lazy to setup my network again but I use a combination of binding for (fixed placed) devices to specific nodes and the roaming blocklist, because I've also seen that AiMesh makes some illogical choices which worsen performance or even loose connection. It could be because of temporary interference that they choose to switch but they never seem to turn back to the most logical choice of node where the signal is measurably stronger and performance better.

So basically, I only use AiMesh for mobile devices (phones, tablet, laptops) moving throughout the house and for the devices that have a fixed place but keep choosing the wrong nodes at the cost of performance, loss of connection, I just bind them to a node or prevent them from roaming. As long as a device stays on the most logical node, I leave it untouched. AiMesh apparently isn't as smart as I hoped it would be.

I don't use Smart Connect either btw, because it doesn't act 'Smart' either. Next time I set up my network again, I'll probably set my AiMesh Node to AP Mode, because beside the great AiMesh UI I personally see much benefit (which could be totally caused by my personal situation, building structure etc. but I've read about more similar experiences).

Assuming you are using the AC86U and AC68U in your sig...

The AC86U WiFi is stronger than the AC68U WiFi, so raising (less negative) Roaming Assistant RSSI thresholds might help with client roaming for your layout.

The AC68U does not support Smart Connect, so you would want to disable Smart Connect and use different SSIDs.

OE
 

Hazel

Regular Contributor
Assuming you are using the AC86U and AC68U in your sig...

The AC86U WiFi is stronger than the AC68U WiFi, so raising (less negative) Roaming Assistant RSSI thresholds might help with client roaming for your layout.

The AC68U does not support Smart Connect, so you would want to disable Smart Connect and use different SSIDs.

OE

Thanks for the info. Smart Connect is disabled, Roaming Assistent as well since a while. What would be better value for Roaming Assistance instead of the default of -70dBm? I'm using two different SSID's (and a third one for a Guest Network), one per band. I think I read that in one of your guides, but I'm not sure.
 

OzarkEdge

Part of the Furniture
Thanks for the info. Smart Connect is disabled, Roaming Assistent as well since a while. What would be better value for Roaming Assistance instead of the default of -70dBm? I'm using two different SSID's (and a third one for a Guest Network), one per band. I think I read that in one of your guides, but I'm not sure.

For my 2xAC86U layout, I raise the 2.4 RA RSSI up to -55 dBm... FWIW, when AiMesh was first released, the default for 2.4 was -55, not -70. With a 77' wireless backhaul, my 5.0 RA RSSI at the default -70 dBm seems ok with my clients.

It's easy enough to raise a RA RSSI threshold by say 15 dBm and then see how your clients behave. Also, shifting a node location a bit might help if the radio signal path is improved by this change.

OE
 

Tech9

Very Senior Member
For my 2xAC86U layout, I raise the 2.4 RA RSSI up to -55 dBm...

When I tested AiMesh with two AC86U routers and then available 41994 beta Asus firmware I found Roaming Assistant not working as I would expect. With -55dBm on 2.4GHz and -65dBm on 5GHz there were clients sticking to one of the routers at -65dBm and -80dBm respectively. Apple devices tend to hold the connection as long as it is useable and the Roaming Assistant was not disconnecting them. The only way to switch was to re-connect the Wi-Fi. I know there is a newer firmware for AC86U, but I don't know if there are changes to AiMesh coming with it.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top