AiMesh with RT-AX88U and two RT-AX92U forces at least one node on 2.4GHz backhaul

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Tolkey

New Around Here
Hi everyone. I think that my knowledge is not sufficient to sort this issue out, so I hope someone here has an idea.

I have three ASUS Routers in a triangle AiMesh mode: one RT-AX88U (main router) and two RT-AX92U (nodes), working without any ethernet backhaul. This setup worked perfectly fine with the following configuration (meaning that I got 5GHz backhaul whatever the configuration of the AiMesh network):
  • RT-AX88U with firmware RMerlin 384.19_0
  • RT-AX92U with firmware 3.0.0.4_384_9177
  • I don't use SmartConnect and I kept all the Wifi setup by default except that I enabled "Auto select channel including channel 12, 13" for the 2.4GHz band and "Enable 160 MHz" for the 5GHz band
Now the latest firmware for the RT-AX92U went out (version 3.0.0.4_386_40451), so I updated both of them and... I can't get both RT-AX92U to connect on the 5GHz backhaul at the same time anymore. What this means is that I can get one of them to connect to the RT-AX88U through the 5GHz-2 band (with excellent connection), but the other one will then always get stuck on 2.4GHz backhaul. And depending on how I reconnect the nodes, it can be one or the other RT-AX92U stuck in 2.4GHz (or even both of them in 2.4GHz). Another possible configuration is one of the AX-92U connects to the AX-88U in 5GHz and the second AX-92U connects to the first AX-92U in 2.4GHz.

I am in an environment where there aren't many wifi networks arounds and I've tried the following with no luck:
  • Update the RT-AX88U to the latest stock firmware available (3.0.0.4_386_41249), including a full reset of the router
  • Removed the AiMesh nodes from the interface to reset them and even force-reset them with the "WPS + Power switch" combination
  • Force the control channel for the 5Ghz band (100, 104...)
  • Enable or disable roaming assistant for both bands
  • Disable WMM APSD
  • Disable all beamforming options
  • tried latest beta versions for both the AX-88U and AX-92U (9.0.0.4_386_41157)
  • In the end, I played with all the options in the "Professional" tab without success
The attenuation between the RT-AX88U and first RT-AX92U is -50dB (I can have 1500M/1500M up/down between the nodes when in 5GHz backhaul), and between RT-AX88U and the second RT-AX92U I have -60dB (approx. 1000M/1000M up/down when in 5GHz backhaul). The attenuation between the two AX-92U is also around -55dB.

Anyone has any idea what can be the problem? Thanks for your help.
 

OzarkEdge

Part of the Furniture
Hi everyone. I think that my knowledge is not sufficient to sort this issue out, so I hope someone here has an idea.

I have three ASUS Routers in a triangle AiMesh mode: one RT-AX88U (main router) and two RT-AX92U (nodes), working without any ethernet backhaul. This setup worked perfectly fine with the following configuration (meaning that I got 5GHz backhaul whatever the configuration of the AiMesh network):
  • RT-AX88U with firmware RMerlin 384.19_0
  • RT-AX92U with firmware 3.0.0.4_384_9177
  • I don't use SmartConnect and I kept all the Wifi setup by default except that I enabled "Auto select channel including channel 12, 13" for the 2.4GHz band and "Enable 160 MHz" for the 5GHz band
Now the latest firmware for the RT-AX92U went out (version 3.0.0.4_386_40451), so I updated both of them and... I can't get both RT-AX92U to connect on the 5GHz backhaul at the same time anymore. What this means is that I can get one of them to connect to the RT-AX88U through the 5GHz-2 band (with excellent connection), but the other one will then always get stuck on 2.4GHz backhaul. And depending on how I reconnect the nodes, it can be one or the other RT-AX92U stuck in 2.4GHz (or even both of them in 2.4GHz). Another possible configuration is one of the AX-92U connects to the AX-88U in 5GHz and the second AX-92U connects to the first AX-92U in 2.4GHz.

I am in an environment where there aren't many wifi networks arounds and I've tried the following with no luck:
  • Update the RT-AX88U to the latest stock firmware available (3.0.0.4_386_41249), including a full reset of the router
  • Removed the AiMesh nodes from the interface to reset them and even force-reset them with the "WPS + Power switch" combination
  • Force the control channel for the 5Ghz band (100, 104...)
  • Enable or disable roaming assistant for both bands
  • Disable WMM APSD
  • Disable all beamforming options
  • tried latest beta versions for both the AX-88U and AX-92U (9.0.0.4_386_41157)
  • In the end, I played with all the options in the "Professional" tab without success
The attenuation between the RT-AX88U and first RT-AX92U is -50dB (I can have 1500M/1500M up/down between the nodes when in 5GHz backhaul), and between RT-AX88U and the second RT-AX92U I have -60dB (approx. 1000M/1000M up/down when in 5GHz backhaul). The attenuation between the two AX-92U is also around -55dB.

Anyone has any idea what can be the problem? Thanks for your help.

Maybe 5.0 160 MHz is forcing use of DFS channels and those are interfering.

Try non-DFS channels and 20/40/80 MHz to see if the backhauls respond as expected. Less throughput, but stable.

If this is the issue, then you may want to re-install to clean up after all of the experimentation.

OE
 

L&LD

Part of the Furniture
Was that a systematic approach to solving this issue?

What I mean is, did you do those attempted fixes ad-hoc, or did you do them all together and slowly enable settings/features and test as needed to verify the network continued to work as you expect?

The new firmware may also have affected the wireless radios observed distribution/range. Did you test new placements/orientations with the new firmware? Sometimes, inches can make an enormous difference.

Begin by getting the main router reset, at its expected defaults (see the link in my signature for the M&M and ideally, the Nuclear Reset guides to do so), and working as you want it to (forget about enabling advanced features and/or scripts for now). When this is achieved, add a node that has been fully reset first, and see how it behaves for a few hours/days. Then add the last node to the mix.

Make any further changes slowly, continually testing as you go, and only making one change at a time until proven stable for further changes.

Seeing that the main router is running 384.xx level firmware, and the nodes are 386.xx level firmware, I would expect these stability/reliability issues myself. Try/test flashing RMerlin 386.1 Beta 1 (or wait for Beta 2 'soon') level firmware to your main router first, before doing the suggestions above.

Otherwise, it may be prudent to just keep all routers on the same level (384.xx) firmware base for now.
 

Tolkey

New Around Here
Try non-DFS channels and 20/40/80 MHz to see if the backhauls respond as expected. Less throughput, but stable.

I disabled the use of DFS channels and tried 20/40/80 MHz one after the other but it did not change anything. And to be honest I did not have much hope as my configuration with 384 firmwares used them and was really stable.

Was that a systematic approach to solving this issue?

What I mean is, did you do those attempted fixes ad-hoc, or did you do them all together and slowly enable settings/features and test as needed to verify the network continued to work as you expect?

Yes the approach was systematic: I started from the default setup and applied changes one after the other. To be sure that it had nothing to do with the orientation / placement of the routers, I put them all in the same room but the behavior is exactly the same.

Seeing that the main router is running 384.xx level firmware, and the nodes are 386.xx level firmware, I would expect these stability/reliability issues myself. Try/test flashing RMerlin 386.1 Beta 1 (or wait for Beta 2 'soon') level firmware to your main router first, before doing the suggestions above.

I also expected that having the main router running 384 firmware could be the issue but based on my journey, if it is an issue then it is not the only one, I tried these configurations in this order:
  • AX88U in 3.0.0.4.384.9579 and two AX92U in 3.0.0.4_384_9177. All OK (except I don't benefit from AiMesh 2.0).
  • AX88U in 3.0.0.4.384.9579 and two AX92U in 3.0.0.4_386_40451. One of the AX92U will never use 5GHz backhaul.
  • AX88U in 3.0.0.4.384.9579 and two AX92U in 9.0.0.4_386_41157 (beta). One of the AX92U will never use 5GHz backhaul.
  • AX88U in 9.0.0.4_386_41157 (beta) and two AX92U in 3.0.0.4_386_40451. One of the AX92U will never use 5GHz backhaul.
  • AX88U in 9.0.0.4_386_41157 (beta) and two AX92U in 9.0.0.4_386_41157 (beta). One of the AX92U will never use 5GHz backhaul.
  • AX88U in RMerlin 384.19_0 and two AX92U in 3.0.0.4_384_9177. All nodes connect with 5GHz backhaul.
  • AX88U in 3.0.0.4_386_41249 and two AX92U in AX92U in 3.0.0.4_384_9177. All nodes connect with 5GHz backhaul (but both nodes don't benefit from AiMesh 2.0 features)
  • AX88U in 3.0.0.4_386_41249, one AX92U in 3.0.0.4_386_40451 and one AX92U in 3.0.0.4_384_9177. All nodes connect with 5GHz backhaul (but one of the nodes doesn't benefit from AiMesh 2.0 features)
  • AX88U in 3.0.0.4_386_41249 and two AX92U in 3.0.0.4_386_40451. One of the AX92U will never use 5GHz backhaul.
When I say "One of the AX92U will never use 5GHz backhaul", it is completely random which one of them. So I will probably give RMerlin 386.1 Beta 1 or 2 a try but it looks more and more to me like something that was introduced in the latest 386 firmwares for the AX92U makes it impossible to have 5GHz backhaul on more than one AX92U if the main router is an AX88U.

I tend to think that because the configurations with AX88U in 386 firmware and at least one AX92U in 384 firmware provides 5GHz backhaul for each node.
 

L&LD

Part of the Furniture
Testing them in the same room isn't a good test.

How big is your home? In SqFt?

You may be over saturating the space with unneeded Wi-Fi if too many AP's and not enough distance between them.
 

Tolkey

New Around Here
My home is roughly 2000 SqFt on 2 levels. One of the nodes is for an extension. I agree that testing in the same room is not ideal but I got the same results as with the nodes in their original position.
 

L&LD

Part of the Furniture
Three routers in 1,000 SqFt seems to be your issue. Reduce the number of AP's you need by properly placing/orientating them to give you the coverage you want.

I would characterize that a single RT-AX88U placed centrally would be all that is needed.
 

Tolkey

New Around Here
Unfortunately I can’t move the AX88U to the middle of the house for two reasone: because it is far from my internet access and my wife finds it ugly :)

And it’s an old house of the 16th century so the walls are the thickest you’ve ever seen. But I really appreciate your help though, I will try to reconsider my configuration.
 

L&LD

Part of the Furniture
Tell your wife that 1 ugly router is a good compromise vs. 3 ugly routers! You may win! :)

At least you'll know if the thick walls really require you to have so many AP's.
 

leerees

Senior Member
Hi everyone. I think that my knowledge is not sufficient to sort this issue out, so I hope someone here has an idea.

I have three ASUS Routers in a triangle AiMesh mode: one RT-AX88U (main router) and two RT-AX92U (nodes), working without any ethernet backhaul. This setup worked perfectly fine with the following configuration (meaning that I got 5GHz backhaul whatever the configuration of the AiMesh network):
  • RT-AX88U with firmware RMerlin 384.19_0
  • RT-AX92U with firmware 3.0.0.4_384_9177
  • I don't use SmartConnect and I kept all the Wifi setup by default except that I enabled "Auto select channel including channel 12, 13" for the 2.4GHz band and "Enable 160 MHz" for the 5GHz band
Now the latest firmware for the RT-AX92U went out (version 3.0.0.4_386_40451), so I updated both of them and... I can't get both RT-AX92U to connect on the 5GHz backhaul at the same time anymore. What this means is that I can get one of them to connect to the RT-AX88U through the 5GHz-2 band (with excellent connection), but the other one will then always get stuck on 2.4GHz backhaul. And depending on how I reconnect the nodes, it can be one or the other RT-AX92U stuck in 2.4GHz (or even both of them in 2.4GHz). Another possible configuration is one of the AX-92U connects to the AX-88U in 5GHz and the second AX-92U connects to the first AX-92U in 2.4GHz.

I am in an environment where there aren't many wifi networks arounds and I've tried the following with no luck:
  • Update the RT-AX88U to the latest stock firmware available (3.0.0.4_386_41249), including a full reset of the router
  • Removed the AiMesh nodes from the interface to reset them and even force-reset them with the "WPS + Power switch" combination
  • Force the control channel for the 5Ghz band (100, 104...)
  • Enable or disable roaming assistant for both bands
  • Disable WMM APSD
  • Disable all beamforming options
  • tried latest beta versions for both the AX-88U and AX-92U (9.0.0.4_386_41157)
  • In the end, I played with all the options in the "Professional" tab without success
The attenuation between the RT-AX88U and first RT-AX92U is -50dB (I can have 1500M/1500M up/down between the nodes when in 5GHz backhaul), and between RT-AX88U and the second RT-AX92U I have -60dB (approx. 1000M/1000M up/down when in 5GHz backhaul). The attenuation between the two AX-92U is also around -55dB.

Anyone has any idea what can be the problem? Thanks for your help.

This is what worked for us. Our network is just AX92u's.

We had this issue with our second network (which now has 8 AX92u's). You need to leave beamforming on and leave all of the wifi settings on auto (including channel selection). Turning beamforming off for us made the speed tests erratic. Using Winfi to scan and subsequently setting the quietest channels always resulted in slower throughput than leaving it on auto.

With regards to the backhaul, if you leave everything on auto eventually they will switch to 5ghz. If they don't it means that 2.4ghz is the best option. When we were setting up the network we had all the AX92u's in the same room and they all chose a 2.4ghz backhaul. Once we had installed them they started switching over to 5ghz. It takes a while. Again, I believe leaving it on auto will allow it to choose the best settings based on local wifi traffic.

Do not tick enable 160mhz, the backhaul gets 1gbps on 80mhz. If you need speeds faster then 1gbps then the AX92u's are probably not up to the job. They are only dual core with 512MB RAM.
 
Last edited:

KingBravery

Senior Member
I'm using RT-AX86U with 2x Zenwifi XT8.

This problem is same with me if only XT8 use all version of new RC BETA firmware. If I'm using latest official firmware, the connection is solid stable. Just only don't have the new function to tie device to certain node.

Now, I'm just stick with official firmware for XT8 to avoid this 2.4GHz backhaul happen.
 

The PyroPath

Occasional Visitor
I'm using RT-AX86U with 2x Zenwifi XT8.

This problem is same with me if only XT8 use all version of new RC BETA firmware. If I'm using latest official firmware, the connection is solid stable. Just only don't have the new function to tie device to certain node.

Now, I'm just stick with official firmware for XT8 to avoid this 2.4GHz backhaul happen.
Tried using official on 1 XT8 and RC on the other? That's what's working for me right now!
 

KingBravery

Senior Member
Tried using official on 1 XT8 and RC on the other? That's what's working for me right now!
I noticed that too when trying.. but prefer to use same firmware for both to avoid issue
 

rswong

New Around Here
My home is roughly 2000 SqFt on 2 levels. One of the nodes is for an extension. I agree that testing in the same room is not ideal but I got the same results as with the nodes in their original position.

Tokey, out of curiosity, did you try an ethernet backhaul at all? I have an AX88U with two AC68Us, and looking to upgrade to the AX92Us for the edges, but I currently have backhauled ethernet cables. I'm curious if all of the other functionality was available, AiMesh 2.0, etc, with the combinations you had with firmware?

Thanks,
 

Tolkey

New Around Here
So to close the topic, everything is back to normal with latest firmwares (Merlin 386.1_2 for the rt-ax88u and stock firmware for both rt-ax92u). No other change in the configuration.

Only problem remaining is that enabling guest network on the first slot impacts wifi performance, so I configured it on the second slot and it works like a charm (except that I can’t propagate the guest network on the aimesh nodes as a consequence, but I can live with it).

Thanks everyone for the help!
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top