AiProtection - no hits at all

RMerlin

Asuswrt-Merlin dev
I've noticed Web History also stops recording after about a week time on AC86U router running Asuswrt 48260. There are some things to fix.
My personal guess is that it`s tied to their sqlite db management, which might explain why logging stops after a while. Could be something wrong in how they purge old entries when the filesize reaches the threshold limit. Or, some people`s JFFS partition fills up before that threshold is reached.
 

Tech9

Part of the Furniture
I don't know why it stops recording, but reboot fixes it for the next few days.
 

ForkWNY

Regular Contributor
My personal guess is that it`s tied to their sqlite db management, which might explain why logging stops after a while. Could be something wrong in how they purge old entries when the filesize reaches the threshold limit. Or, some people`s JFFS partition fills up before that threshold is reached.
Is there a way these old entries could be removed while the router is up and running to restore logging back to normal? I've noticed my JFFS partition rarely goes above 15%, so I'm thinking the logging issue is related to filesize thresholds or something else, and not partition issues.
 

RMerlin

Asuswrt-Merlin dev
Is there a way these old entries could be removed while the router is up and running to restore logging back to normal? I've noticed my JFFS partition rarely goes above 15%, so I'm thinking the logging issue is related to filesize thresholds or something else, and not partition issues.
I would expect it to be automatically managed (like they do for the AiProtection event log), but I don`t have any details, sorry.
 

alba666

Regular Contributor
Is there a way these old entries could be removed while the router is up and running to restore logging back to normal? I've noticed my JFFS partition rarely goes above 15%, so I'm thinking the logging issue is related to filesize thresholds or something else, and not partition issues.
I dug this out from Merlin from an old thread:


The database where it stores the logs may be corrupted.

1) Disable AiProtection/Malicious Website Blocking
2) Delete the database. Over SSH:

Code:
rm /jffs/.sys/AiProtectionMonitor/*

3) Re-enable the features
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top