amtm Amtm ssh not responsive

  • ATTENTION! You'll notice a Prefix dropdown when you create a thread. If your post applies to one of the topics listed, please use that Prefix for your post. When browsing the thread list you can use the Prefix to filter the view.
  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Andrea_Berzi

New Around Here
Hi All,
i have a problem with amtm, the ssh is not responsive and it gives me this back after a long time

Code:
 amtm 3.2.0 FW             by thelonelycoder
 RT-AC88U (armv7l) FW-386.3 @ 192.168.1.1
    The Asuswrt-Merlin Terminal Menu

Bus error

what can i do to solve?
Thank you
 

thelonelycoder

Part of the Furniture
Never seen this error. Reboot the router and try again.
 

Andrea_Berzi

New Around Here
i have already tried to reboot but it is the same.
until some time ago it was sometimes slow to print the lines, now it just doesn't work.
how do i uninstall all plugins and reinstall amtm?
 

underdose

Regular Contributor
For the curious:
In computing, a bus error is a fault raised by hardware, notifying an operating system (OS) that a process is trying to access memory that the CPU cannot physically address: an invalid address for the address bus, hence the name.
Source: https://en.wikipedia.org/wiki/Bus_error
 

BikeHelmet

Occasional Visitor
Seems like bad USB or bad router. If you can get into the WebUI there's a format JFFS option under Administration -> System, page /Advanced_System_Content.asp

I'd pull the drive and reformat in another computer. Maybe do a block check with something like h2testw to make sure it's a healthy stick. If not, get a new one.

Then plug it back in and see if you can get AMTM going again, using the step by step if necessary.

I had a bad USB drag my router's performance down by about 98%, so don't underestimate what waiting for bad USB storage will do. Maybe your bus error is a timeout where there shouldn't be one, or maybe you do have something going wrong with the router internals. I'm sure you'll find out which one it is, very soon.
 

Andrea_Berzi

New Around Here
Hi,
finally i solved by formatting the jffs partition and also formatting the usb and reinstalled everything manually, i don't know exactly if it was jffs or usb problem.
Thank you
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top