Android can't connect to guest network with HW NAT on

Justinh

Regular Contributor
RT-AC68P, stock FW 3.0.0.4.386_43129, guest network 1 (2.4Ghz)

I had NAT acceleration set to disabled, and my Android 5 tablet never had a problem connecting. I set NAT accel to 'auto' and the tablet can't connect (never even get an error). Tried the typical things to get a connection but the tablet always did the same try, try, try. I set NAT accel back to off and it connects immediately.

What does the NAT accel setting have to do with the guest wireless connection of my tablet? The tablet has an IP of 192.168.101.x, the rest of the LAN has 192.168.1.x, to be sure.
Is there another setting on the router to counteract this, so I can have HW accel and the tablet connected?
 

L&LD

Part of the Furniture
Try using Guest Network 2 instead (with NAT enabled).

And/or using a new SSID.
 

Justinh

Regular Contributor
And/or using a new SSID.
I'm a bit confused about this - can you clarify? Are you saying I could only change the SSID on guest network 1 and it should work? How would the SSID name make this scenario work?

Now, if I use GN2, I'll have to use a different SSID, right?

GN1 with the diff IP range is actually useful to me, so I'd prefer to keep using it.
 

L&LD

Part of the Furniture
Both of the options provided are for testing scenarios. Use the one that works (they are not equivalent).
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top