Android/Modem WAN connection workaround

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

toast

Occasional Visitor
I have a Netgear AC810 connected to the USB port.
The device is detected by the router but no ip address is getting assigned to the router.
When connected to a PC the PC get address 192.168.1.4 as expected.

The udhpc command below (that I dont know if it is fully correct) looks like it obtain the ip but interface (eth3) is not getting configured. Also I have to do a ifdown/ifup first or udhpc just throws an error.
After adding address and default route I can reach internet from the router cli. But clients can still not access Internet. I'm not surprised and asking for some help with this. The ASUS GUI still say that USB WAN is down.

I think/hope that this can be done quite smooth if some one have more knowledge than me. What would be the best way of manually bringing up the interface and enabling the WAN interface in a correct way?

Code:
[email protected]_B1:/tmp/home/root# cat /jffs/scripts/services-start
#!/bin/sh
# This cript get called after all other system services
# have been started at boot on router
# ---------------------------------------------------------
# Sample cron job to install after reboot
sleep 10 && ifconfig eth3 down && ifconfig eth3 up && /sbin/udhcpc -i eth3 -p /var/run/udhcpc0.pid -s /tmp/udhcpc -t1 -T5 -A0 -O33 -O249 && ifconfig eth3 192.168.1.4 netmask 255.255.255.0 && ip r add default via 192.168.1.1 dev eth3
cru a tethering "0 * * * * ifconfig eth3 down && ifconfig eth3 up && /sbin/udhcpc -i eth3 -p /var/run/udhcpc0.pid -s /tmp/udhcpc -t1 -T5 -A0 -O33 -O249 && ifconfig eth3 192.168.1.4 netmask 255.255.255.0 && ip r add default via 192.168.1.1 dev eth3"
[email protected]_B1:/tmp/home/root#
[email protected]_B1:/tmp/home/root#  /sbin/udhcpc -i eth3 -p /var/run/udhcpc0.pid -s /tmp/udhcpc -t1 -T5
-A0 -O33 -O249 && ifconfig eth3 192.168.1.4 netmask 255.255.255.0 && ip r add default via 192.168.1.1
dev eth3
udhcpc: started, v1.25.1
udhcpc: sending discover
udhcpc: sending select for 192.168.1.4
udhcpc: lease of 192.168.1.4 obtained, lease time 43200
[email protected]_B1:/tmp/home/root#
[email protected]_B1:/tmp/home/root#
[email protected]_B1:/tmp/home/root# ip r
10.0.0.0/24 dev br0  proto kernel  scope link  src 10.0.0.1
192.168.1.0/24 dev eth3  proto kernel  scope link  src 192.168.1.4
127.0.0.0/8 dev lo  scope link
default via 192.168.1.1 dev eth3
[email protected]_B1:/tmp/home/root# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=56 time=31.913 ms
64 bytes from 8.8.8.8: seq=1 ttl=56 time=93.550 ms
 

heysoundude

Very Senior Member
Glad you've sorted it out. Was going to ask what the Netgear whatchamahoozit is, but now we don't need to know
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top