1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Asterisk connect: AP mode (accesible) vs. wireless Router mode (non accesible)

Discussion in 'Asuswrt-Merlin' started by fullspam, Mar 16, 2020.

  1. fullspam

    fullspam New Around Here

    Joined:
    Feb 17, 2020
    Messages:
    6
    Hi,
    I have been testing during one month asterisk installed in debian via chroot and it has been working like a champ, but now I found and issue, and in depite I have read some post about nat, iptables and ports nothing works.

    What I have working:
    1. internet ->
    2. ISP cable modem ->
      • serving dhcp (192.168.1.1)
      • + ddns client
      • + nat rules to 5060 & 10000:20000 to 192.168.1.2
    3. ac56u as AP with fix ip 192.168.1.2
      • with asterisk installed in debian chroot.
      • Iptables in ac56u opening 5060 and 10000:20000
    If I'm coonected top ISP cable modem or ac56u I can conect to asterisk users. All ok

    What I'm trying (NOT working)
    1. internet ->
    2. ISP with DMZ to 192.168.1.2 ->
    3. ac56u as wireles router
      • static ip wan 192.168.1.2, GW 192.168.1.1
      • serving dhcp in lan (192.168.10.1)
      • + ddnsclient
      • + asterisk
      • + nginx (port 85; in ac56u I change management port, and in virtual server I have forward to 80 and it works)
      • Same iptables opening 5060, 10000:20000 and now 85 for nginx.
      • vpn server accesible in merlin gui (next step ;)
    As you can see, I tried ac56u to do all the work because I don't want to expend time next time ISP provider changes its router (only assing DMZ).
    In adition, working as AP looses VPN menu from merlin, so I'm interesting in manage asterisk from "wireless router" mode

    As "wireles router" I have nginx working (access from outside to ddns url)
    but I am not able to register any account in asterisk. I have tried to change localnet=192.168.10.0/255.255.255.0 and externhost=ddns url in sip.conf, change iptables from -I to -A, forward port inside merlin menu to the same IP.... but nothing

    In resume: sitching from AP to wireless router makes asterisk non accesible. I think is a isssue with port warding, but I don't find it.

    What I'm loosing? any ideas?