Astrill applet disappeared from router? Getting error message when trying to reinstall.

  • ATTENTION! You'll notice a Prefix dropdown when you create a thread. If your post applies to one of the topics listed, please use that Prefix for your post. When browsing the thread list you can use the Prefix to filter the view.
  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Jiend

New Around Here
Hi there,

I apologize if this has been posted previously, I did a few searches and couldn't find any similar results. I set up my home wifi with integrated VPN at home a few weeks ago and it worked like a charm, had to google around a couple times to figure out the exact procedure (SSH instead of Telnet, etc), but all in all it worked great. Skip to last week and I leave for holidays with the girlfriend for a week, turn off the power at home. We just got back, I turned everything back on and... the Astrill applet is gone. I think to myself no biggie I'll just reinstall it, but now when I run the command (which is: eval `wget -q -O - http://astroutercn.com/router/install/112530/d61xxxxxxxxxxxxxxxxx [removed some of the last digits just in case it's something I shouldn't share]) I get this in Xshell:

'eval' is not recognized as an internal or external command,
operable program or batch file.

I googled this and found a "solution" online which said to first run bash, then run eval, but bash gives me the same message (except it says 'bash' is not recognized of course).

I'm not sure how to fix this and thought this would be a good place to ask. It might be something silly that I missed but I didn't have this issue at all last time around. Any help would be greatly appreciated!
 

Jiend

New Around Here
Ok I'm an idiot indeed. It was a simple matter of not having logged in to the router with Xshell, duh. I will leave this post up just in case anyone else is dumb enough to make this mistake so they can find this and troubleshoot.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top