1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Asus AC-5300 (Asus Merlin) and Portal Wifi

Discussion in 'ASUS AC Routers & Adapters' started by jdaguru, Dec 25, 2018.

  1. jdaguru

    jdaguru New Around Here

    Joined:
    May 28, 2018
    Messages:
    2
    Thank you all for reading this first off. Here is what I am attempting to accomplish and wanted some opinions and data points around then best approach to a solution. Here is my goal: With using what I have already can i configure and setup a solid wifi network.

    What I have:

    1 Asus AC-5300 running Asus Merlin
    1 Portal Wifi (I use as another access point)
    1 Pi-Hole (dns server)
    1 (gigabit internet connection)
    1 hard wired home with cat 6

    my media panel is in the closet of the master bedroom on the opposite end of the rectangle home. There is a hardwire connection in the other end of the home where I wanted to have the Portal Wifi (turned into an AP)

    What I Have done:

    (Main) Asus AC-5300 - DHCP - Asus Merlin (custom config file to ensure any new client is assigned the pi-hole address)
    (AP2) Portal Wifi - In bridge mode (no ability to set channels for wifi, able to split bands SSID) hardwired into the main unit (ethernet backhaul)
    (AP1) (main) Asus AC-5300 wifi (matching the channels to portal for each 5ghz and 2.4ghz)
    Pi-Hole is hardwired and set as a static DNS (local)

    What I Notice:
    - Not able to use wifi calling consistently if i have the AP2 on and apart of my network.
    - I see a decrease in performance, from 500down over wifi to 100 over wifi.
    - I am not able to notice some data from my pi-hole as its giving info on the portals activity not the clients that are connected through the portal.
    - Some of my smart home devices have been dropping off intermittently when the AP2 is a part of the network.

    What I am wondering:
    Is there a configuration I can do to ensure the handing off of the two broadcasts or help make the AP talk better with the Main Router?
    Is there a better way to help my pi-hole dns server understand clients that are connected to the AP?
    Is there a way that I can ensure that supported devices prefer the 5ghz signal over the 2.4?

    Thank you all again for your thoughts on this. At the moment I have run into a bit of a blocker in my knowledge of wireless networking and was hoping that some one could share some advice or at least some thoughts to help.
     
  2. OzarkEdge

    OzarkEdge Very Senior Member

    Joined:
    Feb 14, 2018
    Messages:
    1,224
    Location:
    USA
    It is possible that the router WiFi and AP Wifi are interfering, causing reduced throughput and dropped client connections(?). Try setting the router WiFi to channels not used by the AP. But this may be troublesome if the Portal AP changes channels automatically.

    OE
     
    HuskyHerder likes this.
  3. jdaguru

    jdaguru New Around Here

    Joined:
    May 28, 2018
    Messages:
    2
    I have tried that. the portal wants to run in dfs zone due to the congestion of living in downtown a lot of signals around me. the clients do not switch to the nearest signal.
     
  4. OzarkEdge

    OzarkEdge Very Senior Member

    Joined:
    Feb 14, 2018
    Messages:
    1,224
    Location:
    USA
    I would set the router WiFi to ssid RT-50, n/ac mixed, 20/40/80 MHz, channel Auto, Auto; and ssid RT-24, n-only, 20 MHz, channel Auto (do not hide any ssids). And disable Airtime Fairness for each band. And consider tweaking Roaming Assistant RSSI for each band to encourage router wireless clients to switch to the AP at the point where the AP signal is stronger/less negative dBm power than the router signal (this Android app or similar can help you to determine this).

    And set the AP WiFi to ssid AP-50 and ssid AP-24 and hope it chooses channels that do not conflict with the router WiFi.

    Then configure your wireless clients to connect to the preferred ssid/band (RT-50, RT-24, AP-50, AP-24). Configure any client wireless connection settings available to restrict their connection choice to the preferred ssid/band. The wireless client ultimately decides where to connect.

    And then hope for the best. Or replace the AP with an RT-AC86U AiMesh node.

    I think you'll need to establish a stable, working network first before resolving any other issues with specific clients/services.

    OE
     
    Last edited: Dec 26, 2018