What's new

ASUS AC-RT68U Aidisk File Structure Read Only

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
Welcome all. First time posting! What a great website full of valuable information!

I am posting to find out how people have set up a successful USB storage device over WAN. I have files I don't particularly wish to have stored over a public service cloud storage service. I am trying to set up the Aidisk with limited success. I have used the most recent ASUS and Merlin Firmware. I have the 8 GB USB flash drive installed, and have successfully set up a mapped network drive accessed via HTTPS WAN. I can see and copy files stored on the USB drive, but that's where I run into problems.

The disk seems to be read only, similar to this previous post:


What I can do:

1. Add a folder; however, once a folder is added, it becomes read only like all of the other file folders on the USB Drive
2. Copy files from the drive and save them locally to my computer

What I can't do

Upload files via windows file explorer (files can only be uploaded through the webpage, not ideal for my needs). I get a windows error 0x8007002 when trying to paste files. I think this error relates to username/password problems. I am using the admin username/password in windows to access the USB drive which has write privileges.

Has anyone else had similar problems or found a fix to using the file explorer to move files on and off the USB storage?

Thanks in advance.
I've got the same issue, and until I found this thread I had no idea that it was a common problem on Asus routers. I've got the same router and firmware as you. I've had the same thing happen twice now, where I initially setup the drive and am able to read and write from multiple Windows computers (7 & 10), it works fine for a few weeks until suddenly the drive becomes read only. That happened to me the first time a couple of years ago, I spent a bunch of time trying to troubleshoot, but didn't make any progress (I'd assumed it was a Windows issue and not Asus). I finally gave up and disconnected the drive. Then a couple months ago I decided to try again. Connected the drive and after a little fiddling I got it working again with read/write permissions from 3 different computers. Worked for about 5 weeks and then stopped again, and I've not been able to get it working since.

I'd like to use this as a File History drive with Windows 10, so workarounds like just use FTP are not really practical. Is there a way to get this working again more reliably?
This thread has given me better search terms to use, so I've come across a bunch of threads from 2009 on forward with similar issues, but not much in the way of common solutions. While going through my parts bin, I also found that I had a 2TB external HD that I've never used. So, I thought I might try from scratch to set something new up. Are there some best practices for getting an external drive hooked up to my router to behave nicely with Windows?

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!