Asus AC1900 advice wich router is better?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

bennieboy

New Around Here
Hello guys, I'm quite a noob with this. And could use some good advice.

I've been searching and reading around. But cant really seem to find the answer that i'm looking for..
I got myself an asus rt-ac1900. Wich was advised by Nordvpn. And it was a fair price.
Only when i got to work i found out my speed went from 250Mbit to just 20Mbit.
After searching around and reading apparantly this is just normal with this model ?
I've read that i could better use the rc-ac86u but what speeds can achieve with this model ?
I've been testing the openvpn connections on my pc and the max i get is about 50Mbit.
With another vpn provider.. Apparantly i can not choose protocols in the nordvpn windows application..
So i'm wondering what speed i will get on the ac86. As i understood the ac86 has AES wich the ac1900 does not have ?

Also i was advised to get a router wich support IKEv2 ? IPSec ?
But a routershop advised me a router wich is almost 400 euro's..
I dont mind if the speed slows down to somewhere between 50 / 100. Its just for my tv / playstation / phone.
My computer stays connected to the normal router.
So i'm looking for a router wich is in a fair price and can get me the speed that i like to have.

Hope somewhere here can give me good advice
Thanx.
 

ColinTaylor

Part of the Furniture
The RT-AC86U should be able to achieve over 200 Mbps using OpenVPN. But if you're only getting 50 Mbps using a PC VPN client that might indicate that is the most you can get from your VPN provider (unless your PC is very low spec or the server is a long way away).

I get about 50 Mbps using my RT-AC68U and NordVPN.
 

bennieboy

New Around Here
When i use the Nordvpn app on the PC, i can get about 200Mbit connected to the closest server.
But i guess its using another protocol than openvpn then. I do have an old pc.
Connected to openvpn udp on the pc with Surfshark i get about 50Mbit.

I have kept trying out what speeds i can get on the router. But max what i about can get is 25Mbit.
 

ColinTaylor

Part of the Furniture
When i use the Nordvpn app on the PC, i can get about 200Mbit connected to the closest server.
But i guess its using another protocol than openvpn then.
You can choose what protocol to use in the settings. OpenVPN UDP or TCP, and NordLynx.
 

bennieboy

New Around Here
I found it :)
With Nordlynx i get up to 200Mbit.
With Openvpn about 80Mbit, On the pc.
If i can get the same result 80Mbit on a router its fine.
 

bennieboy

New Around Here
Well actually i brought the router back today at the local store. And replaced it with the RT-AC86U

Connected the router to the closest vpn server.
And got 150Mbit :D
Now i'm just wondering if its usefull to put merlin firmware on it ? Have been reading about it that it makes the performance of your router better ?
And i also need to check out the wifi on the wifi i just get about 10/20 Mbit
 

L&LD

Part of the Furniture
It may if he chooses the number of the VPN connection to use an unused core. :)
 

bennieboy

New Around Here
I managed to put the merlin firmware on the router.
Wasnt that difficult. But now i cant seem to connect to the vpn.

Sep 18 21:23:58 acsd: acs_set_chspec: 0x1009 (9) for reason APCS_CSTIMER
Sep 18 21:38:49 rc_service: httpd 1249:notify_rc start_vpnclient1
Sep 18 21:38:50 ovpn-client1[15073]: Options error: You must define CA file (--ca) or CA path (--capath)
Sep 18 21:38:50 ovpn-client1[15073]: Use --help for more information.
Sep 18 21:38:50 openvpn: Starting OpenVPN client 1 failed!

This is my log.
And this is my setup.
Do the keys and certificate also have to be filled in?


nord1.jpg
nord2.jpg
nord3.jpg
 

RMerlin

Asuswrt-Merlin dev
Do the keys and certificate also have to be filled in?
Yes.

With NordVPN, all you have to do is import their .ovpn file, then re-enter your username and password.
 

bennieboy

New Around Here
No matter what i try. I can not get it to work..
Every time i'm getting the same message. Error configuration. And when i check the log file the same thing about CA file.

Nordvpn mentioned opening the ovpn file and put the CA line beginning and end inside Certificate Authority. I tried that but also doesnt work.
When the settings are applied the CA field is empty again. And i get the same message.
 

bennieboy

New Around Here
After going up and down with the firmware.
Going back to original, and to merlin again i got it to work finally :)
Now only would like to figure out what the best settings are ? If someone could advice me in the right direction :)
 

L&LD

Part of the Furniture

Have a look a the M&M Config guide (link in the last two paragraphs above) for a good baseline settings.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top