What's new

Asus AX6000 no LAN devices through switch after 388.2 Update

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Regular Contributor
I have an Asus AX6000 that was running factory firmware with an unmanaged switch (Trendnet TEG-S82G) as the only hardwired device into the 2.5 LAN port.

I’m not sure it matters but I have an asus AC87R with Wi-Fi off connected to the switch basically functioning as another switch.

I will also note I have a docsis 3.1 modem (no Wi-Fi) connected to the AX6000.

I’ve had zero issues with this setup.

I installed Merlin 388.2 on top of the regular firmware and the only change I made to the configuration was I enabled Cake in QOS and I setup with the Docsis option and left everything else default.

Since then twice I’ve noticed my LAN devices will not show up in my network devices list.

My switch is showing the lights and seems to be on but nothing connected can connect to the internet and the router does not report they are there even though on each device it’s showing the router IP.

I narrowed down the issue to the switch as if I unplug the switch for ten seconds and plug back in everything immediately connects.

I do not run scripts because I don’t know how. I am not running any VPN’s. I am using trend micro and using most options like DDOS mitigation.

I’m sure I’m leaving a lot out here but from my perspective everything worked, I installed Merlin (which I’ve used on older routers since the dark knight router days) and enabled cake and the issue started.

At this point I’m not sure if there’s looping or what but would appreciate some pointers or suggestions.

I can definitely try that but wanted to also clarify I installed 388.2 Merlin on Wednesday morning and enabled Cake for Docsis. That Immediately caused the LAN issue the first time. At that time I hadn't narrowed the issue down yet and restarted everything and got it working. Everything worked for around 29 hours from Wednesday to later in the evening on Thursday when on one of my devices I got a random ethernet disconnected message while using that device and that's when I discovered restarting only the switch resolved the issue.

Thusfar the issue has been intermittent.

Also to clarify: Modem > AX6000 > Switch with multiple devices >AC87R as a switch on another floor with additional devices. AC87R is bridged, Wi-Fi off.
No issues whatsoever with Wi-Fi with any device that connects to Wi-Fi.

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!

Members online