Asus dsl ac68u connection drops


New Around Here
Hi! Hope everyone is well :)

I'm not entirely sure if this is the right place to post this, but I really need some advice/help and I'm not entirely sure how to go about troubleshooting this.

I have a dsl ac68-u, I thought maybe flashing the latest Merlin build may help but the problem keeps persisting, I am currently on 384.17_0-gnuton1. I do have about 28 devices connected to the router (use home assistant, mostly wifi switches, bulbs etc) and also have adgaurd running as a DNS server on a laptop connected via ethernet to the router. In my Wan setting I have connect to DNS automatically, and have the IP of the laptop set as the DNS server in the LAN - DHCP Server settings. I have a shirtty adsl line from my ISP. I did talk with my ISP initially about all this, they tried messing with my SNR and eventually said that these issues were all on my side and not due to the line.

The problem essentially is that the internet connection keeps dropping multiple times of the day. When it does happen the wifi devices stay connected but there is no internet. The DSL link goes down and then comes back up again. Then when I hover over the internet status icon it says connected but remains greyed out. To fix it all I have to do is go into wan settings, don't change anything and just hit apply at the bottom and then the internet comes back and the internet status icon goes green. I've been doing this at least once a day for the last year..!! Any help/pointers in how to troubleshoot this would be much appreciated... there are the logs from the router during a time it went down and I had to click apply on the wan settings to bring it back up again:

These are the logs
(on pastebin)

Any advice/pointers on how to troubleshoot this further would be greatly appreciated!


Occasional Visitor
This sounds similar to a problem I had with my DSL-AC68U last year (post about it here) which will hopefully be useful.

A few questions that might help find the cause and/or resolution...
  1. From your post it appears this became a problem before you flashed with the GNUton Merlin firmware and that at some point before it became a problem it had worked?
  2. Did you try setting the DNS to fixed on the router to your ISP recommended and/or Google and does the problem persist if you remove the LAN-DHCP DNS setting to point to the laptop for DNS?
  3. What is your SNR/Line Attenuation? What connection do you have e.g. FTTC? How far are you from the exchange?
If you're using adguard primarily/only to block adverts there are alternative solutions you can try, for example amtm/Diversion, which may do what you need while removing the need to serve DNS from the laptop.

There is actually a thread on the forums about adguard/diversion here and a search might yield other results that might help.
Last edited:


Part of the Furniture
I think you're running an older @GNUton RMerlin fork on your router?

You may be willing to try either the 384.19 build or even the alpha/beta builds he is working on for the 386.1 code base instead.


Senior Member
Testing the latest alpha firmware will allow you to test the latest ASUS firmware (even newer then the publicly availabe from the asus website).
Beside that I do not think it will help you. My feeling here it's that something hardware is not right or something on the ISP side.
Of course trying a different router would be great test.

The datalink between the two routers somehow gets terminated. The Link Control Protocol (LCP) which continuosly keep the connection between the ISP and the router somehow ends.

I have found an interesting thread which says that the problem related to dhcp and reassigning IP. Please read the last comment in this thread

The other thing which I wanna highlight from your logs is.. the fact your modem completely loses the DSL signal.
Jan 25 07:21:37 DSL: Link up -> down
Jan 25 07:22:47 DSL: Link down -> up
You can achieve that by deattaching the cable, isn't it? have you checked if your line/cable/sockets are fine?

noah way

Regular Contributor
I had a similar problem with an AC68U set up as a repeater. The connection would intermittently drop several times a day. The eventual fix was reverting to an older Asus firmware. Couldn't hurt to try ...

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!