What's new

ASUS DSL-AC68VG bridge mode issues

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

czaki

Occasional Visitor
Hello Everyone,

I was searching the forum if anyone had a similar problem but without success so I hope you can help me. I have a VDSL2 internet connection and I am currently using an ASUS DSL-AC68VG modem router to connect to the internet. Since my coverage was not good enough for the apartment I live in I wanted to extend my network with an additional router. Since the existing device is not capable of AiMesh and I came across a very good deal, I purchased two ASUS RT-AC86U routers. My plan was to switch the modem router to bridge mode and hook one of the new routers to it and set up a PPPoE connection to use the internet. I want to use the other RT-AC86U as an AiMesh node while turning the wireless function off on the DSL-AC68VG.

I have followed the steps of the guide here but unfortunately, they do not work. No matter what I do, the new router is not able to connect to the internet. What I have found interesting is that some of the options are seemingly missing from my device or at least they are different.
  • The Service Unit line is missing, but I have WAN Connection Type where I can select Bridge
  • I have no IPTV STB port option under the IPTV settings
  • There is no Remove VLAN TAG from WAN setting
I have tried the steps shown in this video but no luck either. I know it is for a different device but I was surprised that it is so much different compared to what I have on my router admin page.
  • If I try to set up a second PVC setting with the same VLAN ID I receive an error message that "Duplicate or same VLAN ID settings with PVC 1."
  • When I am trying the above the radio buttons for 802.1Q are inactive
  • The IPTV settings are completely different on my device compared to what I can see in the video
Is there something that I might be doing wrong? I would be really surprised if this router cannot be set up into bridge mode. I would like to benefit from the VPN capabilities of the RT-AC86U and the AiMesh feature while avoiding double NAT too.

I would appreciate if you could help me with any advice in troubleshooting this issue. Thank you in advance!
 
I can't help you with DSL-AC68VG configuration, but...

- RT-AC86U is End-Of-Life model now and with bad reliability history
- AiMesh can be configured as AiMesh in AP Mode to your DSL-AC68VG

1717810304325.png
 
This screenshot link below is for a different model (DSL-AC88U), but do you have this config available on the DSL-AC68VG?
(ignore the 802.1q VLAN ID section, as that should be setup in the RT-AC86U if the ISP requires it)
I've seen statements posted that say don't change an existing WAN connection, add a new one and set it to bridge.

Then in the RT-AC86U -
Set the WAN Connection Type to PPPoE
Set the Username and Password for your connection
Set the VLAN ID if needed in LAN – IPTV tab
 
I can't help you with DSL-AC68VG configuration, but...

- RT-AC86U is End-Of-Life model now and with bad reliability history
- AiMesh can be configured as AiMesh in AP Mode to your DSL-AC68VG

View attachment 59278

Thanks, I know it is an EOL model but the price I got the two devices for was good enough not to worry about not having the latest model. :) My internet connection is not the fastest with being 175 Mbit/s and in reality, only around 140-150 is achieved so it did not seem justified to have a new AX model with modem and AiMesh functionality.

Configuring it as an AiMesh router in AP mode will be an option for sure, but in that case, I lose the ability of connecting to a VPN network with the RT-AC86U as most of the features are disabled, right? I have tried using the DSL-AC68VG as a VPN client but due to CPU limitations it is extremely slow, so it is not a suitable option for me. I know I have an option to install OpenVPN on my devices separately, but for the smart TVs this is not feasible.
 
Thank you for your advice. This is how the DSL-AC68VG WAN settings look like. If I try to add a new Bridge connection besides the existing WAN I cannot leave the VLAN ID empty and it does not allow me to use the same number either, which is weird. I do not have a toggle to enable or disable a PVC setting, both shows being enabled no matter what.

dsl-ac68vg_wan_settings.jpg


The IPTV setting for the DSL-AC68VG are the following.

dsl-ac68vg_iptv_settings.jpg


I have an option to set up the IPTV values manually for the RT-AC86U. I tried yesterday to add the VLAN ID to the Internet line while leaving the LAN Port 3/4 empty as the modem router is connected to the other router with the WAN port of the latter. My ISP does require it and I wonder why no such option is available via the PPPoE menu.

rt-ac86u_iptv_settings.jpg
 
If I try to add a new Bridge connection besides the existing WAN I cannot leave the VLAN ID empty

Disable 802.1q on the DSL-AC68VG - no VLAN tagging needed there.

and it does not allow me to use the same number either, which is weird.

I know that single-digit VLAN IDs aren't supported on the DSL-AC68U when it's in Ethernet WAN (EWAN) mode as they're reserved for system use, so perhaps there's a similar limitation on the DSL-AC68VG in bridge mode.

I tried yesterday to add the VLAN ID to the Internet line while leaving the LAN Port 3/4 empty as the modem router is connected to the other router with the WAN port of the latter.

On the RT-AC86U, in LAN - IPTV set the "Manual Profile" Internet VID VLAN ID as required.
Ensure you're connecting the specified bridge port of DSL-AC68VG (e.g. LAN 1 as in screenshot) to the WAN port of the RT-AC86U.
 
Disable 802.1q on the DSL-AC68VG - no VLAN tagging needed there.



I know that single-digit VLAN IDs aren't supported on the DSL-AC68U when it's in Ethernet WAN (EWAN) mode as they're reserved for system use, so perhaps there's a similar limitation on the DSL-AC68VG in bridge mode.



On the RT-AC86U, in LAN - IPTV set the "Manual Profile" Internet VID VLAN ID as required.
Ensure you're connecting the specified bridge port of DSL-AC68VG (e.g. LAN 1 as in screenshot) to the WAN port of the RT-AC86U.

In parallel to your post I have found the original thread where the screenshot you embedded was coming from. The OP there had the same solution with disabling 802.11Q in the PVC settings of the modem router and adding the VLAN ID in the IPTV section of the new device. It worked for me as well, I got a WAN IP, thank you very much! :)

Just a couple of more questions before making this setup permanent.
  • I plan to turn the wireless function of the modem router off to avoid interference, in such case, how I can reach the admin page of that device?
  • Do I need to set anything special up in order to manage the port forwarding rules on the RT-AC86U, now that is behind a modem router supposedly in bridge mode?
  • Should I disable the DHCP server on the DSL-AC68VG?
  • How can I be ensured that double NAT is not happening in this case?
Thanks again, I am really happy that there is a potential way forward for this problem. :)
 
Last edited:
I plan to turn the wireless function of the modem router off to avoid interference, in such case, how I can reach the admin page of that device?

What is the IP address of the DSL-AC68VG?
What is the IP address of the RT-AC86U?
 
What is the IP address of the DSL-AC68VG?
What is the IP address of the RT-AC86U?

Well I am still at the initial setup, so no final IP layout was made. Normally I keep my routers that are on the same network in an ascending order starting from 192.168.1.1 and the DHCP server starts to lease IPs from 192.168.1.100. But in this case, I am unsure how the modem router will get an IP if there will be two DHCP servers running on each device, or only on the RT-AC86U.

Is there a way to make a setup for the above? Or should I leave a standalone wireless network running on the modem router and toggle the on/off switch of the device if I need to access it?
 
Is there a way to make a setup for the above?
Assuming the RT-AC86U is on default of 192.168.1.1

Plan a) Same subnet
Change the DSL-AC68VG to LAN address of 192.168.1.2 or 192.168.1.254 or whatever suits you (ensure it's outside the router's DHCP range).
When bridged, you can access the DSL-AC68VG by temporarily connecting an additional ethernet cable between the bridged modem and the RT-AC86U, LAN to LAN.

Plan b) Different subnet
Change the DSL-AC68VG to 192.168.0.1 for its LAN management address
b.i) Extra cabling and NIC change way -
When bridged, one way to access it is to temporarily connect an additional ethernet cable between the bridged modem and the RT-AC86U, LAN to LAN.
Then give your computer's network interface/NIC an address in the same subnet range as the modem (e.g. 192.168.0.2 if modem was using 192.168.0.1 as its management address).
Then you can access the modem from a web browser on your computer using the 192.168.0.1 address.
Once you've finished accessing the modem's UI then revert the NIC and cabling changes.
b.ii) No extra cabling/NIC change way -
Access the RT-AC86U using telnet/SSH, then enter the below "ifconfig" command -
Code:
ifconfig $(nvram get wan0_ifname):0 192.168.0.2 netmask 255.255.255.0
The above command creates a second WAN interface on the router, and gives that interface an address that's within the bridged-modem's subnet.
You can then access the modem from a web browser on your computer using the 192.168.0.1 address.
This route only lasts until the next router boot.

Plan b.ii) gives easy access.

Or should I leave a standalone wireless network running on the modem router and toggle the on/off switch of the device if I need to access it?
No need to have the DSL-AC68VG wireless enabled.
 
Assuming the RT-AC86U is on default of 192.168.1.1

Plan a) Same subnet
Change the DSL-AC68VG to LAN address of 192.168.1.2 or 192.168.1.254 or whatever suits you (ensure it's outside the router's DHCP range).
When bridged, you can access the DSL-AC68VG by temporarily connecting an additional ethernet cable between the bridged modem and the RT-AC86U, LAN to LAN.

Plan b) Different subnet
Change the DSL-AC68VG to 192.168.0.1 for its LAN management address
b.i) Extra cabling and NIC change way -
When bridged, one way to access it is to temporarily connect an additional ethernet cable between the bridged modem and the RT-AC86U, LAN to LAN.
Then give your computer's network interface/NIC an address in the same subnet range as the modem (e.g. 192.168.0.2 if modem was using 192.168.0.1 as its management address).
Then you can access the modem from a web browser on your computer using the 192.168.0.1 address.
Once you've finished accessing the modem's UI then revert the NIC and cabling changes.
b.ii) No extra cabling/NIC change way -
Access the RT-AC86U using telnet/SSH, then enter the below "ifconfig" command -
Code:
ifconfig $(nvram get wan0_ifname):0 192.168.0.2 netmask 255.255.255.0
The above command creates a second WAN interface on the router, and gives that interface an address that's within the bridged-modem's subnet.
You can then access the modem from a web browser on your computer using the 192.168.0.1 address.
This route only lasts until the next router boot.

Plan b.ii) gives easy access.


No need to have the DSL-AC68VG wireless enabled.

Thank you so much! I will give option b.ii) a quick go as it should provide an easy access, I hope I will be able to make it work. I am not often restarting the router so it can be an almost permanent solution for me.

On the other hand, if I choose a) at the end, can I leave the LAN to LAN connection in place for good between the two routers, or it must be temporary as it will cause problems?
 
A little update, I have tried option b.ii) and the command went through OK, but still I am unable to access the modem router using the IP address I have set up before (192.168.0.1). A direct LAN to LAN connection did not work either.
 
A little update, I have tried option b.ii) and the command went through OK, but still I am unable to access the modem router using the IP address I have set up before (192.168.0.1). A direct LAN to LAN connection did not work either.
The "plan b.ii)" method was the same one I used for years to get access to the GUI of my bridged single-port Draytek Vigor130 modem (that was up until three months ago, I'm on a fibre connection now so no longer a need for a bridged xDSL modem).

Try this -
Connect an ethernet cable between the bridged modem and your computer.
Give your computer's network interface an address of 192.168.0.2
Then access the modem using the 192.168.0.1 address.
Revert the NIC and cabling changes once you've finished accessing the modem's UI.
 
The "plan b.ii)" method was the same one I used for years to get access to the GUI of my bridged single-port Draytek Vigor130 modem (that was up until three months ago, I'm on a fibre connection now so no longer a need for a bridged xDSL modem).

Try this -
Connect an ethernet cable between the bridged modem and your computer.
Give your computer's network interface an address of 192.168.0.2
Then access the modem using the 192.168.0.1 address.
Revert the NIC and cabling changes once you've finished accessing the modem's UI.

This one unfortunately will not work. The modem is in the living room and I am using a desktop PC in the other side of the apartment. Do I need to set anything further up with the telnet method, or just push the code to the RT-AC86U and use 192.168.0.1 in my browser (e.g. manual IP setup on the computer, etc.)? I have connected the LAN1 port of the modem with the WAN port of the other router (the latter has a dedicated one, the modem router identifies LAN4 as WAN), could that be the issue? Also DHCP is not turned off in the DSL-AC68VG.

So far what I have done is to set up a standalone wireless network in the modem router as a backup solution. I have a button on the front of the device that I can use to turn the wireless radio on or off. Currently it is off, but worst case I can use this if I need to change any setting or perform troubleshooting on it. It is a bit difficult to get to the DSL-AC68VG as I have hung it up on the back of the lowboard in the living room which is directly at a wall, but I guess a little exercising never hurt anybody. 😅
 
Do I need to set anything further up with the telnet method, or just push the code to the RT-AC86U and use 192.168.0.1 in my browser (e.g. manual IP setup on the computer, etc.)?
Nothing further. Does a "route" command show the 2nd WAN interface -
Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
...
192.168.0.0     *               255.255.255.0   U     0      0        0 eth0

So far what I have done is to set up a standalone wireless network in the modem router as a backup solution.
That should be workable, as likely you'll not need to access the modem all that often, mainly just to check on DSL line sync.
 
Nothing further. Does a "route" command show the 2nd WAN interface -
Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
...
192.168.0.0     *               255.255.255.0   U     0      0        0 eth0

Well it does show, both not as eth0 like in your case, but with vlan7, see below. Is this a problem?

route.jpg
 
I don't know enough about this. Do you have any "eth0" interfaces? Why is the 192.168.102.0 i/face being listed? What i/face is your ISP's Gateway address listed against? Similar for the DNS address?

I have no clue about 192.168.102.0, definitely I have not set it up on purpose. Here is the full picture after the route command to the RT-AC86U. I am no expert, more a power user when it comes to networking so I might have reached my limits in investigating this, but I am always happy to learn more. 🤓

route_2.jpg
 
Here is the full picture after the route command to the RT-AC86U.

Okay, must be a difference between my IPoE and your PPPoE.

Try this instead -
WAN - Internet Connection
In section "WAN IP Setting" -
Get the WAN IP automatically: No
IP Address: 192.168.0.2
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.0.1

That's how I did it many moons ago when on ADSL & PPPoA. I believe that technique still works for PPPoE connections.
 
Okay, must be a difference between my IPoE and your PPPoE.

Try this instead -
WAN - Internet Connection
In section "WAN IP Setting" -
Get the WAN IP automatically: No
IP Address: 192.168.0.2
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.0.1

That's how I did it many moons ago when on ADSL & PPPoA. I believe that technique still works for PPPoE connections.

On the DSL-AC68VG, correct?
 

Latest threads

Support SNBForums w/ Amazon

If you'd like to support SNBForums, just use this link and buy anything on Amazon. Thanks!

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top