What's new

Release ASUS GT-BE98 Pro Firmware version

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

From https://rog.asus.com/networking/rog-rapture-gt-be98-pro/helpdesk_bios/ :

ASUS GT-BE98 Pro Firmware version
66.99 MB

New Features:
Introduced AURA Night Mode.
Added Multi-link Operation (MLO) network in Guest Network Pro.
Added automatic WAN/LAN detection feature.
* Please note: After updating to this version, main WiFi encrytpion will be upgraded to GCMP-256 for higher security, please refer to https://www.asus.com/support/faq/1053342/ for more information and setup suggestions.

Bug Fixes and Performance Enhancements:
Enhanced connectivity for WiFi 7 devices.
Fixed client binding issues on AiMesh nodes.
Resolved AiMesh node broadcast issues in Guest Network Pro.
Corrected Link Aggregation UI errors.
Fixed Guest Portal bugs.
Improved AiMesh system stability.
Addressed DNS errors affecting internet access for Guest Network Pro and VPN connections.
Resolved the issues of WireGuard client profile names.
Fixed dual WAN and VLAN 4094 IoT issues.

Security Updates:
Fixed code execution in custom OVPN.
Fixed command injection vulnerability.
Fixed the ARP poisoning vulnerability. Thanks to the contribution of Xin'an Zhou.
Fixed code execution in custom OVPN. Thanks to the contrubution of Jacob Baines.
Fixed the injection vulnerability in AiCloud.
Fixed stack buffer overflow in lighttpd. Special thanks to Viktor Edstrom.
Fixed CVE-2023-35720, CVE-2023-48795, CVE-2023-41913
Fixed the code execution vulnerability in AiCloud. Thanks to the contribution of chumen77.
Fixed the XSS and Self-reflected HTML injection vulnerability. Thanks to the contribution of Redfox Cyber Security.

Please unzip the firmware file, and then verify the checksum.
SHA256: 05b73788261502f5ab92fe2c4df3821de04707d0e57b439bab32704a194a3d2b

I had to do a full factory reset after upgrade. DOT would not work. After the rest it worked for a while but then again stopped working. Just odd. Any settings in DOT will simply not connect. I tried google, cloudflare, cleanbrowsing.
Last edited:
After some troubleshooting I ended up finding out that if you turn off the guest netowrk pro default IOT network it breaks DOT. I guess I'll do a feedback to asus. This caused some headache! If I turn it back on then DOT work fine with MLO enabled.


Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!