What's new

ASUS Merlin 388.2.2 Authentication Error / Timeout Issue

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

Gizmo2035

New Around Here
Hi there,

I have a reoccurring issue where my Open VPN to US server for my Smart TV using VPN director drops out due to an authentication error. DNS config set to exclusive.

Strangely enough my Open VPN for all other devices to an Australian server doesn't have this issue. DNs config set to strict.

Any assistance is greatly appreciated.

Router: ASUS RT-AX86U
Merlin Firmware versions: 388.2.2

Here us an extract from the sys log where the error occurs
May 22 06:53:54 ovpn-client1[28413]: Validating certificate extended key usage
May 22 06:53:54 ovpn-client1[28413]: ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication
May 22 06:53:54 ovpn-client1[28413]: VERIFY EKU OK
May 22 06:53:54 ovpn-client1[28413]: VERIFY X509NAME OK: CN=us9684.nordvpn.com
May 22 06:53:54 ovpn-client1[28413]: VERIFY OK: depth=0, CN=us9684.nordvpn.com
May 22 06:53:54 ovpn-client1[28413]: Control Channel: TLSv1.3, cipher TLSv1.3 TLS_AES_256_GCM_SHA384, peer certificate: 4096 bit RSA, signature: RSA-SHA512
May 22 06:53:54 ovpn-client1[28413]: [us9684.nordvpn.com] Peer Connection Initiated with [AF_INET]185.211.32.207:1194
May 22 06:53:54 ovpn-client1[28413]: TLS: move_session: dest=TM_ACTIVE src=TM_INITIAL reinit_src=1
May 22 06:53:54 ovpn-client1[28413]: TLS: tls_multi_process: initial untrusted session promoted to trusted
May 22 06:53:55 ovpn-client1[28413]: SENT CONTROL [us9684.nordvpn.com]: 'PUSH_REQUEST' (status=1)
May 22 06:53:56 awsiot[14093]: awsiot init : basic data publish success
May 22 06:54:00 ovpn-client1[28413]: SENT CONTROL [us9684.nordvpn.com]: 'PUSH_REQUEST' (status=1)
May 22 06:54:01 ovpn-client1[28413]: AUTH: Received control message: AUTH_FAILED
May 22 06:54:01 ovpn-client1[28413]: ovpn-route-pre-down tun11 1500 0 10.8.0.6 255.255.255.0 init
May 22 06:54:01 ovpn-client1[28413]: Closing TUN/TAP interface
 

Attachments

  • Screen Shot 2023-05-26 at 18.42.15.png
    Screen Shot 2023-05-26 at 18.42.15.png
    175.9 KB · Views: 57
  • Screen Shot 2023-05-26 at 18.42.43.png
    Screen Shot 2023-05-26 at 18.42.43.png
    136.8 KB · Views: 56
When you say "drops out" do you mean that it was working and being used and then dropped the connection, or that it doesn't startup at all?

TBH it looks like an issue on the NordVPN side. Try using a different profile from NordVPN.
 

Similar threads

Support SNBForums w/ Amazon

If you'd like to support SNBForums, just use this link and buy anything on Amazon. Thanks!

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top